Jump to content

DCS World / Flamming Cliffs 3 Adding Trees Bug


Ghostrida9
 Share

Recommended Posts

Hey folks, after almost 2 years, i'm back to DSC with the release of DCS World and Flamming Cliffs 3. Even before I played around with the Jets and Graphics, I tryed to figure out how to mod and improve the simulation.

 

There're a few things I want to talk about but I think it's best to create a own Thread for each one since every one is pretty different. I've started to continue my work on my California Landscape mod after a long break so i wanne finish it for DSC since i see the potential of this Sim.

 

So lets start with adding Objects:

 

I figured that the Folder for all the Fortifications is (DCS World\Bazar\Terrain\Structures\High\EDM). Adding some of these Objects that are not listed inside the Mission editor was also pretty simple, you just need to make sure the Original Name of the Model file is correctly written.

 

For Example, Adding one from many Tree files I did the following:

 

1: I open the File db_precountries.lua and added the Following line:

cnt_unit(default_Fortifications, "Trees166 Medium Line");

 

(This file is great cause it will add the Object to all countries inside DSC)

 

2: then I opened the File db_units_ground and added the following line:

fortification( "Trees166 Medium Line", _("Trees166 Medium Line"), "trees_166", 100);

 

"tree_166" is the exact Name of the Model, Trees166 MediumLine is the Name that i used for the Mission editor.

 

Ok, it all worked out, I can place it as a static Object, no matter which country I choose, the Problem is, the Object appears at Sealevel, far bellow the Ground, not like other static Objects which appear correctly on the Ground.:mad::mad::mad::mad:

 

Somebody outhere who can tell me to fix this Problem????

 

Thanks and Hello again..:thumbup:

[sIGPIC][/sIGPIC]



If all real wars could only be fought in DCS..



 

 

Link to comment
Share on other sites

Ok this is funny, I just added a different Tree Row to the Mission editor and now it works.. I don't know why but it seems like that I've solved this Poblem myself. I'll try a few different "Trees" and see what happen. :thumbup:

[sIGPIC][/sIGPIC]



If all real wars could only be fought in DCS..



 

 

Link to comment
Share on other sites

  • 2 weeks later...

Ok, after tryin almost all the "tree" files, I found something strange.

 

All "small " trees (called trees_1.edm up to trees_12.edm) work, they're placed correctly at the Ground, all of these tree files also have a file called trees_1_blk.edm and so on up to trees_10_blk.edm (Don't know if thats important). Open up those Tree files with the Model Viewer shows that you can zoom out as far as you want, the Model is still visible.

 

Now i'm goin to the "bigger" tree files like trees_166.edm up to trees_2047.edm, and all the alleya model files. Something is wrong with these models, They appear on Sealevel beneath the Ground until you zoom out with the Camera, the further I zoom the more they start to "grow" out of the Ground. Also open up these Tree files with Model Viewer show a strange behaviour, when I zoom out the Model start to dissapear? Whats the difference between these files and the small tree files.

 

It can't be something difficult to deal with, someone from ED or somebody willing to help me out with this??

 

Thanks

 

(I'm running the game on low setting just to try out)

[sIGPIC][/sIGPIC]



If all real wars could only be fought in DCS..



 

 

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...