Jump to content

1.28 will not run


windyman56
 Share

Recommended Posts

So I downloaded the latest update today, and made sure that I had my AV turned off, my administrator privileges on, and tried to run the game. First I ran it from the basic desktop launcher, which displayed the regular launcher check, but then it did nothing. Next, I went and ran from the DCS.exe file, which showed the splash screen with version number, but when it went to fullscreen, as if it were running the game, it sat there, completely blank, no music or anything. My specs are as follows:

 

nVidia GTX 650 Ti

8GB Corsair RAM

500GB HDD (Western Digital)

Intel Core i3 2105 3.10 GHz

Windows 7 64 bit OS

Link to comment
Share on other sites

Running the DCS.Exe File directly will result in a black screen.

 

You need to launch the Launcher File or the Updater File.

Windows 10 Pro, Ryzen 2700X @ 4.6Ghz, 32GB DDR4-3200 GSkill,

X470 Taichi Ultimate, 2x R7970 Lightnings Crossfired @ 1.1/6.0GHz,

3x ASUS VS248HP + Hanns·G HZ201HPB + Oculus HMD,

Thrustmaster Warthog HOTAS + MFDs, CH Fighterstick+Pro Throttle+Pro Pedals

Link to comment
Share on other sites

Saved Games\DCS\Logs\me.log

 

=== Log opened UTC 2014-06-18 22:24:05

00000.000 INFO VFS: Using 'Saved Games': "C:\Users\JP\Saved Games"

00000.111 UNKNOWN main: locale: en EN

00000.227 UNKNOWN main: me_db_api creation started

00001.192 UNKNOWN main: MOD loading: Scripts/Database//CoreModules/Modern Units/MQ-9 Reaper/entry.lua

00001.194 UNKNOWN main: MOD loading: Scripts/Database//CoreModules/WWII Units/entry.lua

00001.197 UNKNOWN main: MOD loading: Scripts/Database//CoreModules/WWII Units/FW-190D9.lua

00001.198 UNKNOWN main: MOD loading: Scripts/Database//CoreModules/WWII Units/Views.lua

00001.207 UNKNOWN main: MOD loading: ./mods/aircrafts/A-10C/entry.lua

00001.209 UNKNOWN main: MOD loading: ./mods/aircrafts/Su-25T/entry.lua

00001.211 UNKNOWN main: MOD loading: ./mods/aircrafts/TF-51D/entry.lua

00001.224 UNKNOWN main: MOD loading: ./mods/aircrafts/TF-51D/TF-51D.lua

00001.226 UNKNOWN main: MOD loading: ./mods/aircrafts/TF-51D/Views.lua

00001.228 UNKNOWN main: MOD loading: ./DemoMods/tech/CombinedArms/entry.lua

00001.236 UNKNOWN main: MOD loading: ./DemoMods/aircrafts/A-10A/entry.lua

00001.238 UNKNOWN main: MOD loading: ./DemoMods/aircrafts/A-10C/entry.lua

00001.239 UNKNOWN main: MOD loading: ./DemoMods/aircrafts/F-15C/entry.lua

00001.241 UNKNOWN main: MOD loading: ./DemoMods/aircrafts/Flaming Cliffs/entry.lua

00001.242 UNKNOWN main: MOD loading: ./DemoMods/aircrafts/Ka-50/entry.lua

00001.243 UNKNOWN main: MOD loading: ./DemoMods/aircrafts/Mi-8MTV2/entry.lua

00001.245 UNKNOWN main: MOD loading: ./DemoMods/aircrafts/P-51D/entry.lua

00001.246 UNKNOWN main: MOD loading: ./DemoMods/aircrafts/Su-25A/entry.lua

00001.248 UNKNOWN main: MOD loading: ./DemoMods/aircrafts/Uh-1H/entry.lua

00001.248 UNKNOWN main: PLUGINS START-------------------------------------------------

00001.248 UNKNOWN main: plugin: World War II AI Units by Eagle Dynamics applied

00001.249 UNKNOWN main: plugin: A-10C Warthog by Eagle Dynamics applied

00001.249 UNKNOWN main: plugin: Su-25T by Eagle Dynamics applied

00001.249 UNKNOWN main: plugin: TF-51D Mustang by Eagle Dynamics applied

00001.249 UNKNOWN main: plugin: Combined Arms by Eagle Dynamics applied

00001.249 UNKNOWN main: plugin: Flaming Cliffs by Eagle Dynamics applied

00001.249 UNKNOWN main: plugin: A-10A by Eagle Dynamics applied

00001.250 UNKNOWN main: plugin: F-15C applied

00001.250 UNKNOWN main: plugin: Ka-50 Black Shark by Eagle Dynamics applied

00001.250 UNKNOWN main: plugin: Mi-8MTV2 Hip by Belsimtek applied

00001.250 UNKNOWN main: plugin: P-51D Mustang by Eagle Dynamics applied

00001.250 UNKNOWN main: plugin: Su-25A by Eagle Dynamics applied

00001.250 UNKNOWN main: plugin: UH-1H Huey by Belsimtek applied

00001.250 UNKNOWN main: PLUGINS DONE--------------------------------------------------

00001.295 UNKNOWN main: ./MissionEditor/data/scripts/unitsclasses.lua loaded

00001.300 UNKNOWN main: ./MissionEditor/data/NewMap/classifier.lua loaded

00001.303 UNKNOWN main: me_db_api creation complete

00001.319 UNKNOWN main: GUI Error: [string ".\MissionEditor\modules\Options\DbOption.lu..."]:131: attempt to call field 'createClass' (a nil value)

GUI debug.traceback: stack traceback:

[C]: in function 'createClass'

[string ".\MissionEditor\modules\Options\DbOption.lu..."]:131: in main chunk

[C]: in function 'require'

[string "./MissionEditor/modules/Options/optionsDb.l..."]:2: in main chunk

(tail call): ?

[string ".\MissionEditor\modules\Options\Data.lua"]:142: in function 'load'

[string ".\MissionEditor\MissionEditor.lua"]:209: in function 'loadOptions'

[string ".\MissionEditor\MissionEditor.lua"]:341: in main chunk

stack traceback:

[C]: in function 'createClass'

[string ".\MissionEditor\modules\Options\DbOption.lu..."]:131: in main chunk

[C]: in function 'require'

[string "./MissionEditor/modules/Options/optionsDb.l..."]:2: in main chunk

(tail call): ?

[string ".\MissionEditor\modules\Options\Data.lua"]:142: in function 'load'

[string ".\MissionEditor\MissionEditor.lua"]:209: in function 'loadOptions'

[string ".\MissionEditor\MissionEditor.lua"]:341: in main chunk

00001.319 ALERT LUACOMMON: Error: GUI Error: [string ".\MissionEditor\modules\Options\DbOption.lu..."]:131: attempt to call field 'createClass' (a nil value)

GUI debug.traceback: stack traceback:

[C]: in function 'createClass'

[string ".\MissionEditor\modules\Options\DbOption.lu..."]:131: in main chunk

[C]: in function 'require'

[string "./MissionEditor/modules/Options/optionsDb.l..."]:2: in main chunk

(tail call): ?

[string ".\MissionEditor\modules\Options\Data.lua"]:142: in function 'load'

[string ".\MissionEditor\MissionEditor.lua"]:209: in function 'loadOptions'

[string ".\MissionEditor\MissionEditor.lua"]:341: in main chunk

=== Log closed.

 

Thing is, I repaired it, and even deleted the SavedGames folder for DCS. btw I really enjoy that Lopster song you made haha

Link to comment
Share on other sites

00001.319 UNKNOWN main: GUI Error: [string ".\MissionEditor\modules\Options\DbOption.lu..."]:131: attempt to call field 'createClass' (a nil value)

 

the fix:

http://forums.eagle.ru/showthread.php?t=124577&highlight=factory.lua

"Please delete file factory.lua in \DCS World\dxgui\bind\ folder.

 

Hmm, such a wide-spread issue. And the reason is still unknown.

I will consider adding this fix to the updater. However, in the Steam case, you still will have to apply the fix manually.

 

 

btw I really enjoy that Lopster song you made haha

Thank you for your kind words!

Dmitry S. Baikov @ Eagle Dynamics

LockOn FC2 Soundtrack Remastered out NOW everywhere - https://band.link/LockOnFC2.

Link to comment
Share on other sites

the fix:

http://forums.eagle.ru/showthread.php?t=124577&highlight=factory.lua

"Please delete file factory.lua in \DCS World\dxgui\bind\ folder.

 

Hmm, such a wide-spread issue. And the reason is still unknown.

I will consider adding this fix to the updater. However, in the Steam case, you still will have to apply the fix manually.

 

 

 

Thank you for your kind words!

 

Heh, it worked! Thanks a lot man!

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...