Jump to content

DCS not compatible with Windows version ?


Recommended Posts

I have been working fine for a long time, I go to start DCS world and launcher just spins for a really long time , like 20 min. I reset the computer and now get this message from the GUI or CLI



C:\Program Files\Eagle Dynamics\DCS World\bin>DCS_Updater

This version of C:\Program Files\Eagle Dynamics\DCS World\bin\DCS_updater.exe is

not compatible with the version of Windows you're running. Check your computer'

s system information to see whether you need a x86 (32-bit) or x64 (64-bit) vers

ion of the program, and then contact the software publisher.


Has this happened to anyone ?

Link to comment
Share on other sites

What are your system specs?

Windows 10 Pro, Ryzen 2700X @ 4.6Ghz, 32GB DDR4-3200 GSkill,

X470 Taichi Ultimate, 2x R7970 Lightnings Crossfired @ 1.1/6.0GHz,

3x ASUS VS248HP + Hanns·G HZ201HPB + Oculus HMD,

Thrustmaster Warthog HOTAS + MFDs, CH Fighterstick+Pro Throttle+Pro Pedals

Link to comment
Share on other sites


System Information


Time of this report: 6/13/2014, 11:00:36

Machine name: LEXINGTON

Operating System: Windows 7 Professional 64-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_gdr.140303-2144)

Language: English (Regional Setting: English)

System Manufacturer: BIOSTAR Group

System Model: A770E3

BIOS: Default System BIOS

Processor: AMD Phenom II X4 965 Processor (4 CPUs), ~3.4GHz

Memory: 12288MB RAM

Available OS Memory: 12288MB RAM

Page File: 3254MB used, 21318MB available

Windows Dir: C:\Windows

DirectX Version: DirectX 11

DX Setup Parameters: Not found

User DPI Setting: Using System DPI

System DPI Setting: 96 DPI (100 percent)

DWM DPI Scaling: Disabled

DxDiag Version: 6.01.7601.17514 64bit Unicode



DxDiag Notes


Display Tab 1: No problems found.

Sound Tab 1: No problems found.

Sound Tab 2: No problems found.

Input Tab: No problems found.



DirectX Debug Levels


Direct3D: 0/4 (retail)

DirectDraw: 0/4 (retail)

DirectInput: 0/5 (retail)

DirectMusic: 0/5 (retail)

DirectPlay: 0/9 (retail)

DirectSound: 0/5 (retail)

DirectShow: 0/6 (retail)



Display Devices


Card name: NVIDIA GeForce GTX 750 Ti

Manufacturer: NVIDIA

Chip type: GeForce GTX 750 Ti

DAC type: Integrated RAMDAC

Device Key: Enum\PCI\VEN_10DE&DEV_1380&SUBSYS_84AC1043&REV_A2

Display Memory: 4022 MB

Dedicated Memory: 1974 MB

Shared Memory: 2048 MB

Current Mode: 1680 x 1050 (32 bit) (60Hz)

Monitor Name: ACER X223W (Analog)

Monitor Model: Acer X223W

Monitor Id: ACR0050

Native Mode: 1680 x 1050(p) (59.883Hz)

Output Type: DVI

Driver Name: nvd3dumx.dll,nvwgf2umx.dll,nvwgf2umx.dll,nvd3dum,nvwgf2um,nvwgf2um

Driver File Version: 9.18.0013.3788 (English)

Driver Version:

DDI Version: 11

Driver Model: WDDM 1.1

Driver Attributes: Final Retail

Driver Date/Size: 5/19/2014 22:44:03, 17480432 bytes

WHQL Logo'd: Yes

WHQL Date Stamp:

Device Identifier: {D7B71E3E-50C0-11CF-3F7D-A1A41FC2C435}

Vendor ID: 0x10DE

Device ID: 0x1380

SubSys ID: 0x84AC1043

Revision ID: 0x00A2

Driver Strong Name: oem67.inf:NVIDIA_SetA_Devices.NTamd64.6.1:Section093:\ven_10de&dev_1380

Rank Of Driver: 00E02001

Link to comment
Share on other sites

I am thinking DCS_Updater tried to update itself today , I see the modified date of today. Somehow it corrupted itself . (assuming)


Does someone have the latest DCS_updater.exe file I can get and tray that ?


If I run from c:\pro...\DCS World/run command it works

Link to comment
Share on other sites

I figured it out, it did get corrupted , but I found DCS_updater in a temp file and copied it over


Works now.


From log:

=== Log opened UTC 2014-06-13 14:00:34

INFO : DCS_Updater/ (Windows NT 6.1.7601; Win64; en-US)

INFO : cmdline: "C:\Users\Steve\AppData\Local\Temp\DCS\DCS_updater.exe" --apply selfupdate "C:\Program Files\Eagle Dynamics\DCS World\bin\DCS_updater.exe"

STATUS: Initializing...

INFO : basedir: C:\Program Files\Eagle Dynamics\DCS World\

INFO : Copying C:\Users\Steve\AppData\Local\Temp\DCS\DCS_updater.exe to C:\Program Files\Eagle Dynamics\DCS World\bin\DCS_updater.exe



So I just copied it manually again from C:\Users\Steve\AppData\Local\Temp\DCS\DCS_updater.exe to C:\Program Files\Eagle Dynamics\DCS World\bin\DCS_updater.exe

Link to comment
Share on other sites


  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...