Jump to content

SP vs MP Question


Recommended Posts

If a MP mission functions properly when flown in SP mode but the exact same mission with no changes made fails to function properly when hosted in the DCS master server in MP mode, what can it mean? Is it possible that the master server somehow has the potential to contaminate a mission? What other possibilities are there?

Link to comment
Share on other sites

What's not working?

 

I mean there are some known differences between MP and SP. For example, using triggers to cause aircraft failures works in SP but not MP. Some script statements may not work as expected in MP but do for SP. Possibly others.

Link to comment
Share on other sites

The reason why Mp is different from SP is that a player in SP does not have to be syncronized with the mission since it entered from the start of the mission.

 

In a MP mission, players join a mission that already started. To make a MP mission work you need to update the players with "critical" data from the mission before he entered. Otherwise some functions are not available for the new player.

 

If you syncronize players that join a mission in progress. Then in theory all should be fine.

 

 

[edit]: Might aswell create an example when saying these things. here

 

 

.


Edited by piXel496
Link to comment
Share on other sites

There's several SSE functions that work in SP but not in MP and this discrepancy isn't usually documented in any way. It would save a lot of trouble for mission makers if it would be documented.

 

I couldn't agree more.

Link to comment
Share on other sites

OK, click =&arrFilter_pf[gameversion]=&arrFilter_pf[filelang]=&arrFilter_pf[aircraft]=&arrFilter_CREATED_USER_NAME=deephouse&set_filter=Filter&set_filter=Y"]HERE for a MP mission (Talon's Reach) I have flown numerous times in the past with no problems in MP mode. Since the last update the AI aircraft (Vapor 51 & 61) is working properly when I test it in SP but fails to become active when flying the mission hosted on the MP server. I am not expecting a solution but rather trying to understand if this is another bug introduced by the latest update. Thanks for your replies. This inconsistency keeps me confused.


Edited by Blooze
Link to comment
Share on other sites

Blooze,

Do you mean Vapor1 and Vapor2? Wow they are up there -- 30,000' elevation.

 

The mission start time is 0545 and both of these a/c are Late Start at 0605 on Day 211. They look OK from the mission editor. Are you waiting 20 minutes to see them?

 

OTOH, Bone71 has a Late Start of 0545 on Day 219 -- 8 days later than the mission start time.

 

---

 

There are some events that work in MP but not in SP :)

 

I don't see anything wrong,,, just the 20 minute delay in Vapor1 & -2 before they show up.

 

WC

Visit the Hollo Pointe DCS World server -- an open server with a variety of COOP & H2H missions including Combined Arms. All released missions are available for free download, modification and public hosting, from my Wrecking Crew Projects site.

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...