Jump to content

Problems with Saitek X52 and Windows 8.1


KamiraHusky
 Share

Recommended Posts

Hi all,

 

Newly registered and struggling to type through the hair that I've been pulling out.

 

I'm running Win 8.1 64Bit and I just can't seem to get my X52 (non pro) to work, I plug it in, it powers on for a few seconds and then powers off entirely.

 

The IT Tech in me (my day job), recognizes this as likely a driver issue, and indeed checking device manager I see a yellow ! on "Programmable Root Enumerator" which has the details as being a Mad Catz driver.

 

The device status is: This device is not working properly because Windows cannot load the drivers required for this device. (Code 31)

 

Insufficient system resources exist to complete the API.

 

Trying a scan for hardware changes on right click within device manager powers the device back up again for a few seconds, so I'm pretty convinced it isn't a hardware failure.

 

Looking for any and all assistance with this, I'm slowly going mental here! :joystick:

 

Thanks All

Brrrrt

Link to comment
Share on other sites

Thanks for the replies, in the past I just used the X52 Pro drivers and it worked just fine on my previous Win8 machine.

 

HiJack: My device has been plugged in to every USB port I have, USB2 and 3 ports, headed ports and back panel ports.

 

If it's of any help, looking at the ! device in device manager, the event details read that SaiNtBus has the following:

 

Device ROOT\PROGRAMMING_SUPPORT\0001 had a problem starting.

 

Driver Name: oem15.inf

Class Guid: {678DCF40-E2E6-11D5-8CD5-E960089EA00A}

Service: SaiNtBus

Lower Filters:

Upper Filters:

Problem: 0x1F

Status: 0x0

Brrrrt

Link to comment
Share on other sites

O.P. Hopefully this can help.

 

you'll have to do a regedit. Windows 8.1 is powering off the USB devices. It's in it's new power management. See this thread:

 

http://forums.eagle.ru/showthread.php?t=115816&highlight=windows+usb

 

I have Windows 8.1, and have the Saitek X52, combat rudders, and the Cougar MFD's. I had to make the Windows 8.1 regedit, to stop the O/S from what it thought was inactive USB devices, and thus powering them off.

 

It's working like a champ on my Win 8.1 system. No more flickers!

 

there's also a sequence to install the Saitek stuff. Install drivers, plug in equipment, then install the programming software. Something like that, (a quick search here will show that).


Edited by javelina1
  • Like 1

Gigabyte Z390 Aorus Ultra, i7-9700k (4.9ghz all cores), NH-D15 cooler, 64 GB CL-14 3200mhz RAM, RTX3090FE, Soundblaster Z, Yamaha 5.1 A/V Receiver, 2x 512GB Samsung NVMe, 1x 1TB Samsung NVMe, 2TB Samsung SSD, Win 10 Pro, TM Warthog, Virpil WarBRD, MFG Crosswinds, 43" Samsung 4K TV, 21.5 Acer VT touchscreen, TrackIR, JetSeat KW-908, Reverb G2, Wheel Stand Pro Super Warthog, Phanteks Enthoo Pro Full Tower Case, EVGA 850 P2 PSU, PointCTRL, Buttkicker 2 , K-51 Helicopter Collective Control

Link to comment
Share on other sites

Yea, saitek is a b i t c h until you got it working. Well, I have X52 drivers for Windows 7 but that may not work on Windows 8.1 either. Have you tried to download the drivers again? It may be something wrong with your downloaded packaged files.

 

As a data point, I downloaded whatever were the current drivers (64bit), and they installed fine on my Win 8.1.

Gigabyte Z390 Aorus Ultra, i7-9700k (4.9ghz all cores), NH-D15 cooler, 64 GB CL-14 3200mhz RAM, RTX3090FE, Soundblaster Z, Yamaha 5.1 A/V Receiver, 2x 512GB Samsung NVMe, 1x 1TB Samsung NVMe, 2TB Samsung SSD, Win 10 Pro, TM Warthog, Virpil WarBRD, MFG Crosswinds, 43" Samsung 4K TV, 21.5 Acer VT touchscreen, TrackIR, JetSeat KW-908, Reverb G2, Wheel Stand Pro Super Warthog, Phanteks Enthoo Pro Full Tower Case, EVGA 850 P2 PSU, PointCTRL, Buttkicker 2 , K-51 Helicopter Collective Control

Link to comment
Share on other sites

Hey Jarvelina,

 

Thanks for your input, was very useful, I've now got my X52 powered and staying on, however I've run (predictably) into another issue, when running the driver installer it prompts to plug in the device, which it doesn't detect, leaving me stuck and unable to proceed.

 

Any more advise??

 

 

***EDIT***

 

OK! A bit more googling around and I found that it's a simple case of the SAITEK website sucking pretty hard and only offering the X52 PRO driver from the main drop down, the X52 non pro has to be selected from the Joysticks category drop down. Go figure.

 

Thanks a lot everyone for your input, I think this might well be solved.


Edited by KamiraHusky
Googled!
  • Like 1

Brrrrt

Link to comment
Share on other sites

Hey Jarvelina,

 

Thanks for your input, was very useful, I've now got my X52 powered and staying on, however I've run (predictably) into another issue, when running the driver installer it prompts to plug in the device, which it doesn't detect, leaving me stuck and unable to proceed.

 

Any more advise??

 

 

***EDIT***

 

OK! A bit more googling around and I found that it's a simple case of the SAITEK website sucking pretty hard and only offering the X52 PRO driver from the main drop down, the X52 non pro has to be selected from the Joysticks category drop down. Go figure.

 

Thanks a lot everyone for your input, I think this might well be solved.

 

great news! good to hear you got things squared away. This forum has been awesome, and a lot of helpful folks here.

 

My Win 8.1 rig is running great for DCSW, thanks to their input and guidance.

 

I was first worried about using Win 8.1, but not any more. It's actually been quite solid for all my DCS modules, and BMS. :thumbup:

Gigabyte Z390 Aorus Ultra, i7-9700k (4.9ghz all cores), NH-D15 cooler, 64 GB CL-14 3200mhz RAM, RTX3090FE, Soundblaster Z, Yamaha 5.1 A/V Receiver, 2x 512GB Samsung NVMe, 1x 1TB Samsung NVMe, 2TB Samsung SSD, Win 10 Pro, TM Warthog, Virpil WarBRD, MFG Crosswinds, 43" Samsung 4K TV, 21.5 Acer VT touchscreen, TrackIR, JetSeat KW-908, Reverb G2, Wheel Stand Pro Super Warthog, Phanteks Enthoo Pro Full Tower Case, EVGA 850 P2 PSU, PointCTRL, Buttkicker 2 , K-51 Helicopter Collective Control

Link to comment
Share on other sites

Yeah, I was really worried it'd be an incompatibility or even worse a hardware issue.

 

Now I've just got to try to get my HOTAS mapping sorted out and try to get the money up for a Track-IR!

 

Thanks again, Really appreciate all the help.

Brrrrt

Link to comment
Share on other sites

Yeah, I was really worried it'd be an incompatibility or even worse a hardware issue.

 

Now I've just got to try to get my HOTAS mapping sorted out and try to get the money up for a Track-IR!

 

Thanks again, Really appreciate all the help.

 

TrackIR is practically a must! You'll love it. It took me a little bit of time to acquire the essentials as well. ;)

Gigabyte Z390 Aorus Ultra, i7-9700k (4.9ghz all cores), NH-D15 cooler, 64 GB CL-14 3200mhz RAM, RTX3090FE, Soundblaster Z, Yamaha 5.1 A/V Receiver, 2x 512GB Samsung NVMe, 1x 1TB Samsung NVMe, 2TB Samsung SSD, Win 10 Pro, TM Warthog, Virpil WarBRD, MFG Crosswinds, 43" Samsung 4K TV, 21.5 Acer VT touchscreen, TrackIR, JetSeat KW-908, Reverb G2, Wheel Stand Pro Super Warthog, Phanteks Enthoo Pro Full Tower Case, EVGA 850 P2 PSU, PointCTRL, Buttkicker 2 , K-51 Helicopter Collective Control

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...