Jump to content

Can anyone help me please?


Recommended Posts

Hi all,

 

I'd be really grateful for any help you can give me. I've played Lock On ever since it came out and after an enforced lay off recently returned to it. To date i've never had any serious issues running it but now find it is unplayable due to sudden drops in fps. I'll try and give you the relevant facts as follows:

 

1. Basic specs of my machine are P4 3GHz, 1Gb RAM, x800XT AGP 120Gb HDD with 85% free capacity TIR2 3.13 and X52 using Saiteks config s\w (all joystick commands deleted from Lockon Input).

2. I have not altered anything hardware or driver wise other than trying various Cat drivers from 5.6 upto 6.2

3. I have reformatted my HDD with a fresh install of windows XP home and Lockon up to v1.12 on the downloaded version

4. FPS drops appear random ie not only over cities or when the action hots up. sometimes they're 40 - 50 which is fine but every 20-30 secs they drop to 1 or even total freeze then gradually return

5. I have tried with and without Modman, all combinations of grfx options \ resolutions. I've tried various fps mods

6. Other than Lock on all other applications appear to be running as usual

7. The fps slow down is worse when taxiing or flying low but also happen at high and medium altitudes

 

If you require any more info or a dxdiag then i can provide them

 

One thing i have noticed is in external view i can pan underground \ water which i could never do before - i think this is since v1.12 but may be wrong - see pics below

 

prob_01.jpg

 

Pan down

 

prob_02.jpg

 

And with ships

 

prob_03.jpg

 

prob_04.jpg

 

This is a very simple mission of 1 x Su25 (Me) and 2 x Moliyana escorting 4 x Elyna - nothing else

 

It may be that my PC has a problem that only Lock On shows but if anyone has any ideas i'd really appreciate some help - i'm at my whits end and desperate to resume playing this fantastic sim

 

Many thanks

 

EDIT/ DXDiag attached

DxDiag_150206.txt

Terrier_Sig.jpg
Link to post
Share on other sites

Re: the ability to go 'sub-terrainian' with the camera....

 

Go into your Lock 0n\Config\View folder and open the file 'view.cfg' (not view.lua) with Notepad.

 

Find the line that says 'CameraTerrainRestriction = ' and change the value from 0 to 1.

 

As for the fps drops, before running LOMAC hit 'ctrl-alt-delete' to bring up the Task Manager, click the 'processes' tab and see if there's anything running in the background that would cause the CPU to choke sporadically under the load.

Link to post
Share on other sites
"One thing i have noticed is in external view i can pan underground \ water which i could never do before - i think this is since v1.12 but may be wrong - see pics below"

 

Just write "true" in the "Camera Terrain restriction=false". I don't have lockon here in this comp. but I think it's in the lockon/config/view/view.cfg but you can easily find it out.. it's in one of those config files..

Robbie.

Link to post
Share on other sites

Thanks for the replies guys

 

Find the line that says 'CameraTerrainRestriction = ' and change the value from 0 to 1.

this was already set =1

 

Camera Terrain restriction=false

this line is not in the view.cfg file but i guess u meant't =1

 

bring up the Task Manager, click the 'processes' tab and see if there's anything running in the background that would cause the CPU to choke sporadically under the load.
i'd already explored that option but there's nothing Lock On has the lot. my worry is it's a CPU starting to fail :(

 

Are they when certain things come into the field of vision (even if they're too far away to see)? - Are the FPS terrible looking one way but OK if you look anywhere else?

there is no set pattern other than on the ground and down low it seems more frequent

having thought about myself maybe i got a corrupted download of v1.1 or v1.12 despite reformatting i used these from a backup of the first d/l

i'll try that and report back

Thanks again!

Terrier_Sig.jpg
Link to post
Share on other sites

I had sudden FPS drops when viewing certain direction in LOMAC before. I swiched heat blur off and it never hapened again (may be due to version change as well).

Also have you Norton systemworks 2006? I found it to cause heavy suttering if worm auto protection is on. I have always disabled antivirus autoprotect before entering LOMAC. Make sure antivirus scheduling is not set too frequently. I found recently it had scheduled antivirus check at hours I usualy was playing lomac... "heck what is going on with the HD?!!....oh its the antivirus, sneaky sneaky"

 

Some Trojans also download stuff and intall other trojans on the fly and they drain a surprising amount of resources. You should check that out.

 

Your PC is good enough to handle LOMAC well. So I dont see any reason for your problems if the above is not true.

 

I have discovered something a while ago with 1.11, dunno if its still true but you should check this thread as well:

http://forum.lockon.ru/showthread.php?t=13624

[sigpic]http://forums.eagle.ru/signaturepics/sigpic4448_29.gif[/sigpic]

My PC specs below:

Case: Corsair 400C

PSU: SEASONIC SS-760XP2 760W Platinum

CPU: AMD RYZEN 3900X (12C/24T)

RAM: 32 GB 4266Mhz (two 2x8 kits) of trident Z RGB @3600Mhz CL 14 CR=1T

MOBO: ASUS CROSSHAIR HERO VI AM4

GFX: GTX 1080Ti MSI Gaming X

Cooler: NXZT Kraken X62 280mm AIO

Storage: Samsung 960 EVO 1TB M.2+6GB WD 6Gb red

HOTAS: Thrustmaster Warthog + CH pro pedals

Monitor: Gigabyte AORUS AD27QD Freesync HDR400 1440P

 

Link to post
Share on other sites

Once again thanks guys, I really appreciate the help. i'll forgoe the direct quoting and answer in general

 

I turn off AV when flying, normally i use fsautostart but have tried without.

I turn off all autoupdates AV, Windows etc all the time

I'm as certain as anyone can be that i'm free of malware with regular scans using multiple AV and spyware tools

Turning off heat blur does improve things slightly with slow downs less frequent and less severe

Water to low gives a marginal improvement as well

edit \ Pilotasso, i don't have that option, it looks like an nVidia feature, thnx anyway

 

i'd guess that its 20-25% better but still hard work

 

i noticed another thread about stutter so maybe i've got a bad case of it

what really confuses me is the underground view. i've treble checked my view.cfg file and it has camera terrain restriction =1

 

i'm going to reformat, re-install with fresh downloads tomorrow. i'll let you know

 

Thanks again

Terrier_Sig.jpg
Link to post
Share on other sites

Just a quickie.....go into your 'view.cfg' file and see if this line is there....

 

CameraTerrainRestriction = 1

 

See if that stops the free camera thingy.

 

I wish there weren't so many duplicate commands in the config folder....:rolleyes:

Link to post
Share on other sites
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...