Disable hot plug devices - ED Forums
 


Notices

Reply
 
Thread Tools Display Modes
Old 10-05-2019, 11:22 AM   #1
BIGNEWY
ED Community Manager
 
BIGNEWY's Avatar
 
Join Date: Aug 2011
Location: UK
Posts: 20,001
Default Disable hot plug devices

Hello all,

For those seeing stutter

We added a config option to the OpenBeta 2.5.5.36986

C:\Users\yourname\Saved Games\DCS.openbeta\Config

If you do not have a autoexec.cfg create on using notepad++ or use the one linked below

autoexec.cfg:
Code:
no_device_hotplug = true
If applied, dcs.log should say "Device hotplug disabled!".
This will disable rescanning of input devices in case of hotplug events.

Please let us know if it helps.
Attached Thumbnails
Click image for larger version

Name:	savedgamesconfig.PNG
Views:	2051
Size:	107.4 KB
ID:	218613  
Attached Files
File Type: cfg autoexec.cfg (74 Bytes, 3112 views)
__________________
BIGNEWY
Community Manager Eagle Dynamics
Windows 10 Pro x64, NVIDIA MSI RTX 2080Ti VENTUS GP, INTEL i7 4790K @4.4 GHz( Cooled by H100i ), 32GB DDR3 @1866 , Asus Z97-AR, TM Warthog, Jet provost rudder pedals, VIVE Cosmos

Last edited by BIGNEWY; 10-05-2019 at 04:54 PM.
BIGNEWY is offline   Reply With Quote
Old 10-05-2019, 07:15 PM   #2
goodman.od.ua
Junior Member
 
Join Date: Feb 2019
Posts: 6
Default

Tried this today, had just couple minutes but noticed no stutter at all, seems to be working
goodman.od.ua is offline   Reply With Quote
Old 10-05-2019, 07:17 PM   #3
Devrim
Veteran
 
Devrim's Avatar
 
Join Date: Mar 2011
Location: Turkey
Posts: 4,400
Default

Also thanks a lot for other options in your image.
__________________
I'm done and out - until better DCS coding or a new PC or next life...
See you...
MY MODS
Devrim is offline   Reply With Quote
Old 10-05-2019, 08:08 PM   #4
BIGNEWY
ED Community Manager
 
BIGNEWY's Avatar
 
Join Date: Aug 2011
Location: UK
Posts: 20,001
Default

Quote:
Originally Posted by Devrim View Post
Also thanks a lot for other options in your image.
yes some handy ones there
__________________
BIGNEWY
Community Manager Eagle Dynamics
Windows 10 Pro x64, NVIDIA MSI RTX 2080Ti VENTUS GP, INTEL i7 4790K @4.4 GHz( Cooled by H100i ), 32GB DDR3 @1866 , Asus Z97-AR, TM Warthog, Jet provost rudder pedals, VIVE Cosmos
BIGNEWY is offline   Reply With Quote
Old 10-06-2019, 05:48 AM   #5
Lange_666
Senior Member
 
Lange_666's Avatar
 
Join Date: Apr 2005
Location: Bubblegium
Posts: 1,681
Send a message via ICQ to Lange_666
Default

Could you explain why this could cause stutter?
__________________
System: Win10 Pro 64-bit, CPU: I7-4770K @ 4.5 GHz, Cooling: Corsair H100i, Motherboard: AsRock Extreme4, Video: ASUS Strix 1080Ti OC 11GB, RAM: 32 GB DDR3 G.Skill 2400, SSD's: Samsung EVO 120GB & EVO 250GB, HD: Samsung 1TB, Monitor: Samsung SyncMaster 2443 1920x1200, HOTAS: Warthog with Virpil WarBRD base & CH Pro pedals, TrackIR4, Oculus Rift S.
Personal Wish List: A6 Intruder, Vietnam theater, decent ATC module, higher FPS!
Lange_666 is online now   Reply With Quote
Old 10-06-2019, 07:40 AM   #6
BIGNEWY
ED Community Manager
 
BIGNEWY's Avatar
 
Join Date: Aug 2011
Location: UK
Posts: 20,001
Default

From c0ff ED Team member

Quote:
Originally Posted by Lange_666 View Post
Could you explain why this could cause stutter?
Quote:
Originally Posted by c0ff View Post
Hi!

Thank you for an excellent investigation! Highly appreciated!

There's a high probability that dashost issue is related to the input hotplug functionality of DCS.
I've added a config option to the next OpenBeta.
autoexec.cfg:
Code:
no_device_hotplug = true
If applied, dcs.log should say "Device hotplug disabled!".
This will disable rescanning of input devices in case of hotplug events.
We'll see if this helps.
__________________
BIGNEWY
Community Manager Eagle Dynamics
Windows 10 Pro x64, NVIDIA MSI RTX 2080Ti VENTUS GP, INTEL i7 4790K @4.4 GHz( Cooled by H100i ), 32GB DDR3 @1866 , Asus Z97-AR, TM Warthog, Jet provost rudder pedals, VIVE Cosmos
BIGNEWY is offline   Reply With Quote
Old 10-06-2019, 05:09 PM   #7
Loukuins
Junior Member
 
Join Date: Nov 2017
Location: France
Posts: 31
Default

Gonna try this on my Oculus Rift CV1
__________________
My Setup : i5-4690 3.50GHz + 24GB RAM DDR3 1600MHz + MSI RTX 2060 Super Ventus OC + 2 SSD + 4 HDD + Oculus Rift CV1 + TM T.16000M Hotas
Super Etendard for Life !
Loukuins is offline   Reply With Quote
Old 10-07-2019, 03:58 AM   #8
lastresort77
Junior Member
 
Join Date: May 2018
Posts: 35
Default

Thank you so much! Tonight I had not one stutter in my Rift S after almost 2 months of random stutters then snapping instantly back to 80 fps. DCS is enjoyable again!
lastresort77 is offline   Reply With Quote
Old 10-07-2019, 08:46 AM   #9
c0ff
ED Team
 
c0ff's Avatar
 
Join Date: Mar 2003
Posts: 3,164
Default

Quote:
Originally Posted by Lange_666 View Post
Could you explain why this could cause stutter?
Device drivers issues. For example:
https://stackoverflow.com/questions/...painfully-slow
__________________
Dmitry S. Baikov @ Eagle Dynamics
First LP out NOW at http://c0ff.bandcamp.com (Melodic electronics IDM)
c0ff is offline   Reply With Quote
Old 10-08-2019, 02:57 PM   #10
cabzi
Member
 
Join Date: Oct 2013
Posts: 146
Default

Fingers crossed this will also fix the ”trackir unplugged” issue that has been going on for years.
__________________
i7-6850K | GTX1080 | 32GB DDR4 | Windows 10 Pro
cabzi is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT. The time now is 08:56 PM. vBulletin Skin by ForumMonkeys. Powered by vBulletin®.
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.