TM Warthog - Zoom Friction Slider - ED Forums
 


Notices

Reply
 
Thread Tools Display Modes
Old 08-15-2013, 07:35 PM   #1
Tetra
Member
 
Tetra's Avatar
 
Join Date: May 2009
Location: Nottingham, UK
Posts: 225
Default TM Warthog - Zoom Friction Slider

I currently use the fake friction axis slider on the Warthog throttle for zoom on all ED aircraft I own. One thing that I find a slight annoyance is that the centre detent on the slider does not match the "default" zoom position. I have to also bind the "default" zoom to the Hotas, which although isn't a big deal is a big of a pain.

For example if you zoom in or out using it then return the slider to the notched centre position this is not the same FOV as if you then press NumPad Enter key (default zoom).

Is there anything I can do to match the two so when the slider is in its centre detent it is effectively at the default zoom level ?

Last edited by Tetra; 08-15-2013 at 07:38 PM.
Tetra is offline   Reply With Quote
Old 08-16-2013, 01:48 AM   #2
TheThumper
Member
 
TheThumper's Avatar
 
Join Date: Jul 2009
Location: USA
Posts: 120
Default

You can edit the Server.lua file in your C:\Users\<your account>\Saved Games\DCS\Config\View (please note that you might have to create or copy this file from where DCS is installed and then modify).

The line you are looking to change is something like:
CameraViewAngleLimits = {40.000000,140.000000}, (note I have changed my values already).

This line dictates the minFOV and maxFOV when you zoom in and out. I have modified mine to closely match my default FOV (which, by the way is in the SnapView.lua found in the same directory mentioned).

I haven't done a great job of explaining what to do, but if you search for "FOV" and "Server.lua" there are lots of posts that explain it better, but I hope this points you in the right direction.
TheThumper is offline   Reply With Quote
Old 08-16-2013, 02:59 AM   #3
Tetra
Member
 
Tetra's Avatar
 
Join Date: May 2009
Location: Nottingham, UK
Posts: 225
Default

Hi Thumper many thanks for replying, I presume you are referring to setting the minimum FOV to the default FOV, for example my default snap view FOV is 90 so I set the minimum FOV in server lua to 20.0000,90.0000 however that means I have to use the full travel of the slider and loose any ability to increase my FOV further, not that it's a major problem as I very rarely do it.

On the flip slide to get a fov of 90 at the center detent I would have to increase my min/max to something like 20.0000,200.0000 giving me 90 at the centre point.

Is this what you were referring to? It's a good enough work around if so even if it does take the full travel of the slider to go from default to zoomed in now.
Tetra is offline   Reply With Quote
Old 08-16-2013, 03:17 PM   #4
Intrepid1
Junior Member
 
Join Date: Aug 2011
Location: Ontario Canada
Posts: 95
Default

Tetra
I am using the slider the way you are proposing and what I did was adjust the curves in the Options /Controls /Axis tune panel for Joy slider 1
The dead zone is set to "0" saturation X and Y are set to "100
Slider and user curve at Ticked and the vertical slider numbers across the bottom are 0 29 45 57 65 71 77 83 89 95 100
You may have to adjust these values for your preference but this will get you started without having to mess with the lua's
I hope the pik is ledgable
Randy
Attached Thumbnails
Click image for larger version

Name:	axis adjust.jpg
Views:	295
Size:	61.2 KB
ID:	86202  
Intrepid1 is offline   Reply With Quote
Old 08-16-2013, 06:19 PM   #5
Tetra
Member
 
Tetra's Avatar
 
Join Date: May 2009
Location: Nottingham, UK
Posts: 225
Default

Quote:
Originally Posted by Intrepid1 View Post
Tetra
I am using the slider the way you are proposing and what I did was adjust the curves in the Options /Controls /Axis tune panel for Joy slider 1
The dead zone is set to "0" saturation X and Y are set to "100
Slider and user curve at Ticked and the vertical slider numbers across the bottom are 0 29 45 57 65 71 77 83 89 95 100
You may have to adjust these values for your preference but this will get you started without having to mess with the lua's
I hope the pik is ledgable
Randy
Ah yes! No idea why I never even considered to do it with curves :S lol Managed to get it pretty much spot on in the centre now. Many thanks to both of you for your help
Tetra is offline   Reply With Quote
Old 08-16-2013, 09:10 PM   #6
Intrepid1
Junior Member
 
Join Date: Aug 2011
Location: Ontario Canada
Posts: 95
Default

Tetra; I have received so much help in these forums , I am happy to be a contributor for a change :-)
Randy
Intrepid1 is offline   Reply With Quote
Old 08-16-2013, 10:48 PM   #7
TheThumper
Member
 
TheThumper's Avatar
 
Join Date: Jul 2009
Location: USA
Posts: 120
Default

That is a good idea Intrepid. I will have to incorporate that into my solution as well.
On another note concerning the Zoom Friction Slider, does everyone else get some "wobble" at zoom levels when the friction slider is not at full max/min or in the indent in the middle?
TheThumper is offline   Reply With Quote
Old 08-17-2013, 03:04 AM   #8
Intrepid1
Junior Member
 
Join Date: Aug 2011
Location: Ontario Canada
Posts: 95
Default

-I do get some "wobble" but not near what I was getting with the Saitek system I used to have
Randy
Intrepid1 is offline   Reply With Quote
Old 08-17-2013, 03:48 AM   #9
Tetra
Member
 
Tetra's Avatar
 
Join Date: May 2009
Location: Nottingham, UK
Posts: 225
Default

Quote:
Originally Posted by TheThumper View Post
That is a good idea Intrepid. I will have to incorporate that into my solution as well.
On another note concerning the Zoom Friction Slider, does everyone else get some "wobble" at zoom levels when the friction slider is not at full max/min or in the indent in the middle?
If it's the same thing I think you're referring to it seems to be the LED's on the warthog throttle. Try switch them off with the TARGET GUI software and see if it stops it. If I turn mine off I have zero glitches or wobbling at all.
Tetra is offline   Reply With Quote
Old 08-17-2013, 11:16 AM   #10
Milli
Member
 
Milli's Avatar
 
Join Date: Mar 2011
Location: Shropshire, England, United Kingdom
Posts: 632
Default

It is a known problem with wobbling occuring when the LED's are on. So yes, turn them off to stop it. I think turning them up to maximum will also cure the problem.

Regards,
Milli
Milli is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT. The time now is 03:37 PM. vBulletin Skin by ForumMonkeys. Powered by vBulletin®.
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.