Screen Tearing - ED Forums
 


Notices

Reply
 
Thread Tools Display Modes
Old 07-15-2017, 03:01 PM   #1
cthulhu68
Member
 
cthulhu68's Avatar
 
Join Date: Aug 2016
Location: R'lyeh, The Deepest Depths of the South Pacific
Posts: 856
Reputation power: 5
cthulhu68 is a jewel in the roughcthulhu68 is a jewel in the roughcthulhu68 is a jewel in the roughcthulhu68 is a jewel in the roughcthulhu68 is a jewel in the roughcthulhu68 is a jewel in the roughcthulhu68 is a jewel in the roughcthulhu68 is a jewel in the rough
Default Screen Tearing

I've been having issues with what I guess is screen tearing. Most noticeable on canopy frame when quickly looking side to side. In 2.1 version I only see this when pressing Alt+Enter (testing to see if it helped performance} but I see it in 1.57 version all the time now. I.ve been playing around with all kinds of settings in-game and with Nvidia settings so I'm wondering what settings could affect this or what I could do to get rid of it.
I have an ASUS PB277Q with 1MS response and 75HZ refresh rate.
Computer spec= I7 6700K, GTX 970. 16 gig RAM.
cthulhu68 is offline   Reply With Quote
Old 07-15-2017, 03:02 PM   #2
razo+r
Veteran
 
Join Date: Jul 2014
Posts: 3,015
Reputation power: 13
razo+r is just really nicerazo+r is just really nicerazo+r is just really nicerazo+r is just really nicerazo+r is just really nicerazo+r is just really nicerazo+r is just really nicerazo+r is just really nice
Default

VSync/Gsync or whatever else exists on?
__________________
Maximus VII Ranger, 4790K @ 4.00 Ghz, ASUS GTX 1070 O8G, 16 GB non-oc RAM, 250 GB SAMSUNG EVO 850 SSD, 2TB HDD, Win 10 64-bit
razo+r is offline   Reply With Quote
Old 07-15-2017, 03:08 PM   #3
cthulhu68
Member
 
cthulhu68's Avatar
 
Join Date: Aug 2016
Location: R'lyeh, The Deepest Depths of the South Pacific
Posts: 856
Reputation power: 5
cthulhu68 is a jewel in the roughcthulhu68 is a jewel in the roughcthulhu68 is a jewel in the roughcthulhu68 is a jewel in the roughcthulhu68 is a jewel in the roughcthulhu68 is a jewel in the roughcthulhu68 is a jewel in the roughcthulhu68 is a jewel in the rough
Default

VSync off in-game and Application controlled in Nvidia Panel.

I just tried Vsync on in-game and although it did seem to get rid of tearing it replaced it with an equally annoying "vibrating" effect.

Last edited by cthulhu68; 07-15-2017 at 03:18 PM.
cthulhu68 is offline   Reply With Quote
Old 07-15-2017, 07:19 PM   #4
Art-J
Senior Member
 
Art-J's Avatar
 
Join Date: Jun 2014
Location: Warsaw, Poland
Posts: 2,546
Reputation power: 15
Art-J is just really niceArt-J is just really niceArt-J is just really niceArt-J is just really niceArt-J is just really niceArt-J is just really niceArt-J is just really niceArt-J is just really niceArt-J is just really niceArt-J is just really niceArt-J is just really nice
Default

To avoid tearing, I've always been using adaptive V-sync via drivers (in-game V-sync off), with Alt-Entering to make it work. I agree, however, it doesn't seem to be giving smooth panning after 1.5.7 update (compared to previous version and to 2.1.1 that is), on my GTX1070.

I suspect it's a result of the old renderer not working very well with new features partially ported from 2.1.x. Pity, because 1.5.6 was a rocket compared to 2.1.1, but now Caucasus seems to be running more rough than Nevada for some reason.
__________________
i5 4670K @ 4.4, single GTX1070, 16 gigs of RAM, TH Warthog, MFG Crosswind, Win7 x64.
Art-J is offline   Reply With Quote
Old 07-16-2017, 02:45 AM   #5
cthulhu68
Member
 
cthulhu68's Avatar
 
Join Date: Aug 2016
Location: R'lyeh, The Deepest Depths of the South Pacific
Posts: 856
Reputation power: 5
cthulhu68 is a jewel in the roughcthulhu68 is a jewel in the roughcthulhu68 is a jewel in the roughcthulhu68 is a jewel in the roughcthulhu68 is a jewel in the roughcthulhu68 is a jewel in the roughcthulhu68 is a jewel in the roughcthulhu68 is a jewel in the rough
Default

Using Nvidia V-sync is a big improvement. I always kept V-sync off because I thought it was for V-sync Monitors only, if there is such a thing.
cthulhu68 is offline   Reply With Quote
Old 07-17-2017, 05:40 AM   #6
Lange_666
Senior Member
 
Lange_666's Avatar
 
Join Date: Apr 2005
Location: Belgium
Posts: 1,198
Reputation power: 21
Lange_666 is just really niceLange_666 is just really niceLange_666 is just really niceLange_666 is just really niceLange_666 is just really niceLange_666 is just really niceLange_666 is just really niceLange_666 is just really niceLange_666 is just really niceLange_666 is just really niceLange_666 is just really nice
Send a message via ICQ to Lange_666
Default

There's not such a thing as a V-Sync monitor, only a G-Sync monitor (or Free Sync for AMD). Both are hardware sulutions for V-Sync problems.

Quote:
Originally Posted by cthulhu68 View Post
I just tried Vsync on in-game and although it did seem to get rid of tearing it replaced it with an equally annoying "vibrating" effect.
The "vibrating" effect comes from your FPS dropping below the V-Sync rate.
__________________
Lange,
Air Operations
666th Black Brigade
System: Win10 Pro 64-bit, CPU: I7-4770K @ 4.6 GHz, Cooling: Corsair H100i, Motherboard: AsRock Extreme4, Video: Gigabyte GTX-780 OC WindForce 3GB, RAM: 16 GB
Corsair Vengance 2133, SSD's: Samsung EVO 120GB & EVO 250GB, HD: Samsung 1TB, Monitor: Samsung SyncMaster 2443 1920x1200, HOTAS: Cougar (U2 mod) & CH Pro pedals, TrackIR4
Lange_666 is offline   Reply With Quote
Old 07-17-2017, 09:10 AM   #7
droopy114
Member
 
droopy114's Avatar
 
Join Date: Mar 2014
Location: france
Posts: 407
Reputation power: 6
droopy114 is a jewel in the roughdroopy114 is a jewel in the roughdroopy114 is a jewel in the roughdroopy114 is a jewel in the roughdroopy114 is a jewel in the roughdroopy114 is a jewel in the roughdroopy114 is a jewel in the rough
Default

Quote:
Originally Posted by Lange_666 View Post
The "vibrating" effect comes from your FPS dropping below the V-Sync rate.
Nope, i have the same issue with TIR and DCS. I run DCS on a 144HZ screen, what i've found:

Vsync at 144HZ, testing a solo mission when i'am sure to have a constant 144FPS (and confirmed by the FPS counter): view panning with TIR feel a bit jerky, but playable.

Vsync at 120HZ, 120FPS all the time: view panning with TIR perfectly smooth.

Vsync at 60HZ, 60 FPS all the time: view panning perfectly smooth, but I can notice motion blur, more than on a native 60HZ screen.

Screen at 144HZ, Vsync set to adaptive 1/2 refresh rate, so 72FPS, view panning with TIR is not smooth, but perfect with mouse or keyboard. It's hard to describe in English, but it's like running DCS at 30FPS.
__________________
I5 4690K @4.5Ghz/ 16Gb RAM Gskill @2133 Mhz/KFA² GTX1070/ MSI Z97 Guard-Pro/ HDD/ TIR v4/ Hotas Cougar+Pro Pedal/ Windows 10 64 bits.

French DCS group: http://flying-skulls.forumactif.com/
droopy114 is offline   Reply With Quote
Old 07-17-2017, 01:12 PM   #8
cthulhu68
Member
 
cthulhu68's Avatar
 
Join Date: Aug 2016
Location: R'lyeh, The Deepest Depths of the South Pacific
Posts: 856
Reputation power: 5
cthulhu68 is a jewel in the roughcthulhu68 is a jewel in the roughcthulhu68 is a jewel in the roughcthulhu68 is a jewel in the roughcthulhu68 is a jewel in the roughcthulhu68 is a jewel in the roughcthulhu68 is a jewel in the roughcthulhu68 is a jewel in the rough
Default

I noticed that the V-sync helped but was also causing a hit to performance. I tested the 4 settings and found...

On= Gets rid of tearing but drops FPS by 15 or so
Adaptive= Seemed to do nothing but lower FPS
Adaptive(1/2 refresh rate) = Didn't work as well as On and same FPS loss
Fast= Works as good or better than On and no FPS loss
cthulhu68 is offline   Reply With Quote
Old 07-17-2017, 01:54 PM   #9
Quadg
Junior Member
 
Join Date: Oct 2016
Posts: 74
Reputation power: 1
Quadg will become famous soon enoughQuadg will become famous soon enough
Default

adaptive v-sync does not try to match or sync frames. what it does is reject frames that will tear.

so you get a much faster and smoother sync effect by rejecting unsynced frames. than you do by trying to sync every frame.

i much prefer adaptive v-sync

but im flying in VR now so this is all moot.

you need dcs running in full screen mode for adaptive v -sync to work
so after the game starts press lalt-enter. because even if it looks like its running in full screen mode. it is not..
i have to do this every time for VR too.. or else mouse clicks on cockpit buttons actually click random things on my desktop..
__________________
My Rig: i7 4930k 4.5Ghz, 16GB DDR3 2400, 2x SSD, EVGA 1080 Superclocked, Warthog Throttle and Stick, MFG Crosswinds, Oculus Rift.
Quadg is offline   Reply With Quote
Old 07-17-2017, 02:57 PM   #10
cthulhu68
Member
 
cthulhu68's Avatar
 
Join Date: Aug 2016
Location: R'lyeh, The Deepest Depths of the South Pacific
Posts: 856
Reputation power: 5
cthulhu68 is a jewel in the roughcthulhu68 is a jewel in the roughcthulhu68 is a jewel in the roughcthulhu68 is a jewel in the roughcthulhu68 is a jewel in the roughcthulhu68 is a jewel in the roughcthulhu68 is a jewel in the roughcthulhu68 is a jewel in the rough
Default

I'll try the adaptive modes in full'screen and see how that works. Thx. One question about forcing full-screen. Do I have to start DCS in windowed mode with fullscreen unchecked in-game?

Maybe one day I won't be so confused by all these monitor settings but you are talking with someone who once had a tv/stereo that looked something like this...
Attached Thumbnails
Click image for larger version

Name:	1960 Curtis Mathes Console TV, Radio and Turntable.jpg
Views:	13
Size:	171.0 KB
ID:	165995  
cthulhu68 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT. The time now is 12:44 PM. vBulletin Skin by ForumMonkeys. Powered by vBulletin®.
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.