Problem with roughmet - ED Forums
 


Notices

Reply
 
Thread Tools Display Modes
Old 05-06-2019, 06:04 AM   #1
SWE-Timberwolf
Junior Member
 
SWE-Timberwolf's Avatar
 
Join Date: Jun 2017
Location: Sweden
Posts: 96
Default Problem with roughmet

Hi! I have a little problem with the RoughMet for the TCS and the Pylons. The diffuse layer works just fine but it won’t accept the roughmet. I have checked so the filename matches with the name in the Lua file. Should that layer be named differently to work? I’m not at my computer now so I cannot post the text in the lua file right now. Have anybody had this problem or do you know what I am doing wrong?
__________________
System: MSI Z370 | i7 8700K | 32GB DDR4 | GTX 1080 | TM Warthog | Logitech Pro Flight Rudder Pedals | Oculus Rift S |

Modules: FC3 | UH-1H Huey | SA342 Gazelle | Spitfire | AJS-37 Viggen | F-5E Tiger II | A-10C | M-2000C | AV-8B Harrier | F/A-18C Hornet | F-14 Tomcat | C-101 Aviojet | F-86F Saber | MiG-21 Bis | MiG-19 Farmer| NTTR | Normandie | Persian Gulf |
SWE-Timberwolf is offline   Reply With Quote
Old 05-06-2019, 09:53 AM   #2
SWE-Timberwolf
Junior Member
 
SWE-Timberwolf's Avatar
 
Join Date: Jun 2017
Location: Sweden
Posts: 96
Default

Could it be that the lua file have gotten corrupted? I read some where that editing the lua files with notpad could cause this and that you should use notepad++ instead. Do you think this could be the issue?
__________________
System: MSI Z370 | i7 8700K | 32GB DDR4 | GTX 1080 | TM Warthog | Logitech Pro Flight Rudder Pedals | Oculus Rift S |

Modules: FC3 | UH-1H Huey | SA342 Gazelle | Spitfire | AJS-37 Viggen | F-5E Tiger II | A-10C | M-2000C | AV-8B Harrier | F/A-18C Hornet | F-14 Tomcat | C-101 Aviojet | F-86F Saber | MiG-21 Bis | MiG-19 Farmer| NTTR | Normandie | Persian Gulf |
SWE-Timberwolf is offline   Reply With Quote
Old 05-06-2019, 02:18 PM   #3
watermanpc
Senior Member
 
watermanpc's Avatar
 
Join Date: Dec 2015
Location: Spain
Posts: 2,060
Default

Check a post I made in the skinners thread...is an issue with incorrect file name...it is working for me after changing it...hope they fix it asap...also the Normal map is NOT working no matter what, its name is correct.

https://forums.eagle.ru/showpost.php...&postcount=452

hope it helps!
__________________
i7 6700K@4,5Ghz | GB Z170x-UD3 | GTX 1080ti Gaming X| 32Gb DDR4@3000Mhz | 850 EVO 500Gb (DCS here) + SSD + Barracuda x3 | NOX Hummer M750 | HOTAS WartHog | DIY IR Clip+Opentrack | Win10 64 pro

Take a look at my MODS here
watermanpc is offline   Reply With Quote
Old 05-06-2019, 02:28 PM   #4
SWE-Timberwolf
Junior Member
 
SWE-Timberwolf's Avatar
 
Join Date: Jun 2017
Location: Sweden
Posts: 96
Default

Quote:
Originally Posted by watermanpc View Post
Check a post I made in the skinners thread...is an issue with incorrect file name...it is working for me after changing it...hope they fix it asap...also the Normal map is NOT working no matter what, its name is correct.

https://forums.eagle.ru/showpost.php...&postcount=452

hope it helps!
Thank you! I will try this as soon as I get home :-)
__________________
System: MSI Z370 | i7 8700K | 32GB DDR4 | GTX 1080 | TM Warthog | Logitech Pro Flight Rudder Pedals | Oculus Rift S |

Modules: FC3 | UH-1H Huey | SA342 Gazelle | Spitfire | AJS-37 Viggen | F-5E Tiger II | A-10C | M-2000C | AV-8B Harrier | F/A-18C Hornet | F-14 Tomcat | C-101 Aviojet | F-86F Saber | MiG-21 Bis | MiG-19 Farmer| NTTR | Normandie | Persian Gulf |
SWE-Timberwolf is offline   Reply With Quote
Old 05-06-2019, 05:09 PM   #5
SWE-Timberwolf
Junior Member
 
SWE-Timberwolf's Avatar
 
Join Date: Jun 2017
Location: Sweden
Posts: 96
Default

Quote:
Originally Posted by watermanpc View Post
Check a post I made in the skinners thread...is an issue with incorrect file name...it is working for me after changing it...hope they fix it asap...also the Normal map is NOT working no matter what, its name is correct.

https://forums.eagle.ru/showpost.php...&postcount=452

hope it helps!



I have tested it a bit, but cannot get it to work. My Lua file looks like this, does it look correct?



{"HB_F14_EXT_01", 0 ,"HB_F14_EXT_01",false};
{"HB_F14_EXT_01", ROUGHNESS_METALLIC ,"HB_F14_EXT_01_RoughMet",false};
{"HB_F14_EXT_02", 0 ,"HB_F14_EXT_02",false};
{"HB_F14_EXT_02", ROUGHNESS_METALLIC ,"HB_F14_EXT_02_RoughMet",false};
{"HB_F14_EXT_03", 0 ,"HB_F14_EXT_03",false};
{"HB_F14_EXT_03", ROUGHNESS_METALLIC ,"HB_F14_EXT_03_RoughMet",false};
{"HB_F14_EXT_04", 0 ,"HB_F14_EXT_04",false};
{"HB_F14_EXT_04", ROUGHNESS_METALLIC ,"HB_F14_EXT_04_RoughMet",false};
{"HB_F14_EXT_TAIL", 0 ,"HB_F14_EXT_TAIL",false};
{"HB_F14_EXT_TAIL", ROUGHNESS_METALLIC ,"HB_F14_EXT_TAIL_RoughMet",false};
{"HB_F14_WING_LEFT_01", 0 ,"HB_F14_WING_LEFT",false};
{"HB_F14_WING_LEFT_01", ROUGHNESS_METALLIC ,"HB_F14_WING_LEFT_RoughMet",false};
{"HB_F14_WING_RIGHT", 0 ,"HB_F14_WING_RIGHT",false};
{"HB_F14_WING_RIGHT", ROUGHNESS_METALLIC ,"HB_F14_WING_RIGHT_RoughMet",false};
{"HB_F14_EXT_DROPTANKS", 0 ,"HB_F14_EXT_DROPTANK",false};
{"HB_F14_EXT_DROPTANKS", ROUGHNESS_METALLIC ,"HB_F14_EXT_DROPTANK_RoughMet",false};
{"HB_F14_EXT_PHOENIXRAILS", 0 ,"HB_F14_EXT_PHOENIXPYLONS",false};
{"HB_F14_EXT_PHOENIXRAILS", ROUGHNESS_METALLIC ,"HB_F14_EXT_PHOENIXPYLONS_RoughMet",false};
{"HB_F14_EXT_PYLONS", 0 ,"HB_F14_EXT_PYLONS_01",false};
{"HB_F14_EXT_PYLONS", ROUGHNESS_METALLIC ,"HB_F14_EXT_PYLONS_01_RoughMet",false};
{"HB_F14_TCS", 0 ,"HB_F14_EXT_TCS",false};
{"HB_F14_TCS", ROUGHNESS_METALLIC ,"HB_F14_EXT_TCS_RoughMet",false};
{"HB_F14_EXT_PILOT_HELMET", 0 ,"HB_F14_EXT_PILOT_HELMET",false};
{"HB_F14_EXT_PILOT_HELMET", ROUGHNESS_METALLIC ,"HB_F14_EXT_PILOT_HELMET_RoughMet",false};
{"HB_F14_EXT_RIO_HELMET", 0 ,"HB_F14_EXT_PILOT_HELMET",false};
{"HB_F14_EXT_RIO_HELMET", ROUGHNESS_METALLIC ,"HB_F14_EXT_PILOT_HELMET_RoughMet",false};
{"HB_F14_EXT_PILOT_SUIT", 0 ,"HB_F14_EXT_PILOT_SUIT",false};
{"HB_F14_LOD1_3in1", 0 ,"HB_F14_LOD1_3in1",false};
{"HB_F14_LOD1_3in1", ROUGHNESS_METALLIC ,"HB_F14_LOD1_3in1_RoughMet",false};
}
__________________
System: MSI Z370 | i7 8700K | 32GB DDR4 | GTX 1080 | TM Warthog | Logitech Pro Flight Rudder Pedals | Oculus Rift S |

Modules: FC3 | UH-1H Huey | SA342 Gazelle | Spitfire | AJS-37 Viggen | F-5E Tiger II | A-10C | M-2000C | AV-8B Harrier | F/A-18C Hornet | F-14 Tomcat | C-101 Aviojet | F-86F Saber | MiG-21 Bis | MiG-19 Farmer| NTTR | Normandie | Persian Gulf |
SWE-Timberwolf is offline   Reply With Quote
Old 05-06-2019, 05:42 PM   #6
000rick000
Member
 
Join Date: Oct 2017
Posts: 526
Default

Try this changing the text to a number? It shouldn't matter but "13" is ID for Roughmets. You might want to just double check your file names are spelled correctly. I had this issue with one of mine and I swore up and down that I had it spelled right, turns out it wasn't!


{"HB_F14_TCS", 0 ,"HB_F14_EXT_TCS",false};
{"HB_F14_TCS", 13 ,"HB_F14_EXT_TCS_RoughMet",false};
__________________
Cheers,

Rick
CSEL\CMEL\IFR
Certified Airplane Nut
000rick000 is offline   Reply With Quote
Old 05-06-2019, 05:51 PM   #7
SWE-Timberwolf
Junior Member
 
SWE-Timberwolf's Avatar
 
Join Date: Jun 2017
Location: Sweden
Posts: 96
Default

Quote:
Originally Posted by 000rick000 View Post
Try this changing the text to a number? It shouldn't matter but "13" is ID for Roughmets. You might want to just double check your file names are spelled correctly. I had this issue with one of mine and I swore up and down that I had it spelled right, turns out it wasn't!


{"HB_F14_TCS", 0 ,"HB_F14_EXT_TCS",false};
{"HB_F14_TCS", 13 ,"HB_F14_EXT_TCS_RoughMet",false};
Thanks!
I have tried both text and numbers, same result I’m afraid. I’ll check my filenames again and if that don’t help then I will recreate the lua file.
__________________
System: MSI Z370 | i7 8700K | 32GB DDR4 | GTX 1080 | TM Warthog | Logitech Pro Flight Rudder Pedals | Oculus Rift S |

Modules: FC3 | UH-1H Huey | SA342 Gazelle | Spitfire | AJS-37 Viggen | F-5E Tiger II | A-10C | M-2000C | AV-8B Harrier | F/A-18C Hornet | F-14 Tomcat | C-101 Aviojet | F-86F Saber | MiG-21 Bis | MiG-19 Farmer| NTTR | Normandie | Persian Gulf |
SWE-Timberwolf is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT. The time now is 11:00 AM. vBulletin Skin by ForumMonkeys. Powered by vBulletin®.
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.