Poor VR Performance - Page 4 - ED Forums
 


Notices

Reply
 
Thread Tools Display Modes
Old 03-14-2020, 01:37 PM   #31
Gunnars Driver
Member
 
Gunnars Driver's Avatar
 
Join Date: Dec 2016
Location: Sweden
Posts: 441
Default

Quote:
Originally Posted by Bones308th View Post
Guys, just did a quick night AAR mission with the Viper out of Batumi, and the frame rates were terrible. That’s with today’s update, and the latest NVidia drivers released yesterday. I’m using Windows 10, i9-9900K, NVidia 2080Ti, and the Reverb. Has anybody noticed any drop in VR performance? I also know there was a new update to Steam VR, so I have to check the VR settings and see if there were any changes in settings. I’ll try a day mission tomorrow as well, and report back here. Just wondering if anyone here has noticed any drop in performance. Thanks.

Ray
I might have missed it in the thread, are you using Open Beta 2.5.6 or ?

Did you follow the thuds guide for Reverb setup on vr4dcs.com ?

-I'm asking because there is not only one trap to fall into. Low fps etc might have multiple different causes and deleting shaders might fix one of the issues, not all.

That giude is very good when it comes to the things to do. For example update to latest windows10, 1909.

If you hade Everything running like a Dream, then installed 2.5.6 and got stuck with very low fps...then I really Think this thread is good. If not, I Think following the thuds guide is a good starting point.
__________________
[T.M HOTAS Warthog Stick & Throttle + T.Flight pedals, HP Reverb pro, Oculus Rift]
[DCS Mirage 2K; Huey; Spitfire Mk IX, AJS 37, F-14, F-18, FC3 ]
i9 9900KS@5.2/32Gb@3200/ ASUS ROG STRIX RTX2080ti OC 11Gb @2080Mhz, ASUS ROG STRIX Z390-F , 2Tb m2 NVMe
Gunnars Driver is offline   Reply With Quote
Old 03-14-2020, 01:41 PM   #32
FoxTwo
Member
 
Join Date: Mar 2019
Posts: 315
Default

Quote:
Originally Posted by Pikey View Post
I wonder how many people complain about performance whilst their computers rebuild the shaders during play? Because maybe they updated, launch, headset on and have no idea the dcs.log is chuntering through all the shader compiles for the new lighting effects... see bad performance, try a different terrain and a different aircraft, get the same again, use up their alloted 2 hours of game time a week and log off, rant on the forums about performance and start downgrading to the previous version before the shaders finished? Not saying it's every case, but after I cleaned out my shaders, let DCS settle, run a few cockpits and terrains, patiently, then restarted my computer and ran DCS, it was absolutely fine, for me?

This ain't my first rodeo mate. I've even played around with a 2080ti and I'm not seeing ANY significant difference over a 1080ti. There's something inherently wrong with 2.5.6 particularly with multiplayer in VR causing the GPU to be significantly under utilized (50 to 70% max).
FoxTwo is offline   Reply With Quote
Old 03-14-2020, 03:54 PM   #33
Alec Delorean
Member
 
Join Date: Sep 2009
Posts: 373
Default

@Pikey

Shaders are rebuild during loading, when dcs is started or loading a scenario.
__________________
i9 10920X @4.6GHz, 2080ti OC, 64 GB RAM @3600, Valve Index, HOTAS & Rudder: all Virpil with FFB base mod (G940)
Alec Delorean is offline   Reply With Quote
Old 03-25-2020, 08:43 PM   #34
The_Nephilim
Member
 
The_Nephilim's Avatar
 
Join Date: Nov 2008
Posts: 659
Default

Quote:
Originally Posted by boedha68 View Post
TIP from senior for FPS issues


I updated the new OB update yesterday. I've got half the FPS then normal. And..... everything is back where it was.



First time to load is new compiling so long load times. After that everthing is normal.



Delete User Shaders:
X:\Users\[You]\Saved Games\[DCS User Directory]\fxo\ - DELETE ALL FILES
X:\Users\[You]\Saved Games\[DCS User Directory]\metashaders2\ - DELETE ALL FILES

Delete Terrain Shaders:
X:\...(usually under Program Files)\[DCS Install Directory]\Mods\terrains\[Terrain]\misc\metacache\ - If it's there, DELETE THE "\DCS" folder entirely
Repeat for all terrains you own

Hi I am trying to determine if deleting the DCS Folders under terrain is actually reccomended from ED after a Cleanup, Repair?? I seen no other threads talking about deleting those folders where did you get this information from??
__________________
MSI Z270 SLI MotherBoard / Intel 7600K Kaby Lake @5.0ghz / Coolermaster 212x / 2 - Samsung 960 Evo RAID 0 / Asus 1080GTX OC / Corsair 32GB RAM 3000MHZ XMP PRofile / Samsung Odyssey Plus VR / HOTAS Cougar & MFD's
The_Nephilim is offline   Reply With Quote
Old 03-25-2020, 11:00 PM   #35
cowboy6
Junior Member
 
Join Date: Apr 2019
Posts: 3
Default

Hello
I'm experiencing very poor performance in vr since about 2 months. Here is my hardware:
-rift s
-cpu i5 3470 3,2GHz
-ram 16gb
-gpu rtx 2080 super
-system and DCS installed on a SSD drive


I could have stable 40fps till January/February. Now it is about 20-30fps when I'm close to the ground and 40fps when on hight altitude. I love carrier ops so the pain is that I can't land on a carrier, when a carrier is in sight it's 10-20fps What is stange is that when I pause the game fps goes to stable 40 and when I unpause fps goes back to about 15. I suppose that there is a cpu issue. How can I check if there is a problem with my cpu? Do you also suspect that cpu is the problem here? Any ideas? For now VR is unplayable. Thank you.

Last edited by cowboy6; 03-26-2020 at 10:56 AM.
cowboy6 is offline   Reply With Quote
Old 03-26-2020, 03:49 AM   #36
stuartaston
Senior Member
 
stuartaston's Avatar
 
Join Date: Jan 2009
Location: UK
Posts: 1,007
Default

Quote:
Originally Posted by boedha68 View Post
TIP from senior for FPS issues


I updated the new OB update yesterday. I've got half the FPS then normal. And..... everything is back where it was.



First time to load is new compiling so long load times. After that everthing is normal.



Delete User Shaders:
X:\Users\[You]\Saved Games\[DCS User Directory]\fxo\ - DELETE ALL FILES
X:\Users\[You]\Saved Games\[DCS User Directory]\metashaders2\ - DELETE ALL FILES

Delete Terrain Shaders:
X:\...(usually under Program Files)\[DCS Install Directory]\Mods\terrains\[Terrain]\misc\metacache\ - If it's there, DELETE THE "\DCS" folder entirely
Repeat for all terrains you own
Whilst deleting fxo and metashaders2 will help recompile shaders, deleting terrain shaders accomplishes nothing unless you are replacing them with something else, except providing you a long wait.

This confusion I believe comes from the vr shaders mod, that recommends this as part of the installation, but you only get the benefit *because* there is a change and because the base terrain shaders are not present, which forces them to recompile differently.
__________________


SYSTEM SPECS: Hardware Intel Corei7-9700K @ 5.0 GHz, 32Gb RAM, EVGA 1080ti FTW 11Gb, Dell S2716DG, Thrustmaster Warthog + MFG Crosswinds V2, HP Reverb Pro SOFTWARE: Microsoft Windows 10 Pro x64, VoiceAttack & VIACOM PRO, TacView, CombatFlite

VR Stuff: My DCS VR Settings FPS Bump in VR Shaders MOD for VR Making an IC compliant version of the Shaders MOD
stuartaston is offline   Reply With Quote
Old 03-26-2020, 10:56 AM   #37
cowboy6
Junior Member
 
Join Date: Apr 2019
Posts: 3
Default

Thank you for your reply. Unfortunately this dosn't work for me In non vr gaming I've got about 60-70fps when I'm on a carrier (or when carrier is visible) and 110-140fps in the air. It is strange for me but lowering graphic setting doesn't give me any fps increase. Maybe my cpu is a bottleneck? Any ideas how to check that? Or maybe you have any other ideas? I forgot to mention that I've got my system and DCS installed on a SSD. Thanks in advance.
cowboy6 is offline   Reply With Quote
Old 03-26-2020, 11:04 AM   #38
stuartaston
Senior Member
 
stuartaston's Avatar
 
Join Date: Jan 2009
Location: UK
Posts: 1,007
Default

it's possible it is, if you are running 2.5.6 you are just likely to be facing the pain that is 2.5.6 in its current state... there are many threads on this
__________________


SYSTEM SPECS: Hardware Intel Corei7-9700K @ 5.0 GHz, 32Gb RAM, EVGA 1080ti FTW 11Gb, Dell S2716DG, Thrustmaster Warthog + MFG Crosswinds V2, HP Reverb Pro SOFTWARE: Microsoft Windows 10 Pro x64, VoiceAttack & VIACOM PRO, TacView, CombatFlite

VR Stuff: My DCS VR Settings FPS Bump in VR Shaders MOD for VR Making an IC compliant version of the Shaders MOD
stuartaston is offline   Reply With Quote
Old 03-27-2020, 12:46 PM   #39
cowboy6
Junior Member
 
Join Date: Apr 2019
Posts: 3
Default

Once again thank you for you reply. So I assume that for now I have to wait till ED will try to solve it (maybe in some of the next updates?)?
cowboy6 is offline   Reply With Quote
Old 03-27-2020, 01:58 PM   #40
stuartaston
Senior Member
 
stuartaston's Avatar
 
Join Date: Jan 2009
Location: UK
Posts: 1,007
Default

yep, or roll back to 2.5.5
__________________


SYSTEM SPECS: Hardware Intel Corei7-9700K @ 5.0 GHz, 32Gb RAM, EVGA 1080ti FTW 11Gb, Dell S2716DG, Thrustmaster Warthog + MFG Crosswinds V2, HP Reverb Pro SOFTWARE: Microsoft Windows 10 Pro x64, VoiceAttack & VIACOM PRO, TacView, CombatFlite

VR Stuff: My DCS VR Settings FPS Bump in VR Shaders MOD for VR Making an IC compliant version of the Shaders MOD
stuartaston is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT. The time now is 12:10 PM. vBulletin Skin by ForumMonkeys. Powered by vBulletin®.
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.