Firmware Update - ED Forums
 


Notices

Reply
 
Thread Tools Display Modes
Old 07-08-2019, 07:25 AM   #1
nima2014
Junior Member
 
Join Date: Feb 2017
Posts: 44
Default Firmware Update

Hello everyone,

I thought that I is about time to update the firmware of my VKB Gunfighter MCG Pro.

So I downloaded the newest Vkb config, bootloader and Firmware 1.96F.

I followed the instructions listed here

https://vkbcontrollers.com/?faq=how-...er-mar-15-2018

After Flashing, everything looks normal to me apart that I have and had all the time a solid red stick light while according to the manual it’s supposed to be solid green. But everything shows the correct new firmware and the calibration thereafter is standard as usual and everything works as it should be. After I changed my brake lever axis to a button which these instructions
http://forum.vkb-sim.pro/viewtopic.php?t=2868, the stick light starts flashing green but the everything seems to work normal. Any idea what’s wrong?

I was using:
Vkb dev v0.90.28
Njoy32 Firmware v 1.96.C
Firmware MCG Pro v 1.96F
Bootloader v 1.15
nima2014 is offline   Reply With Quote
Old 07-08-2019, 10:41 AM   #2
Snacko
Senior Member
 
Snacko's Avatar
 
Join Date: Oct 2007
Location: Columbus, Ohio USA
Posts: 1,763
Default

I would not update the firmware unless I had a reason. Surely not just because "it's time". If you have things working how you want, leave it alone. I have updated 3-4 times to fix things. Now it's working great and how I want. Always save your old firmware and flash back if necessary.

Sent from my Moto Z Play using Tapatalk
__________________
Intel I7-6700K 4.00 ghz (OC'ed @ 4.8ghz) ││ Asus Maximus VIII Extreme ││ G.Skill Ripjaws V Series 64GB (4 x 16GB) DDR4 3200 ││ Thermaltake Water 3.0 Ultimate 360MM
GeForce GTX 1080 TI 11gb ││ Corsair 850watt ││ 2x SanDisk 250gb(SSDs Raid0) ││ 2x WD 300gb ││ 1x WD 1tb ││ 3x Acer 28" ││ 1x 28" Touchscreen


- ҉ - Blackshark Cockpit Trainer - ҉ -
-- Thread -- ♥ Download
Snacko is offline   Reply With Quote
Old 07-08-2019, 08:49 PM   #3
VampireNZ
Senior Member
 
VampireNZ's Avatar
 
Join Date: Oct 2013
Location: New Zealand
Posts: 1,437
Default

Make sure you hit the big DEFAULT button following any update. I also had a red light permanently but everything seemed to work fine.

By enabling the DEV option I could see the reason for each LED, and they were all screwed up, so hit default and it reset everything properly and it was all sweet.

Just a suggestion.
__________________
Asus Maximus VIII Hero Alpha| i7-6700K @ 4.60GHz | nVidia GTX 1080ti Strix OC 11GB @ 2075MHz| 16GB G.Skill Trident Z RGB 3200Mhz DDR4 CL14 |
Samsung 950 PRO 512GB M.2 SSD | Corsair Force LE 480GB SSD | Windows 10 64-Bit |
TM Warthog with FSSB R3 Lighting Base | VKB Gunfighter Pro + MCG | TM MFD's | Oculus Rift S | Jetseat FSE

VampireNZ is offline   Reply With Quote
Old 07-09-2019, 12:12 AM   #4
Supmua
Member
 
Join Date: Feb 2018
Location: USA
Posts: 767
Default

Yes, hitting DEFAULT if very important after every update else you can get a stuck button or two. I used to think Thrustmaster's software is hard to use, but the VKB one easily takes the cake.
__________________
PC: 9900K/2080Ti, 32GB RAM.
Joystick bases: TMWx2, VPC WarBRD, VKB GFII, FSSB R3L
Joystick grips: TMW, TM F/A-18, F-16SGRH, Kosmosima LH, MCG, MCG Pro, MongoosT50-CM2
Throttles: TMWx2, Winwing F/A-18
VR: HTC Vive/Pro/Oculus Rift/Valve Index.
Supmua is offline   Reply With Quote
Old 07-09-2019, 05:28 AM   #5
absolut79
Member
 
absolut79's Avatar
 
Join Date: Nov 2003
Location: beer-7
Posts: 110
Default

It’s really hard to guess what went wrong , follow instructions here forum.vkb-sim.pro/viewtopic.php?f=25&t=2762

And please attach snapshots. Sometimes issue is very minor and could be solved in seconds.
__________________
i7 8700K | Corsair Vengeance LPX 32GB| Gigabyte Z370 AORUS Gaming 7 | MSI GeForce GTX 1080 Ti GAMING X TRIO | Samsung 960 PRO Series - 512GB PCIe NVMe
absolut79 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT. The time now is 12:23 AM. vBulletin Skin by ForumMonkeys. Powered by vBulletin®.
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.