TM TPR Issues - Page 4 - ED Forums
 


Notices

Reply
 
Thread Tools Display Modes
Old 06-16-2019, 11:03 PM   #31
captflyby
Member
 
Join Date: Dec 2017
Location: USA
Posts: 182
Default

Quote:
Originally Posted by Guppy View Post
I figured it out Panther - your direction helped with a bit of research on my end. Please find my write-up. I also sent it off to Thrustmaster incase anyone else gets stupidly excited like me and goes rogue.

BEHAVIOR:
When pressing down the break pedals, games and windows only register 50-100% of the axis movement even though the full range is being applied on the physical pedal itself. This causes games to incorrectly register the axis @ 50% all the time unless pressed. Then it cycles from 50 to 100%.

LIKELY CAUSE:
Using Windows default calibration software (Game Controllers) to calibrate the pedals prior to downloading and installing:
1) Drivers from TM website (Package Drivers - Hotas Warthog - 2018_TMHW_1 + Firmware) and
2) Calibration utility (T.RJ12 USB ADAPTER_Calibration tool (v1.11))

Additional detail:
When I initially setup these pedals I immediately plugged them into windows and calibrated there. I tried a game, noticed I had issues... then I went to your website and downloaded #1 and #2 above. I did not follow the printed instructions in your booklet - i went rogue.

HOW TO RESOLVE:
a) Launch the Package Drivers installation software. This will uninstall the TPR Pedals and their associated applications.
b) reboot your PC
c) Launch Windows calibration software (Game Controllers)
d) click on TPR Pedals from the list, click properties, Settings tab, Click Reset to default
e) reboot PC
f) Install #1 and #2 above
g) FIXED

ADDITIONAL NOTE:
If the user has not downloaded and installed #1 and #2 above, but are having issues with axis movements because they only used the windows calibration software (game controllers). Instruct user to follow steps c) through g) above. Essentially they need to wipe their current calibration in windows and start with the drivers/calibration utility.

I have tested this multiple times and have been able to reproduce every single time.



Thanks Guppy, perfect fix. Can't tell you how much time spent trying to figure this out. Thank you for posting!
captflyby is offline   Reply With Quote
Old 05-05-2020, 06:55 PM   #32
MaddHatter
Junior Member
 
Join Date: Sep 2019
Posts: 1
Default

Looking into Purchasing the TPRs. Does anyone know if TM has resolved the issue with linkage with the braking mechanism breaking.
MaddHatter is offline   Reply With Quote
Old 05-06-2020, 08:51 AM   #33
Gruman
Member
 
Join Date: Oct 2010
Location: Switzerland
Posts: 417
Default

Quote:
Originally Posted by MaddHatter View Post
Looking into Purchasing the TPRs. Does anyone know if TM has resolved the issue with linkage with the braking mechanism breaking.
I read about this issue exactly one time. AFAIK this was a single occurence when the pedals launched.

Everybody I know who purchased the TPR (including me) are perfectly happy with them and never had any issues (high expectation considering the price ).
__________________

TM Warthog, VPC T-50 Base, TM TPR, PointCtrl, VRK
Gruman is offline   Reply With Quote
Old 05-06-2020, 08:52 AM   #34
tintifaxl
Senior Member
 
Join Date: Mar 2009
Posts: 2,171
Default

Never had a problem with that.
__________________
Windows 10 64bit, Intel i9-9900@5Ghz, 32 Gig RAM, Palit RTX 2080 TI, 1 TB SSD, 43" 2160p@1440p monitor.
tintifaxl is offline   Reply With Quote
Old 08-01-2020, 03:32 PM   #35
AvgWhiteGuy
Member
 
AvgWhiteGuy's Avatar
 
Join Date: Feb 2015
Location: Shanghai, China
Posts: 289
Default

Regarding Thrustmaster TPR pedals......
I was away for about a month and tonight was practicing landings when I discovered I had no rudder or nosewheel steering. My year old TPRs are suddenly not recognized in DCS when I check the control panel.
Then I discovered they are not recognized AT ALL by my machine. I removed the TPR soft & driver and tried reinstall...NO JOY. My computer, with no significant changes or upgrades, suddenly can't recognize the hardware when plugged in. TM HOTAS and everything else is fine.

Any suggestions and/or help would be greatly appreciated...had my heart set on returning to DCS following my recovery for a hip replacement.

Please....
__________________
Asus B85 Pro Gamer - 32GB - Intel(R) Core(TM) i5-4460 CPU - SanDisk SDSSDXPS480G -Windows 10 Pro 64-bit - NVIDIA GeForce GTX 1070
TrackIR5 - TM Warthog HOTAS Stick & Throttle - TM Cougar MFCDs - TM TPR Rudder Pedals - Razer Orbweaver - SoundBlasterX G5 DAC
AvgWhiteGuy is offline   Reply With Quote
Old 08-01-2020, 04:46 PM   #36
=Panther=
Senior Member
 
=Panther='s Avatar
 
Join Date: Oct 2008
Location: Las Vegas
Posts: 1,039
Default

Check the connection in the back, maybe the cable is disconnected, or maybe try a different cable. It’s the standard printer cable (USB A to B) style.
__________________
Twitch Channel


Virtual Thunderbirds, LLC | Sponsored by Thrustmaster
Spoiler:
Z390 Aorus Xtreme, i9 9900k, G.SKILL TridentZ Series 32GB, 1080ti 11GB, Obutto R3Volution, Thrustmaster HOTAS Warthog, TPR, Cougar MFDs, FSSB R3L, JetSeat, Oculus Rift S, Buddy-Fox A-10C UFC, F/A-18C UFC, Tek Creations F-16 ICP
=Panther= is offline   Reply With Quote
Old 08-01-2020, 06:02 PM   #37
Gruman
Member
 
Join Date: Oct 2010
Location: Switzerland
Posts: 417
Default

Do you see the TPR in the Device Manager? If not, do you have a yellow warning sign with a unknown device?
__________________

TM Warthog, VPC T-50 Base, TM TPR, PointCtrl, VRK
Gruman is offline   Reply With Quote
Old 08-03-2020, 05:28 PM   #38
AvgWhiteGuy
Member
 
AvgWhiteGuy's Avatar
 
Join Date: Feb 2015
Location: Shanghai, China
Posts: 289
Default

@Panther & Gruman....got it sorted, cable and connection was fine, something went FUBAR with drivers. Had to tear out ALL my TM stuff and got it right on the 3rd re-install !

Quite frustrating but back in the air with rudder N/A steering and wheelbrakes.

Thanks for your suggestions and attention....that's why I love this community. Pretty damn boring here in Shanghai without my wings to keep me out of the bar!

Cheers, regards...fly safe
__________________
Asus B85 Pro Gamer - 32GB - Intel(R) Core(TM) i5-4460 CPU - SanDisk SDSSDXPS480G -Windows 10 Pro 64-bit - NVIDIA GeForce GTX 1070
TrackIR5 - TM Warthog HOTAS Stick & Throttle - TM Cougar MFCDs - TM TPR Rudder Pedals - Razer Orbweaver - SoundBlasterX G5 DAC
AvgWhiteGuy is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT. The time now is 09:05 AM. vBulletin Skin by ForumMonkeys. Powered by vBulletin®.
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.