MOOSE - Mission Object Oriented Scripting Framework - Page 114 - ED Forums
 


Notices

Reply
 
Thread Tools Display Modes
Old 06-17-2018, 05:24 PM   #1131
blaueente
Member
 
Join Date: Oct 2014
Location: Germany
Posts: 229
Default

Code:
2018-06-17 15:42:30.082 INFO    SCRIPTING:  10153( 10468)/E:            DATABASE00003.AddGroup({[1]=Add GROUP:,[2]=IRA_CAP MiG-29A #2,})
2018-06-17 15:42:30.082 INFO    SCRIPTING:  10473(  9832)/E:            DATABASE00003._RegisterGroupsAndUnits({[1]=Register Unit:,[2]=Pilot #018,})
2018-06-17 15:42:30.082 INFO    SCRIPTING:  10467(  9832)/E:            DATABASE00003._RegisterGroupsAndUnits({[1]=Register Group:,[2]=IRA_CAP MiG-29A #1,})
2018-06-17 15:42:30.082 INFO    SCRIPTING:  10153( 10468)/E:            DATABASE00003.AddGroup({[1]=Add GROUP:,[2]=IRA_CAP MiG-29A #1,})
A few lines later :

Code:
2018-06-17 15:42:30.126 ERROR   DCS: Mission script error: : [string "C:\Users\BLAUEE~1\AppData\Local\Temp\DCS\/~mis0000361E"]:20532: SPAWN:New: There is no group declared in the mission editor with SpawnTemplatePrefix = 'IRA_CAP'
What now ?!
blaueente is offline   Reply With Quote
Old 06-17-2018, 05:34 PM   #1132
Delta99
Member
 
Delta99's Avatar
 
Join Date: Jan 2017
Posts: 248
Default

Likely you need the full group name not a prefix.

Quote:
Originally Posted by blaueente View Post
Code:
2018-06-17 15:42:30.082 INFO    SCRIPTING:  10153( 10468)/E:            DATABASE00003.AddGroup({[1]=Add GROUP:,[2]=IRA_CAP MiG-29A #2,})
2018-06-17 15:42:30.082 INFO    SCRIPTING:  10473(  9832)/E:            DATABASE00003._RegisterGroupsAndUnits({[1]=Register Unit:,[2]=Pilot #018,})
2018-06-17 15:42:30.082 INFO    SCRIPTING:  10467(  9832)/E:            DATABASE00003._RegisterGroupsAndUnits({[1]=Register Group:,[2]=IRA_CAP MiG-29A #1,})
2018-06-17 15:42:30.082 INFO    SCRIPTING:  10153( 10468)/E:            DATABASE00003.AddGroup({[1]=Add GROUP:,[2]=IRA_CAP MiG-29A #1,})
A few lines later :

Code:
2018-06-17 15:42:30.126 ERROR   DCS: Mission script error: : [string "C:\Users\BLAUEE~1\AppData\Local\Temp\DCS\/~mis0000361E"]:20532: SPAWN:New: There is no group declared in the mission editor with SpawnTemplatePrefix = 'IRA_CAP'
What now ?!
__________________
My Missions: Valley Patrol Mission :: Valley Escort Mission :: A2A Engagements
Delta99 is offline   Reply With Quote
Old 06-17-2018, 05:54 PM   #1133
blaueente
Member
 
Join Date: Oct 2014
Location: Germany
Posts: 229
Default

Thanks Delta99 , now it's working properly. Maybe i dont understand the meaning of the word 'prefix'

Greetings
blaueente is offline   Reply With Quote
Old 06-17-2018, 06:08 PM   #1134
Delta99
Member
 
Delta99's Avatar
 
Join Date: Jan 2017
Posts: 248
Default

Yeah, prefix is a bit misleading in that I believe it was meant to be what the prefix will be when the units are actually spawned. Or its just plain wrong to use Prefix here.
__________________
My Missions: Valley Patrol Mission :: Valley Escort Mission :: A2A Engagements
Delta99 is offline   Reply With Quote
Old 06-18-2018, 01:07 AM   #1135
Swany
Junior Member
 
Join Date: May 2018
Posts: 67
Default

Ok, so back around page 100 and 101 (WAYYYY too many posts to read through to see if anyone answered the questions already) people are talking about the EVENT nil and SPAWN nil errors as well as the Build Modules errors when setting up LDT

1) The Build Modules error, for me, was because of the name of the folder I was telling it Moose was in. MOOSE-2.3.1_-_New_Mark_Events. When I renamed it to just MOOSE-2.3.1, it setup just fine, no issues

2) The EVENT nil and SPAWN nil are happening for me because the MOOSE.LUA included in the MOOSE ZIP file is almost empty. Has like 16 lines of code in it (1k in size). I grabbed the MOOSE.LUA from the GITHUB site (2.6M in size) and now it works fine

If these have already been discovered, just yell at me and I'll delete this post!
__________________
B. "Swany" Swanberg
Dell Alienware R7, i7 8700k @3.7 (not OC'ed) @3696MHz
16GB Mem
nVidia gForce 1080Ti 11GB liquid cooled
3 Dell S2716DG monitors in Surround mode (7680x1440)
Thrustmaster Warthog Throttle and Stick
Thrusmaster Rudder Pedals
assorted button boxes/Arduino boards
All drivers always kept up to day (30 days old, max)
Swany is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT. The time now is 04:03 AM. vBulletin Skin by ForumMonkeys. Powered by vBulletin®.
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.