Disembarking Airborne Troops on ship - ED Forums
 


Notices

Reply
 
Thread Tools Display Modes
Old 05-15-2019, 12:47 PM   #1
DynamicROFL
Junior Member
 
DynamicROFL's Avatar
 
Join Date: Jun 2016
Location: Prague, CZ
Posts: 7
Default Disembarking Airborne Troops on ship

Hi all,

I am trying to make a mission where the player will, using a utility helo, embark troops and then take them to a ship (a carrier in this instance) and then the units will disembark.

It seems that troops will not disembark on a carrier, so I am now trying to make it so the troops embark the player's helo but when the player lands on the carrier, the troop group will deactivate, thus emptying the helo's cargo and displaying a "you did it!" message.

However I can't figure out a good set of triggers to get this to work reliably. I have tried using UNIT INSIDE MOVING ZONE and attaching the zone to the carrier but it didn't work. I have tried using UNIT flight parameters (VERTICAL SPEED, ALTITUDE HIGHER/LOWER THAN, etc) but this also has not worked it seems.

Does anyone have any practical suggestions on how to get this reliably working? Please don't suggest MOOSE, CTLD, or anything of the sort. I have spent hours trying to work with them and understand them and I always come up short. It's much easier for me to just work through triggers--maybe later I will get to understanding those things.

Thank you!
DynamicROFL is offline   Reply With Quote
Old 05-15-2019, 03:01 PM   #2
shagrat
ED Translator
 
shagrat's Avatar
 
Join Date: Oct 2010
Location: Germany
Posts: 10,027
Default

Quote:
Originally Posted by DynamicROFL View Post
Hi all,



I am trying to make a mission where the player will, using a utility helo, embark troops and then take them to a ship (a carrier in this instance) and then the units will disembark.



It seems that troops will not disembark on a carrier, so I am now trying to make it so the troops embark the player's helo but when the player lands on the carrier, the troop group will deactivate, thus emptying the helo's cargo and displaying a "you did it!" message.



However I can't figure out a good set of triggers to get this to work reliably. I have tried using UNIT INSIDE MOVING ZONE and attaching the zone to the carrier but it didn't work. I have tried using UNIT flight parameters (VERTICAL SPEED, ALTITUDE HIGHER/LOWER THAN, etc) but this also has not worked it seems.



Does anyone have any practical suggestions on how to get this reliably working? Please don't suggest MOOSE, CTLD, or anything of the sort. I have spent hours trying to work with them and understand them and I always come up short. It's much easier for me to just work through triggers--maybe later I will get to understanding those things.



Thank you!
Combination of "altitude lower than 150" (feet or m MSL?) with "speed below 1 m/sec" should work on the carrier. You can add "vertical speed below 1 m/sec" if you want. the chance you hover that precise is not very likely, so it's the best you can do without scripts, I think.
__________________
Shagrat

- Flying Sims since 1984 -
Win 10 | i5 7600K@4.0GHz | 32GB | GeForce GTX 1080 8GB - Acer XB280HK 28" 4k | TrackIR5 | Simshaker & Jetseat | TM HOTAS Warthog custom extension | MFG Crosswind Rudder Pedals | TM Cougar MFDs |a hand made UFC | AHCP | 2x Elgato StreamDeck (Buttons galore)
shagrat is offline   Reply With Quote
Old 05-21-2019, 07:21 PM   #3
DynamicROFL
Junior Member
 
DynamicROFL's Avatar
 
Join Date: Jun 2016
Location: Prague, CZ
Posts: 7
Default

Thanks much
DynamicROFL is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT. The time now is 10:50 PM. vBulletin Skin by ForumMonkeys. Powered by vBulletin®.
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.