FPS drops when maneuvering - ED Forums
 


Notices

Reply
 
Thread Tools Display Modes
Old 02-17-2019, 01:34 PM   #1
MiG_Eater
Junior Member
 
Join Date: Feb 2019
Posts: 7
Default FPS drops when maneuvering

Hi everybody, I am relatively new to VR (I have the rift) and still trying to optimise my graphics settings - generally I am able to get a consistent 45fps using ASW, but I tend to get sudden FPS drops for what seems like no reason, it often seems to happen if I make a violent maneuver, but sometimes it seems to happen for no reason at all.


Bear in mind, when launching weapons, external views or flying over cities I normally get a solid 45 fps using ASW. My specs and current settings are below:


CPU: i5 6400
RAM: 24gb DDR4
GPU: GTX 1080

Running everything from an HDD


Graphics settings are:


PD=1.3

Textures = High
Terrain Textures = High
Civ traffic = Low
Water = High
Vis Range = Medium
Heat Blur = Low
Shadows = Low
Res of Cockpit displays = 1024
MSAA = Off
DOF = Off
Lens = None
Motion Blue = Off
SSAA = Off


Clutter = 750
Trees = 90%
Preload 150000 (max)
Chimeny Smoke -= 1
Gamma = 2.2
Anisotropic Filtering = 16x
Terrain Object Shadows = Default
Cockpit Global Illumination = On



Re: my graphics settings - I have tried lots of other options and found them largely the same FPS wise. MSAA and high shadows are a killer, but dropping the options you see below I find virtually no improvement unless i'm in a super busy airfield on the ground.


Any help would be massively appreciated!
MiG_Eater is offline   Reply With Quote
Old 02-17-2019, 02:03 PM   #2
Quadg
Member
 
Join Date: Oct 2016
Posts: 447
Default

change the shadows to flat. lots of shadows when manoeuvring hard.
turn off anisotropic filtering.
set pd to 1.2

and you have the same settings as me.
I also have chimney smoke off because I often only see it in one eye..
__________________
My Rig: i7 4930k 4.5Ghz, 16GB DDR3 2400, 2x SSD, EVGA 1080 Superclocked, Warthog Throttle and Stick, MFG Crosswinds, Oculus Rift.
Quadg is offline   Reply With Quote
Old 02-17-2019, 06:00 PM   #3
MiG_Eater
Junior Member
 
Join Date: Feb 2019
Posts: 7
Default

Thanks Quadg,


Do you have the normal ASW settings and do you get solid 45fps?
MiG_Eater is offline   Reply With Quote
Old 02-17-2019, 06:22 PM   #4
dburne
Veteran
 
Join Date: Sep 2009
Posts: 5,841
Default

I would also lower the trees setting.
__________________
Don B

EVGA Z390 Dark MB | i9 9900k CPU @ 5.1 GHz | EVGA RTX 2080 Ti FTW3 Ultra | 32 GB G Skill Trident Z 3200 MHz CL14 DDR4 Ram | Corsair H150i Pro Cooler | EVGA T2 Titanium 1000w PS | Samsung 970 Pro, 970 Evo 1TB m.2 Nvme |VKB GF Pro MCG Pro| EVGA DG 87 Case |
dburne is offline   Reply With Quote
Old 02-17-2019, 08:31 PM   #5
MiG_Eater
Junior Member
 
Join Date: Feb 2019
Posts: 7
Default

Thanks for the advice guys but no joy!


I tried Quadg's settings with the lowest tree options and got no perceptible improvement.


Then I tried the VR default settings at PD 1.0 and still have almost the exact same frames and the same occasional frame drops.


Any ideas?


My only thought is that it could be my HDD taking time to call up files, and thus could be solved by running off an SSD.
MiG_Eater is offline   Reply With Quote
Old 02-17-2019, 09:57 PM   #6
eaglecash867
Member
 
Join Date: Nov 2010
Posts: 363
Default

Lower your cockpit displays resolution to 256 and see how that works. In VR, I don't find it any more difficult to use the TGP and Maverick sensors with the resolution at its lowest setting.

Also, if you set water to low, and turn clutter completely off, these things should all come together to give you a big boost in performance.

The images in the mirrors will be terrible, and the water won't look as pretty, but I don't spend much time staring at either one.
__________________
ASRock Z370 Professional Gaming i7, Intel i7 8700K Coffee Lake processor @4.7GHz, Corsair H105 Liquid Cooler, G.SKILL Ripjaws V Series 64GB DDR4 3400 memory, ZOTAC GTX1080Ti AMP Extreme 11GB video card, Samsung 840PRO 256MB SSD for Windows 10 64-bit OS, Samsung 850PRO 2TB SSD for program files, LG WH14NS40 Blu-Ray burner. HOTAS Warthog, Saitek Pedals, and Oculus Rift CV1.
eaglecash867 is offline   Reply With Quote
Old 02-17-2019, 11:13 PM   #7
MiG_Eater
Junior Member
 
Join Date: Feb 2019
Posts: 7
Default

Hi Eagle,


Thanks for the advice, but this has not affected things at all. I'm still running a pretty solid 45fps with sudden and unexpected stutters - especially when maneuvering.
MiG_Eater is offline   Reply With Quote
Old 02-19-2019, 12:10 AM   #8
MiG_Eater
Junior Member
 
Join Date: Feb 2019
Posts: 7
Default

OK latest update for those interested -



I have dropped every available graphics settings to the lowest possible, including pixel density and have noticed absolutely no change whatsoever.



I am hoping that the stutters are caused by my HDD taking time to find files. I'll be getting an SSD in a week or two so hopefully this will solve the problem!
MiG_Eater is offline   Reply With Quote
Old 02-19-2019, 05:36 PM   #9
Harlikwin
Senior Member
 
Harlikwin's Avatar
 
Join Date: Nov 2018
Posts: 1,458
Default

Sounds like the HDD/SDD thing might be the issue if thats the case.

Your settings don't seem to be overly ambitious. I'm running a bit lower than you with a worse card and I'm generally ok. My settings are in the low-end vr thread. I do have an SSD tho.
__________________
i7 4720HQ ~3.5GHZ, +32GB DDR3 + Nvidia GTX980m (4GB VRAM) TM Warthog. TrackIR, Rift CV1 (yes really).
Harlikwin is offline   Reply With Quote
Old 02-19-2019, 05:58 PM   #10
=Buckeye=
Senior Member
 
=Buckeye='s Avatar
 
Join Date: Apr 2014
Location: Columbus, OH
Posts: 2,085
Default

Turn "Game Mode" to OFF in Windows settings.

Also, AF doesn't impact FPS at all really, so you can leave it at 16x without any worrying.

Nvidia control panel: Turn to "Prefer Maximum Performance" and VR Pre-Rendered Frames to 3.
__________________
VR Cockpit (link):
Custom Throttletek F/A-18C Throttle w/ Hall Sensors + Otto switches | Slaw Device RX Viper Pedals w/ Damper | VPC T-50 Base + 15cm Black Sahaj Extension + Warthog Grip | JetSeat SE | Super Warthog Wheel Stand Pro | Steelcase Leap V2

VR Rig:
Pimax 5K+ | ASUS ROG Strix 1080Ti | Intel i7-9700K | Gigabyte Z390 Aorus Master | Corsair H115i RGB Platinum | 32GB Corsair Vengeance Pro RGB 3200 | Dell U3415W Curved 3440x1440
=Buckeye= is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT. The time now is 07:45 PM. vBulletin Skin by ForumMonkeys. Powered by vBulletin®.
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.