Confused by auto pilot ATT - Page 5 - ED Forums
 


Notices

Reply
 
Thread Tools Display Modes
Old 01-13-2019, 08:15 PM   #41
Holton181
Senior Member
 
Join Date: Feb 2015
Location: Far north
Posts: 1,074
Default

I really wish @RagnarDA, @Cobra847 or anyone else from the team could chime in on this already!
__________________
Helicopters and Viggen
DCS 1.5.7 and OpenAlpha
Win7 Pro 64bit
i7-3820 3.60GHz
P9X79 Pro
32GB
GTX 670 2GB
VG278H + a Dell
PFT Lynx
TrackIR 5
Holton181 is offline   Reply With Quote
Old 01-13-2019, 09:17 PM   #42
imacken
Senior Member
 
Join Date: Dec 2016
Location: Cornwall, UK
Posts: 1,941
Default

Quote:
Originally Posted by Holton181 View Post
I'm back.
As I said you missed my edit I did at the same time you posted the above.
The reason why you don't seem to be able to make the return-to-course to work whatever you try might be due to your controller. I don't know what you have, but if it doesn't have high resolution and/or have noisy, maybe worn potentiometers and maybe in addition have a centering mechanism that isn't efficient enough to bring it to dead center (and not just to appear to be centered), it would for sure be difficult to get it working. In all my tests all stick deflection has been itsy bitsy tiny even for a high res, noise free controller with a very good centering mechanism. Other than that I have no clue.

Regarding my theory I realized now when trying to find a better explanation for you, I was a bit too fast sharing it. It is only partly explaining what is happening. The rest I haven't figured out yet. I remember from the University that the subject of "automatic control engineering" (what this thread is all about) was considered among the most difficult subjects to wrap your head around. So don't bother to much about my theory for now. Let's just stop at the conclusion it doesn't seem to work as intended.
But I would like to add a thought I forgot to share previously. In my first rest regarding the return-to-course functionality I said it really did return even if not centering the stick. It really did. Then in the second test, where I deflected the stick a bit more and both in pitch and bank, it returned to altitude but not to course. Now why this inconsistency? I really have no clue!
Thanks again for that.
As you can see from my signature, I have a TM HOTAS Warthog, and it works perfectly. There is no problem with my device in centring terms or any other. In any case, with movement less than 7 degrees, the device self levels in the Viggen.
If we put the science to one side, the fact is that this is not working at all for me, and I'm struggling to see how you are getting this drift back on course over a long period of time.
As I said before, I have tried everything to get to work with ATT and it just doesn't. Small (<7 degree which when stick is released auto-level) drifts don't revert, nor do any trim drifts, larger movement, etc. Nothing. I have made 1-2 degree drifts and still no revert.
I am mystified by how you are achieving this. Can you post a video?
__________________
Intel i7 8700 4.8GHz · Palit RTX 2080 Ti OC Gaming Pro · ASUS ROG STRIX Z370-F · Acer 4K 32" XB321HK · Samsung 970 500Gb M.2 NVMe · Samsung 850 Evo 500Gb · 2Tb HDD · 32Gb Corsair Vengance 3000MHz DDR4 · Windows 10 · HOTAS Warthog · TM Pedals · HTC Vive Pro
imacken is offline   Reply With Quote
Old 01-13-2019, 09:45 PM   #43
Holton181
Senior Member
 
Join Date: Feb 2015
Location: Far north
Posts: 1,074
Default

Quote:
Originally Posted by imacken View Post
Thanks again for that.
As you can see from my signature, I have a TM HOTAS Warthog, and it works perfectly. There is no problem with my device in centring terms or any other. In any case, with movement less than 7 degrees, the device self levels in the Viggen.
If we put the science to one side, the fact is that this is not working at all for me, and I'm struggling to see how you are getting this drift back on course over a long period of time.
As I said before, I have tried everything to get to work with ATT and it just doesn't. Small (<7 degree which when stick is released auto-level) drifts don't revert, nor do any trim drifts, larger movement, etc. Nothing. I have made 1-2 degree drifts and still no revert.
I am mystified by how you are achieving this. Can you post a video?
Quote:
Originally Posted by imacken View Post
Thanks again for that.
As you can see from my signature, I have a TM HOTAS Warthog, and it works perfectly. There is no problem with my device in centring terms or any other. In any case, with movement less than 7 degrees, the device self levels in the Viggen.
If we put the science to one side, the fact is that this is not working at all for me, and I'm struggling to see how you are getting this drift back on course over a long period of time.
As I said before, I have tried everything to get to work with ATT and it just doesn't. Small (<7 degree which when stick is released auto-level) drifts don't revert, nor do any trim drifts, larger movement, etc. Nothing. I have made 1-2 degree drifts and still no revert.
I am mystified by how you are achieving this. Can you post a video?
I'm on tapatalk, don't see any signatures. Sorry for that.
Googled a bit for TM HOTAS Warthog and it seems to have excellent 16bit resolution. So not the problem. It has Hall sensors, so noise and worn sensors goes out the window. Can't tell about centering, but I trust you it's not the issue. The only thing I can think of is that I don't look at bank angles per se, but on input values from the stick (DXTweak). I make sure they are as small as possible (300 out of 65536) after I first stabilize. Do you have an extension? As I said earlier I have a basically full length helicopter cyclic (without centering spring but with friction to hold it in place), much easier for tiny stick deflections, and I basically only tapp lightly on it to get the 300 input, can't realy see it on the stick or on the controller helper (RCtrl+Enter). If you don't already have it, or something similar, I recommend you search for a copy of DXTweak try it out.
I have never made a gaming video and have no such software for it, sorry.
__________________
Helicopters and Viggen
DCS 1.5.7 and OpenAlpha
Win7 Pro 64bit
i7-3820 3.60GHz
P9X79 Pro
32GB
GTX 670 2GB
VG278H + a Dell
PFT Lynx
TrackIR 5
Holton181 is offline   Reply With Quote
Old 01-13-2019, 09:51 PM   #44
imacken
Senior Member
 
Join Date: Dec 2016
Location: Cornwall, UK
Posts: 1,941
Default

Quote:
Originally Posted by Holton181 View Post
I'm on tapatalk, don't see any signatures. Sorry for that.
Googled a bit for TM HOTAS Warthog and it seems to have excellent 16bit resolution. So not the problem. It has Hall sensors, so noise and worn sensors goes out the window. Can't tell about centering, but I trust you it's not the issue. The only thing I can think of is that I don't look at bank angles per se, but on input values from the stick (DXTweak). I make sure they are as small as possible (300 out of 65536) after I first stabilize. Do you have an extension? As I said earlier I have a basically full length helicopter cyclic (without centering spring but with friction to hold it in place), much easier for tiny stick deflections, and I basically only tapp lightly on it to get the 300 input, can't realy see it on the stick or on the controller helper (RCtrl+Enter). If you don't already have it, or something similar, I recommend you search for a copy of DXTweak try it out.
I have never made a gaming video and have no such software for it, sorry.
If you are running Windows10 then you have the software. It's just win+g when in game.
EDIT: Just saw your sig. Don't think it works on Win 7.
__________________
Intel i7 8700 4.8GHz · Palit RTX 2080 Ti OC Gaming Pro · ASUS ROG STRIX Z370-F · Acer 4K 32" XB321HK · Samsung 970 500Gb M.2 NVMe · Samsung 850 Evo 500Gb · 2Tb HDD · 32Gb Corsair Vengance 3000MHz DDR4 · Windows 10 · HOTAS Warthog · TM Pedals · HTC Vive Pro
imacken is offline   Reply With Quote
Old 01-13-2019, 10:20 PM   #45
Holton181
Senior Member
 
Join Date: Feb 2015
Location: Far north
Posts: 1,074
Default

Correct
__________________
Helicopters and Viggen
DCS 1.5.7 and OpenAlpha
Win7 Pro 64bit
i7-3820 3.60GHz
P9X79 Pro
32GB
GTX 670 2GB
VG278H + a Dell
PFT Lynx
TrackIR 5
Holton181 is offline   Reply With Quote
Old 01-14-2019, 08:38 AM   #46
QuiGon
Veteran
 
Join Date: Jul 2013
Location: Germany
Posts: 8,359
Default

Quote:
Originally Posted by Holton181 View Post
I really wish @RagnarDA, @Cobra847 or anyone else from the team could chime in on this already!
+1
__________________
Intel i7-4790K @ 4x4GHz + 16 GB DDR3 + Nvidia Geforce RTX 2080 (8 GB VRAM) + Windows 10 64Bit

DCS Panavia Tornado (IDS) really needs to be a thing!

QuiGon is offline   Reply With Quote
Old 01-14-2019, 08:46 AM   #47
imacken
Senior Member
 
Join Date: Dec 2016
Location: Cornwall, UK
Posts: 1,941
Default

Quote:
Originally Posted by QuiGon View Post
+1
I've said that here and on other threads where there are issues and we don't get any help.
I appreciate that the guys are busy, but I see replies from Dagnar on other threads in the last few days.
I don't think it's too much to ask really for some help with this and other issues.
__________________
Intel i7 8700 4.8GHz · Palit RTX 2080 Ti OC Gaming Pro · ASUS ROG STRIX Z370-F · Acer 4K 32" XB321HK · Samsung 970 500Gb M.2 NVMe · Samsung 850 Evo 500Gb · 2Tb HDD · 32Gb Corsair Vengance 3000MHz DDR4 · Windows 10 · HOTAS Warthog · TM Pedals · HTC Vive Pro
imacken is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT. The time now is 01:42 AM. vBulletin Skin by ForumMonkeys. Powered by vBulletin®.
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.