USB 3.0 & Thrustmaster Warthog - ED Forums
 


Notices

Reply
 
Thread Tools Display Modes
Old 09-19-2015, 09:55 AM   #1
NeilWillis
Veteran
 
Join Date: Jun 2013
Location: United Kingdom
Posts: 4,778
Default USB 3.0 & Thrustmaster Warthog

I seem to have a very puzzling issue with just a single peripheral and how it behaves with USB 3.0 on my rig.

I had for years run a Warthog joystick with no issues at all, along side a number of other devices including the throttle unit, pedals, printer etc.

Just a few months back, the joystick went down. The issue has been determined to be the main card blowing. To cut a long story short, the issue was resolved with a new joystick.

After a few days, the new joystick blew in the same way. Again it was replaced. Now, after less than a week, it has happened yet again, but no other peripheral has been affected.

Is this a sign that Thrustmaster have a poorly designed main board, or could the USB 3.0 ports on my PC be causing the problem?

Any electricians out there who can point me in the right direction to identify and resolve this mess?
NeilWillis is offline   Reply With Quote
Old 09-19-2015, 11:46 AM   #2
NeilWillis
Veteran
 
Join Date: Jun 2013
Location: United Kingdom
Posts: 4,778
Default

OK, that's a little embarassing!

I have got to the root of the problem - a loose connection in the PS2 cable in the joystick extension.

Thank goodness it wasn't anything more serious at least!
NeilWillis is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT. The time now is 09:08 AM. vBulletin Skin by ForumMonkeys. Powered by vBulletin®.
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.