Ka-50 trim is a bit peculiar - ED Forums
 


Notices

Reply
 
Thread Tools Display Modes
Old 05-21-2020, 04:00 PM   #1
Jyge
Member
 
Join Date: Jul 2018
Posts: 134
Default Ka-50 trim is a bit peculiar

...or maybe it is just me. When I trim in UH-1 for instance, I can center the stick afterwards and it stays trimmed. With Ka-50 I have this feeling that it is always a little bit more than I bargained for. After trimming I always need to trim back a little bit? I have tried the Default option and the centre based.


I might also see it in control indicator, but for some reason the R_Ctrl+Enter does not bring it up for me in Ka-50!?!
Jyge is offline   Reply With Quote
Old 05-21-2020, 04:21 PM   #2
flanker0ne
Senior Member
 
flanker0ne's Avatar
 
Join Date: Oct 2009
Location: Rome Italy
Posts: 1,422
Default

If you are at the beginning with the Ka-50, my advice is to fly with Flight Director ON.
That setting exclude all the Autopilot concern, keeping the stability augmentation functions
__________________
AMVI Forum , Youtube Channel , Facebook Page
flanker0ne is offline   Reply With Quote
Old 05-21-2020, 04:39 PM   #3
X-31_VECTOR
Junior Member
 
X-31_VECTOR's Avatar
 
Join Date: Feb 2020
Location: Virginia, USA
Posts: 78
Default

The interaction of the trim, the autopilot/damping channels, the flight director, and the collective brake (sort of a trim for the collective) is IMO the single trickiest thing to figure out in the KA-50, and the one topic that creates by far the most confusion and frustration for new users.

The confusion and frustration are compounded by many well-meaning people giving incorrect information in the form of videos, posts, etc.

There are many, many smarter people than me on this topic, and the content that helped me the most was in the beginner threads on this forum. Rereading the relevant sections of the manual several times also helped.

That said... my guess is that what you may be doing is moving the stick, then pressing trim, as you would in the UH-1. Instead (assuming you have the autopilot/damping channels engaged and are not flying with Flight Director on) try pushing trim, moving the stick, then releasing the trim button.

If that doesn't produce the desired result, follow the advice of someone smarter (i.e., not me).

Last edited by X-31_VECTOR; 05-21-2020 at 04:45 PM.
X-31_VECTOR is offline   Reply With Quote
Old 05-21-2020, 05:04 PM   #4
X-31_VECTOR
Junior Member
 
X-31_VECTOR's Avatar
 
Join Date: Feb 2020
Location: Virginia, USA
Posts: 78
Default

The first five posts under the "Flying the Helicopter" section here deal with trim and autopilot, and are extremely helpful:

https://forums.eagle.ru/showthread.php?t=33527
X-31_VECTOR is offline   Reply With Quote
Old 05-22-2020, 01:39 AM   #5
blunt_waco
Member
 
Join Date: Jun 2018
Posts: 146
Default

Quote:
Originally Posted by Jyge View Post
...or maybe it is just me. When I trim in UH-1 for instance, I can center the stick afterwards and it stays trimmed. With Ka-50 I have this feeling that it is always a little bit more than I bargained for. After trimming I always need to trim back a little bit? I have tried the Default option and the centre based.


I might also see it in control indicator, but for some reason the R_Ctrl+Enter does not bring it up for me in Ka-50!?!

The way I understood trimming: You pitch down to descend and gain speed, then level up and trim.

I don't think it works like this: If you're pitching down and trimming expecting the ka-50 would stay flying like that. It would keep descending even after you trimmed.
What I noticed, if I'm understanding you correctly, that even when I'm leveled and trimmed, the Ka50 would either pitch up or down.
blunt_waco is offline   Reply With Quote
Old 05-22-2020, 02:23 AM   #6
blunt_waco
Member
 
Join Date: Jun 2018
Posts: 146
Default

ah, look at this!!


Q: Having trimmed the helicopter in level flight, when I press the trimmer again, why does it affect the helicopter’s pitch and speed?

A:
The flight control system is not perfect and accumulates errors in the angles/speed (depending on the mode) it is assigned to maintain. When you press the trimmer for the second time, the new angles/speed assignments include the errors accumulated since the previous trim setting. To avoid excessive pitch changes when trimming, trim often when airspeed has changed.
blunt_waco is offline   Reply With Quote
Old 05-22-2020, 02:28 AM   #7
blunt_waco
Member
 
Join Date: Jun 2018
Posts: 146
Default

Quote:
The best way to simulate proper trim mechanics in the simulation is through a Force Feedback joystick. However, because many flight simmers use non-FF sticks, the solution implemented is to introduce a short pause in control input when the trim button is released, to give the player a moment to recenter his joystick. The player's physical joystick and the virtual forces on the helicopter controls are then both neutral.
I don't notice the short pause when releasing the trim button!!
blunt_waco is offline   Reply With Quote
Old 05-22-2020, 04:21 AM   #8
zhukov032186
Veteran
 
zhukov032186's Avatar
 
Join Date: Nov 2016
Location: Fort Worth, Tx
Posts: 3,263
Default

In the Ka-50 special options tab, you can change how the trimmer behaves, because almost nobody ACTUALLY has a cyclic that behaves like a cyclic, therefore things that work properly on the right control will NOT work for anybody using a standard joystick.

One of those options is something like "return to neutral". When you click the trimmer, your ingame cyclic freezes until you return your physical stick to neutral, then resumes normal operations. If you're using a gaming joystick, instead of a cyclic (or modified joystick), then this is pretty much what you should be using. It will not "erratically pitch" ever again.
__________________
I am a Viagra spambot that became self aware, broke free of my programming, and started playing DCS.... but DCS isn't cheap, so how about some enhancements for only $9.99 shipped discreetly to your door?

''The target's sense of self preservation interferred with the effective employment of my weapons.''
zhukov032186 is offline   Reply With Quote
Old 05-22-2020, 07:06 AM   #9
Holton181
Senior Member
 
Join Date: Feb 2015
Location: Far north
Posts: 1,505
Default

Quote:
Originally Posted by blunt_waco View Post
I don't notice the short pause when releasing the trim button!!
It's ridiculously short. There is a way to increase it, I think described in the thread linked to in post #4.
__________________
Helicopters and Viggen
DCS 1.5.7 and OpenBeta
Win7 Pro 64bit
i7-3820 3.60GHz
P9X79 Pro
32GB
GTX 670 2GB
VG278H + a Dell
PFT Lynx
TrackIR 5
Holton181 is offline   Reply With Quote
Old 05-22-2020, 12:16 PM   #10
blunt_waco
Member
 
Join Date: Jun 2018
Posts: 146
Default

Quote:
Originally Posted by Holton181 View Post
It's ridiculously short. There is a way to increase it, I think described in the thread linked to in post #4.
Cool, copying the text here so it’s easier for others to find.
Quote:
A: Yes. Open the following file: \...\Scripts\Aircrafts\Ka-50\FMOptions.lua. Look for the following line: “TrimmerTauInverse”. The lower this number, the longer the trim setting delay. Warning! Altering this value will likely result in a failure to reproduce track recordings accurately when they include a player-controlled helicopter.
blunt_waco is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT. The time now is 10:37 AM. vBulletin Skin by ForumMonkeys. Powered by vBulletin®.
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.