New RTX 2080, very poor performance - ED Forums
 


Notices

Reply
 
Thread Tools Display Modes
Old 07-15-2019, 06:15 PM   #1
chrisofsweden
Member
 
chrisofsweden's Avatar
 
Join Date: Jan 2014
Posts: 614
Default New RTX 2080, very poor performance

So here goes. Just exchanged my old GX 980 to an RTX 2080.
I'm getting WORSE performance in games with the 2080.

DCS is like giving me 60% of what it used to with my old 980.

Where i would see 60-70 FPS with the GTX980, I now see 30-40 with the 2080.
GPU shows 100% in windows task manager, and thats in just 1080p and not at all maxed out settings.

Help! What could be wrong?
chrisofsweden is offline   Reply With Quote
Old 07-15-2019, 06:17 PM   #2
Svsmokey
Senior Member
 
Join Date: Dec 2017
Location: Dystrumpia
Posts: 2,103
Default

Did you use DDU to remove your old drivers ?
__________________
I5-6500 3.2ghz cpu, 16 gb ddr4-2133mhz , Asrock H170M PRO4 , 128gb & 240gb ssd's , 1tb hdd , EVGA 1070 FE , Rift , CH Hotas and pedals , Foxx deskmounts

"Hold my beer"
Svsmokey is offline   Reply With Quote
Old 07-15-2019, 06:18 PM   #3
chrisofsweden
Member
 
chrisofsweden's Avatar
 
Join Date: Jan 2014
Posts: 614
Default

No. Whats that?

EDIT: Ok Display Driver Uninstaller. I'll give that a try.

Last edited by chrisofsweden; 07-15-2019 at 06:23 PM.
chrisofsweden is offline   Reply With Quote
Old 07-15-2019, 06:24 PM   #4
Svsmokey
Senior Member
 
Join Date: Dec 2017
Location: Dystrumpia
Posts: 2,103
Default

It is a free downloadable utility that will clear the old graphics card drivers . THEN install the new ones . There have been two changes in architecture between the 970 and 2080 . Be sure and follow instructions regarding booting in safe mode to install new drivers . Also , visit Nvidea for latest updates after new driver installation .
__________________
I5-6500 3.2ghz cpu, 16 gb ddr4-2133mhz , Asrock H170M PRO4 , 128gb & 240gb ssd's , 1tb hdd , EVGA 1070 FE , Rift , CH Hotas and pedals , Foxx deskmounts

"Hold my beer"
Svsmokey is offline   Reply With Quote
Old 07-15-2019, 06:44 PM   #5
chrisofsweden
Member
 
chrisofsweden's Avatar
 
Join Date: Jan 2014
Posts: 614
Default

Thanks for the tip. I disabled my NIC, rebooted to safe mode and ran DDU clean and then shutdown. Started up, installed latest drivers, same result Did I just waste $730 on a graphics card??? How is it even possible that I get MUCH worse performance with a 2080 over a 980??? Heeeeeeelp!
chrisofsweden is offline   Reply With Quote
Old 07-15-2019, 06:58 PM   #6
Svsmokey
Senior Member
 
Join Date: Dec 2017
Location: Dystrumpia
Posts: 2,103
Default

Are you certain you installed the card in a pcie×16 slot ? Double-check power connectors ?
__________________
I5-6500 3.2ghz cpu, 16 gb ddr4-2133mhz , Asrock H170M PRO4 , 128gb & 240gb ssd's , 1tb hdd , EVGA 1070 FE , Rift , CH Hotas and pedals , Foxx deskmounts

"Hold my beer"
Svsmokey is offline   Reply With Quote
Old 07-15-2019, 07:01 PM   #7
petsild
Member
 
Join Date: Feb 2015
Location: Czech Republic
Posts: 614
Default

Under load the GPU core clock MHz?
__________________
Asus B-85 Pro Gamer, i7 4790K non-oc, Asus GTX 1080 Ti, 16 GB non-oc RAM, Intel SSD 520 - 240 GB, MSFFB2, Win7 64-bit.
petsild is offline   Reply With Quote
Old 07-15-2019, 07:05 PM   #8
SnapRoll
Junior Member
 
Join Date: Jun 2017
Posts: 73
Default

Have you deleted your fxo and matashaders2 folder in your saved games?
Have you checked other games?
SnapRoll is offline   Reply With Quote
Old 07-15-2019, 07:07 PM   #9
veenee
Junior Member
 
veenee's Avatar
 
Join Date: Jan 2015
Location: 3rd rock from the Sun
Posts: 85
Default

as above - what about other games? do they also struggle or is it just DCS?

have you ever made changes in your BIOS? perhaps loading default values or updating it would make sense?
__________________
So many modules, so little time...

www.mikphotography.com
veenee is offline   Reply With Quote
Old 07-15-2019, 07:09 PM   #10
tintifaxl
Senior Member
 
Join Date: Mar 2009
Posts: 1,895
Default

Quote:
Originally Posted by chrisofsweden View Post
Thanks for the tip. I disabled my NIC, rebooted to safe mode and ran DDU clean and then shutdown. Started up, installed latest drivers, same result Did I just waste $730 on a graphics card??? How is it even possible that I get MUCH worse performance with a 2080 over a 980??? Heeeeeeelp!
This is not normal behavior for a RTX 2080 (i used to have one and it ran DSC great @1440p) - there is something very wrong...
__________________
Windows 10 64bit, Intel i9-9900@5Ghz, 32 Gig RAM, Palit RTX 2080 TI, 1 TB SSD, 43" 2160p@1440p monitor.
tintifaxl is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT. The time now is 03:49 AM. vBulletin Skin by ForumMonkeys. Powered by vBulletin®.
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.