no "shoulder" in L-39 - ED Forums
 


Notices

Reply
 
Thread Tools Display Modes
Old 04-28-2017, 02:17 AM   #1
SDsc0rch
Senior Member
 
SDsc0rch's Avatar
 
Join Date: May 2014
Location: San Diego
Posts: 1,451
Default no "shoulder" in L-39

when i turn all the way around to look back, i see the headrest - if i want to see behind the aircraft, i have to first lean that direction, then turn all the way around - and i can see past the wing

checking six works fine in the eagle (the only other a/c i fly)

anyone got any tips?

i'm aware of this thread...
https://forums.eagle.ru/showthread.php?t=96116

the solution is probably going to be in the server.lua file - not sure what could be going wrong here.......
__________________
i7-4790K | Asus Sabertooth Z97 MkI | 16Gb DDR3 | EVGA GTX 980 | TM Warthog | MFG Crosswind | Panasonic TC-58AX800U

SDsc0rch is offline   Reply With Quote
Old 04-28-2017, 12:05 PM   #2
JG14_Smil
Senior Member
 
Join Date: Dec 2008
Posts: 2,390
Send a message via MSN to JG14_Smil
Default

There is absolutely nothing going wrong. What are you using for views? A joystick hat? I could see the problem if so. Edit a snap view to your liking.

If you are using VR or TIR - you are supposed to lean to look around the seat. L-39 is a sim. F-15 is FC and shouldn't even be in DCS (my opinion... I'm allowed).

I do note I saw numbers for "shoulders" in a lua file, but I forgot which, so it is editable.

Best wishes to you,
JG14_Smil is offline   Reply With Quote
Old 04-28-2017, 12:29 PM   #3
firmek
Senior Member
 
firmek's Avatar
 
Join Date: Sep 2015
Posts: 1,319
Default

As above, aside of turning your head you'll also need to lean to a side.
You could make your "shoulders" wider, which will offset head to a side more as it's being turned but at some point it starts to feel unnatural. To do it just change-increase the line:
Code:
local gShoulderSize             = 0.15                                   -- 0.25 Shift head left/right when view angle is more than 90 degrees
Something like 0.25 should help, though you can go higher. Note that if you're using this file "as is" this setting will affect all of your aircrafts.
__________________
F/A-18, F-16, F-14, M-2000C, A-10C, AV-8B, AJS-37 Viggen, F-5E-3, F-86F, MiG-21bis, MiG-15bis, L-39 Albatros, C-101 Aviojet, P-51D, Spitfire LF Mk. IX, Bf 109 4-K, UH-1H, Mi-8, Ka-50, NTTR, Normandy, Persian Gulf... and not enough time to fully enjoy it all
firmek is offline   Reply With Quote
Old 04-28-2017, 04:47 PM   #4
SDsc0rch
Senior Member
 
SDsc0rch's Avatar
 
Join Date: May 2014
Location: San Diego
Posts: 1,451
Default

like i said, in the eagle i just turn around and i'm looking around the side of the seat through the vertical tails - no "shifting" in my seat is required

having to consciously "shift" to the side robs from the experience - you end up turning around instinctively, seeing the damn seat, and having to re-do it right this time - you don't do that in real life, cmon!

thx firmek - will try it
__________________
i7-4790K | Asus Sabertooth Z97 MkI | 16Gb DDR3 | EVGA GTX 980 | TM Warthog | MFG Crosswind | Panasonic TC-58AX800U

SDsc0rch is offline   Reply With Quote
Old 04-30-2017, 07:28 AM   #5
kobeshow
Member
 
Join Date: Nov 2014
Posts: 429
Default

I noticed something in the .lua file when I was trying to solve the same issue that you have here scorch.
There are general settings and then there are seperate settings for each plane.
On the planes which work as they should (like your eagle) there is a line like this:

ViewSettings["F-15C"] = {
Cockpit = {
[1] = default_fighter_player({

On the other hand, when I switch to one of the planes that have "no shoulder" for me, like the 25T for example, the line looks like this:

ViewSettings["Su-25T"] = {
Cockpit = {
[1] = {-- player slot 1


So maybe changing "player slot 1" to "default fighter player" will give the proper shoulder effect when you set it the way firmek suggested. Have not tried it myself, will try to fix it and report back with results.

Edit: I acatually took more than 5sec to look for things this time and there are 2 lines that control the shoulder size, for the different cockpit types:

local GlobalShoulderSize
local GlobalShoulderSize_for_not_full_3D_Cockpit

the latter was set to 0 by default for me, but as I said above some of my FC3 planes use the default_fighter_player setting.
__________________

"DCS World is the main public build, it has nothing to do with being stable" -Bignewy

Last edited by kobeshow; 04-30-2017 at 09:20 AM.
kobeshow is offline   Reply With Quote
Old 04-30-2017, 04:57 PM   #6
SDsc0rch
Senior Member
 
SDsc0rch's Avatar
 
Join Date: May 2014
Location: San Diego
Posts: 1,451
Default

interesting ----- will try...


thx
__________________
i7-4790K | Asus Sabertooth Z97 MkI | 16Gb DDR3 | EVGA GTX 980 | TM Warthog | MFG Crosswind | Panasonic TC-58AX800U

SDsc0rch is offline   Reply With Quote
Old 05-01-2017, 02:44 AM   #7
SDsc0rch
Senior Member
 
SDsc0rch's Avatar
 
Join Date: May 2014
Location: San Diego
Posts: 1,451
Default

finally!

yeah - i just had to add that code

it works as intended... thank you
__________________
i7-4790K | Asus Sabertooth Z97 MkI | 16Gb DDR3 | EVGA GTX 980 | TM Warthog | MFG Crosswind | Panasonic TC-58AX800U

SDsc0rch is offline   Reply With Quote
Reply

Tags
neck, shoulder

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT. The time now is 05:08 PM. vBulletin Skin by ForumMonkeys. Powered by vBulletin®.
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.