Saitek X52 PRO or Saitek X55 Rhino? - Page 2 - ED Forums
 


Notices

Reply
 
Thread Tools Display Modes
Old 11-26-2014, 10:06 AM   #11
Hadwell
Senior Member
 
Join Date: Jul 2013
Posts: 1,133
Default

Quote:
Originally Posted by Muttley12 View Post
I've had my X-55 for about 2 months. It has allot of cool adjustable settings but has one BIG NASTY glitch. Things randomly turn on & off. Landing gear goes up & down, APU starts in flight, an engine will shut down, speed brakes will deploy. Tried calibrating, wiping out set-ups & re-loading profiles, swinging a rubber chicken in circles over the damned thing....notta. Hopefully MadCatz or Saitek will have an answer if I can get a response from them.
i'd RMA it or return it and get another, sounds like you got a dud... i haven't had any issues with mine at all, other than like i said, stick doesn't have adjustable palm rest.
Hadwell is offline   Reply With Quote
Old 11-26-2014, 05:47 PM   #12
Darkenmass
Junior Member
 
Join Date: May 2014
Location: Italy
Posts: 41
Default

Hi to all , i have a x55 , and i have to say it's great.....with a10 i am not touching the keyboard anymore expect for radio comms, but.....
But still i have to say the software for mapping is really not intuitive, it took a lot of effort to understand and map properly.
And the mouse nipple is not working well at all.
Still the thrust is so smooth it's now really easy to air refuel and you have so many buttons and rotative .... i like it a lot.
No problem with the twist neither with the springs or whatever, the joystick works great and is precise is just a matter of setting and again setting is not easy with this product, it takes time and effort.
So if you are not going for the warthog hotas and like me you dont want to buy pedals i think x55 it's a good product.....just be patient to learn the software.
Darkenmass is offline   Reply With Quote
Old 11-26-2014, 06:45 PM   #13
xaoslaad
Member
 
xaoslaad's Avatar
 
Join Date: Dec 2011
Location: New England
Posts: 969
Default

Not the X-52 Pro. Mine also had a problem with the mouse stick intermittently drifting hard right. Plugging and unplugging it 50,000 times (3 or 4 really) would eventually get it to work. Gave it away after getting a warthog and it haunts the new owner eternal as well.

I am not too impressed with the Saitek Pro Flight Combat Rudder Pedals either. They have a lot of jitter on the toe breaks, though I set dead zones in the Windows control panel and they seem to work fine.

I am not impressed with Saitek products. Can't speak about the X-55 though. Never put my hands on one.
xaoslaad is offline   Reply With Quote
Old 11-26-2014, 06:49 PM   #14
xaoslaad
Member
 
xaoslaad's Avatar
 
Join Date: Dec 2011
Location: New England
Posts: 969
Default

Quote:
Originally Posted by Muttley12 View Post
I've had my X-55 for about 2 months. It has allot of cool adjustable settings but has one BIG NASTY glitch. Things randomly turn on & off. Landing gear goes up & down, APU starts in flight, an engine will shut down, speed brakes will deploy. Tried calibrating, wiping out set-ups & re-loading profiles, swinging a rubber chicken in circles over the damned thing....notta. Hopefully MadCatz or Saitek will have an answer if I can get a response from them.
Is this happening when you're playing multiplayer only, specifically when you have TeamSpeak up. There is a bad interaction between the Saitek Profiling software for the X-52 Pro (not sure if it is the same or similar) and TeamSpeak, where you need to change 'Default' to 'Keyboard and Mouse Only' (in TeamSpeak) Settings>Options>Hotkeys, bottom right drop down. It does al kinds of daffy things otherwise.
xaoslaad is offline   Reply With Quote
Old 11-26-2014, 07:15 PM   #15
Gladman
Senior Member
 
Gladman's Avatar
 
Join Date: Jun 2013
Location: Kitscoty, AB
Posts: 1,262
Default

xaoslaad hit it on the head. I had the "ghosting" issue the first time I played multiplayer and yes the "keyboard and mouse only" setting fixed it immediately.

Dale
Gladman is offline   Reply With Quote
Old 11-26-2014, 08:03 PM   #16
saxon.jones
Junior Member
 
Join Date: Aug 2014
Posts: 2
Default

I own the X65F which the X55 is very similar to. I have to say for DCS A-10C it's awesome but also very frustrating, as it so nearly has everything I want but some important things are missing (mostly the dual-stage trigger but also the lights switch on the throttle). I also owned the X52 Pro (and the X52 and X45 before that) and there is simply no comparison with the X65F (and I presume the X55), but they were fine for most games (especially Il-2 back then).

If you can't afford the HOTAS Warthog I think it's a good choice, though I recently spent the money to buy the HOTAS Warthog and wish I'd just done that from the start.
saxon.jones is offline   Reply With Quote
Old 11-26-2014, 09:09 PM   #17
Shein
Member
 
Shein's Avatar
 
Join Date: Nov 2011
Posts: 419
Default

X55 pre-order owner here. Love it minus the two stage trigger. Also read an article on... I wanna say simhq? That said they would make new sticks that plug and play into the base. Maybe they'll make a stick with a two stage trigger who knows.
Only issue with my stick is the mouse nipple is junk. I made a YouTube video about it, and some people commented their problems and fixes as well. Also, I have a dcs a10 profile for the x55 if you decide to go that route!
Shein is offline   Reply With Quote
Old 11-27-2014, 06:33 AM   #18
Muttley12
Junior Member
 
Join Date: Nov 2014
Posts: 2
Default X-55

The "Ghosting" issue does this on lone wolf mode, I haven't even tried multiplayer. Does it in FSX as well, guess this one is a Lemon. Worked great for about 2 weeks then went straight to the POS mode. Let's see how good MadCatz customer service is. Let you know what the wait time is & how many hoops I'll have to jump through.

Last edited by Muttley12; 11-27-2014 at 06:43 AM.
Muttley12 is offline   Reply With Quote
Old 12-08-2015, 11:35 PM   #19
Devrim
Veteran
 
Devrim's Avatar
 
Join Date: Mar 2011
Location: Turkey
Posts: 4,203
Default

And?

The "ghosting issue" is fixed?

Questioning this, because I'm about to buy a X-55 in two weeks. I'll give my X52Pro to a friend of mine for a reasonable price and will buy X-55.

I like lots of hats, rotaries and switches on X-55, and I'm aware of cons of X-55 (positioning of hats/castles, no adjustable wrist unlike X52Pro, single stage fire bla bla bla). I've read lots of reviews and watched videos (including Ralfidude's one).

Generally I'm lucky about the health of electronic devices. I use many many devices in all my life. Today I'm at 40, so far no any electronic has died in my hands. Shortly, I don't care about what people are complaining on some bad sides of X-55, but ghosting problem.

I just wonder if this bug has been fixed by Saitek ... or .. .or MadCats?..

Thank you.

Edit: I've read a couple times about a powered USB hub is needed to resolve ghosting issue, right?
__________________
i7-2600 @3.4GHz | Corsair Veng. 16GB @1600MHz. | MSI nVidia GTX970 | Samsung 850EVO 256GB SSD (Win7HPx64)
Samsung 27" LS27D590P & Samsung 20" SyncMaster206BW | Saitek X-55 Rhino & Rudder | Trustmaster MFD Cougars | Logitech G13 & G230 & G510 & SwitchPanel | TIR5

MY MODS | MY CONTROLLER PROFILE

Last edited by Devrim; 12-09-2015 at 07:52 AM.
Devrim is offline   Reply With Quote
Reply

Tags
saitek, x52 pro, x55

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT. The time now is 02:58 PM. vBulletin Skin by ForumMonkeys. Powered by vBulletin®.
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.