Jump to content

Blitz262

Members
  • Content Count

    20
  • Joined

  • Last visited

About Blitz262

  • Rank
    Junior Member

Personal Information

  • Flight Simulators
    DCS, IL-2 BoX
  • Location
    Wisconsin, USA
  1. I agree with this wholeheartedly; in my opinion removing them would be a big mistake. At most a nerf should be in order, but I see no reason why they should be removed from the game entirely. If some players don't want them, they can either not use them or leave it to mission makers and server owners to leave them out. I for one can't wait to use these things :)
  2. With the promise to continue development on them until they're complete, which in my opinion is fair. I don't support ED taking on so many projects at once, but I'm more than happy that I got to fly my Viper early. Anyways, this isn't a thread about that so I'm not going to derail it. I guess if you guys really feel like spending $80 on a module then there's a case for charging that much, but for the rest of us... let's just say ED has a lot of sales every year for a reason.
  3. But... it hasn't been released yet? Also, while it'll mostly be finished when it drops on Dec. 4th, that doesn't mean Deka should charge an exuberant amount compared to the other aircraft in game. Which I guess at this point $79.99 isn't when compared to EDs newer stuff and the F-14, but imo only the F-14 deserves that price. If charging that much for modules actually earns them more money, then I guess there's a case for it, but personally I think for the amount of content we're getting that price point is too high. If what's being said about Deka's actual plan is true, I think $69.99 i
  4. I think at most $69.99 is fair. Heatblur put out an amazing product, but to be frank $80 is the limit for how expensive any module should be, and the F-14 is the highest quality aircraft out of anything we've seen yet. Also keep in mind that Heatblur promised F-14 buyers the F-14A, so technically you're getting two different aircraft for that price. Don't get me wrong, the JF-17 is also an amazing piece of equipment, but I don't feel that it packs quite the same amount of content. Edit: F/A-18C being $80 completely went over my head somehow. That one I'm not sure I can justify, it just fe
  5. Very strange... It's not an issue with a particular mission, I'm encountering the issue in every mission I try.
  6. What I mean is that the HUD locks itself into AtG mode, but doesn't let me select any weapons or change to any other HUD modes.
  7. For whatever reason, when I try to use bombs in the Su-27 (only tried with FAB 250 w/ bomb rack specifically) they never drop, and my HUD proceeds to lock. Switching between HUD modes (1,2,3,7, etc) doesn't change anything. I haven't played DCS in a while, but is this new? Or is this an issue that some of you guys are having as well? EDIT: Just tried FAB 500 M62's and they work fine. Must be a problem with the FAB 250's then?
  8. I was hoping this would happen ever since I figured out that the F-14B could carry a LANTIRN pod, so I was wondering if that will be implemented in-game, and if you guys think it should be implemented.
  9. Didn't know that you could bind CD keys to your ED account, thanks for the help!
  10. So I purchased some DCS modules on steam awhile back, and one of them was VEAO's Hawk T.1A. Shortly after I started using DCS standalone instead because it ran more smoothly when playing multiplayer; I could also use all of my Steam purchased modules on it. After the upgrade to DCS 1.5, I noticed that DCS didn't register my Hawk, and never gave me the option to download it via the new in-game module section. All of my other addons I purchased on Steam worked perfectly fine, but I have never received the option to download the Hawk. Is this a current problem with VEAO and/or DCS 1.5? I have all
  11. Oh, well that kind of sucks :( I was looking forward to something like the F-4 or F-16, but I guess I won't be buying any of LN's products until the F-14 comes out
  12. I really wish you guys could tell us about the new aircraft you are planning on releasing, as I don't want to purchase the Mirage if there is something better coming :)
  13. I have been trying to download the MiG-15Bis and Hawk T.1A but I can't find the installers for these modules in 1.5 format, does anyone know where to find them?
  14. Q: What weapons will be compatable with the L-39C uppon public release?
×
×
  • Create New...