This sounds like a similar issue they had with MSFS 2020. The solution was to set cpu scheduling to background services instead of programs. This can be found in: Advanced system settings > performance > Settings’ > Tab advanced

It might be worth a try.