Announcement

Collapse
No announcement yet.

Saitek X-52 Software/Treiberproblem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Saitek X-52 Software/Treiberproblem

    Guten Abend alle miteinander,
    seit ein paar Tagen schlage ich mich mit einem neuen Problem rum und hoffe ihr könnt mir vielleicht weiterhelfen.

    Seit fast 2 Jahren hab ich jetzt schon den X-52 (nicht pro) und alles lief gut. Bis ich vor ein paar Wochen durch eine neue SSD mein Windows neu aufgesetzt habe. Da die mitgelieferte Treiber CD von damals nicht mehr aufzufinden war, habe ich einfach den neuesten Treiber + SST Software von der Saitek HP runtergeladen und installiert (Version 7.xx).
    Folgendes Problem trat auf: Nachdem ich den Treiber und die Software installiert sowie meine vorher gesicherten Profile wieder eingefügt habe, startete ich eine kleine Runde in DCS (MiG-21). Bis kurz nach dem Start funktionierte alles einwandfrei, doch jedes mal nimmt das Spiel dann so gut wie gar keine Tasten mehr vom Joystick & Throttle wahr, bis auf die Achsen, die funktionieren alle noch.

    Kurz darauf Treiber und Software wieder runter geschmissen, alles gelöscht und auch Reste aus der Registry entfernt. Habe dann eine ältere Version von Treiber und SST installiert die ich in einem alten Thread hier gefunden habe http://forums.eagle.ru/showthread.ph...ht=Saitek+X-52 (Version 6.6.6.9).
    Dies hat leider auch nix gebracht, es bestand immer noch das selbe Problem im Spiel.
    Dasselbe passiert auch bei anderen Modulen.

    Kumpel Google wusste nun auch keine hilfreiche Antwort mehr. Ich hoffe ihr habt vielleicht ein paar Lösungsvorschläge parat

    Hier noch meine Hard- & Software Daten, falls benötigt.
    Spoiler:
    OS: Windows 7 Professional
    Mainboard: ASRock Z77
    CPU: Intel Core I5-3570K
    GraKa: Zotac GTX 480 AMP
    RAM: 8GB DDR3 1600MHz
    DCS Version: aktuellste / 1.2.14.36041



    Danke schon ein mal für jede Antwort
    Gruß Ulman



    EDIT: Ein weiteres Problem habe ich noch vergessen zu erwähnen.
    Als ich nach den Versuchen DCS beendet habe, ging so gut wie gar nix mehr. Programme wurden nicht mehr geladen und Browser konnte keine Seite mehr öffnen.
    Nach einem Systemneustart funktionierte wieder alles.
    Last edited 02-16-2015, 09:35 PM.
    Windows 10 Pro 64bit | Intel I5-3570K @ 3.80 GHz | ASrock Z77 Professional-M | Zotac GTX 970 | 16GB DDR3 @ 2400 MHz
    TM Hotas Warthog | Saitek Pro Flight Rudder | TrackIR 5

    #2
    außerhalb des spiels funktionieren alle tasten?

    falls ja, hast du mal einen anderen USB port probiert oder die möglichkeit einen USB-Hub mit externer stromversorgung zu testen?
    sigpic
    "There's nothing to be gained by second guessing yourself.
    You can't remake the past, so look ahead... or risk being left behind.
    "

    Noli Timere Messorem


    "No matter how fast light travels, it finds the darkness has always been there first, and is waiting for it."
    Terry Pratchett

    Comment


      #3
      Hast Du die Tasten in SST belegt oder in DCS? DCS speichert für jeden Joystick das Profil unter einen anderen Namen ab. Wenn du den Treiber neuinstalliert hast, wird dem Joystick ein neuer Name zugewiesen. Schau mal ob du bei DCS das passende Profil laden kannst.

      Ansonsten ist Saitek was Treiber angeht eher schlecht. Ich musste auch mehrere Treiber/SST Versionskombinationen testen bevor ich eine halbwegs stabile Konfig gefunden habe.
      f4l0
      Developer of Simshaker for Aviators

      Feel the brrrrttt:
      [Official] SimShaker for Aviators Forums thread at ED forums
      SimShaker blog - transfer game effects into the real world
      SimShaker Soundmodule with Voicemeeter Banana Setup: http://forums.eagle.ru/showthread.php?p=2469416

      DCS Toggle Switches

      System specs: Intel i7-8700k, 32 GB RAM, Nvidia 1070 GTX, lots of SSDs
      Flightgear: Oculus Rift, Warthog, MFG Crosswind, Cougar MFDs, Jetseat, Bass shaker

      Comment


        #4
        Danke erstmal für die Antworten


        @Roadrunner, ja außerhalb funktioniert alles. In der SST Konfiguration funktionieren alle Tasten und Achsen.
        Einen anderen USB Port habe ich schon probiert, Ergebnis blieb leider dasselbe. Einen USB-Hub habe ich nicht, müsste ich mir ert einen kaufen um es testen zu können. Aber warum sollte es denn auf einmal daran liegen wenn es doch vorher Jahrelang auch ohne ging?


        @f4l0, habe alle Tasten in der SST Software belegt, da man in DCS einige Tasten nicht wie gewünscht programmieren kann. Nach der ersten Deinstallation habe ich auch die DCS Profile für den Joystick gelöscht damit sich das Spiel eine neue Datei erstellt. Leider löste es das Problem auch nicht.


        Gruß
        Ulman
        Windows 10 Pro 64bit | Intel I5-3570K @ 3.80 GHz | ASrock Z77 Professional-M | Zotac GTX 970 | 16GB DDR3 @ 2400 MHz
        TM Hotas Warthog | Saitek Pro Flight Rudder | TrackIR 5

        Comment


          #5
          die idee ist dabei der stromverbrauch, normalerweise kein problem, es kann aber vorkommen, dass der USB port nicht genug saft liefert und somit manche funktionen auf der strecke bleiben.

          passiert normalerweise, wenn an einem usb-port zuviel dran hängt per usb hub ohne eigene stromversorgung. daher der gedanke es einfach mal zu probieren falls möglich.

          in wieweit die saitek software zickt kann ich nicht sagen, nutze die schon seit jahren nicht, da ich für die propeller und den huey einfach mit den standart tasten die DCS erkennt hinkomme
          sigpic
          "There's nothing to be gained by second guessing yourself.
          You can't remake the past, so look ahead... or risk being left behind.
          "

          Noli Timere Messorem


          "No matter how fast light travels, it finds the darkness has always been there first, and is waiting for it."
          Terry Pratchett

          Comment


            #6
            Ja davon habe ich schon öfters gelesen. Nur hatte ich vorher nie Probleme mit Spannungsschwankungen des USB Ports. Habe seit Jahren nur meine Maus, Tastatur und halt den X-52 am USB, und alles lief wunderbar

            Ich könnte auch gern auf die Software verzichten...wenn es möglich wäre in DCS den Pinkie und den Clutch Button als Modifikator nutzen zu können. Mit der Huey ist das keine große Sache, aber schon bei der Black Shark wird es etwas eng mit Belegungen ohne diese Tasten
            Windows 10 Pro 64bit | Intel I5-3570K @ 3.80 GHz | ASrock Z77 Professional-M | Zotac GTX 970 | 16GB DDR3 @ 2400 MHz
            TM Hotas Warthog | Saitek Pro Flight Rudder | TrackIR 5

            Comment


              #7
              Man kann in DCS neue Tasten als Modifikator zuweisen. Mache ich auch so. In SST weise ich nur dem Ministick und den Drehreglern Tastenkommandos zu. Z.B. kann man dann mit dem Ministick die Slewcontrol realisieren...
              f4l0
              Developer of Simshaker for Aviators

              Feel the brrrrttt:
              [Official] SimShaker for Aviators Forums thread at ED forums
              SimShaker blog - transfer game effects into the real world
              SimShaker Soundmodule with Voicemeeter Banana Setup: http://forums.eagle.ru/showthread.php?p=2469416

              DCS Toggle Switches

              System specs: Intel i7-8700k, 32 GB RAM, Nvidia 1070 GTX, lots of SSDs
              Flightgear: Oculus Rift, Warthog, MFG Crosswind, Cougar MFDs, Jetseat, Bass shaker

              Comment


                #8
                Hallo zusammen,

                habe seiner Zeit mal ein ähnliches Problem. Schuld daran war mein Teamspeak3.
                Es lief ja immer im Hintergrund. Einfach unter Einstellung->Hotkeys unten rechts von "Standart" auf "Nur Tastatur und Maus" umstellen.

                Voila, die Profiele liefen via Profileeditor......
                My Rig: Windows 10 Pro, Intel i7-8700k@4.7GHz, 32GB DDR4 3200 RAM, Gigabyte Z370 AORUS Ultra Gaming, 1TB Sabrent Rocket NVMe, Samsung 3*1TB HDD (RAID 0), GTX1070 G1, Thrustmaster HOTAS WARTHOG + Saitek Pro Flight Pedals + TrackIR5, ACER 30" 4K 60FPS GSync Display

                Comment


                  #9
                  Sollte dein Problem nicht anderweitig schon gelößt sein und für alle Saitek Problem Besitzer.

                  Da du ein Z77 Motherboard hast könnte sich durch den einbau der SSD der xHCI modus eingeschaltet haben. Hierzu von mir aus einem anderen Thread:

                  --
                  Fuer alle Saitek X Modell:
                  Wenn eins oder mehrere der Folgenden Probleme auftauchen liegt das zu 100% an der Inkompatibilität zwischen Saitek X - Treibern und modernen Motherboarts mit xHCI:
                  -Treiber/Software bricht bei Installation ab
                  -Buttons blinken willkürlich
                  -Buttons gehen nicht/ seltsame/ keine Reaktion des Joysticks
                  -Programme laden lange
                  -BlueScreen
                  -PC fährt nicht runter
                  -PC fährt nicht hoch
                  -Einstellungen lassen sich nicht öffnen
                  -Einstellungen laden lange
                  -Kein Internet!

                  Lösung:
                  -Joystick aus stecken
                  -Neustart und Software weitest möglich deinstallieren
                  -Neustart und ins BIOS, dort unter zb: "Peripherie" den xHCI Modus Deaktivieren (XHCI HandsOff und EHCI sind hier uninteressant)
                  -Neustart und Treiber installieren
                  -Software Installieren
                  --

                  MFG

                  Comment


                    #10
                    @Johnexample du bist mein Retter

                    Alles befolgt was du geschrieben hast, nun funktioniert endlich wieder alles so wie es soll.
                    Hatte schon die Hoffnung aufgegeben als alle vorherigen Tipps nicht halfen. Aber auf die Peripherie im BIOS wäre ich glaube nie gekommen

                    Also danke nochmal, und auch allen anderen!
                    Windows 10 Pro 64bit | Intel I5-3570K @ 3.80 GHz | ASrock Z77 Professional-M | Zotac GTX 970 | 16GB DDR3 @ 2400 MHz
                    TM Hotas Warthog | Saitek Pro Flight Rudder | TrackIR 5

                    Comment


                      #11
                      Das Freut mich. Hab mich extra nur angemeldet um hier die Saitek X- Probleme zu beseitigen. Ohne Joystick landet ja sonst der Flugsimulator in der Ecke^^

                      Comment


                        #12
                        Hallo Ihr da,

                        habt ihr schon mal geschaut ob es vielleicht ein BIOS update für eure MB's gibt?
                        Scheint ja ein Problem desselbigen zu sein, denn normal sollte AHCI bzw xHCI keine Probleme der USB Ports verursachen, oder?

                        Egal, ansonsten mal den Support vom Hersteller anschreiben, damit die das auf dem Zettel haben und zur gegebenen Zeit im BIOS fixen!
                        My Rig: Windows 10 Pro, Intel i7-8700k@4.7GHz, 32GB DDR4 3200 RAM, Gigabyte Z370 AORUS Ultra Gaming, 1TB Sabrent Rocket NVMe, Samsung 3*1TB HDD (RAID 0), GTX1070 G1, Thrustmaster HOTAS WARTHOG + Saitek Pro Flight Pedals + TrackIR5, ACER 30" 4K 60FPS GSync Display

                        Comment


                          #13
                          Das problem scheint alle Z chip Motherboards mehr oder weniger stark zu betreffen. Es gibt weder von MB Hersteller seite noch von Saitek dazu eine Aussage. Das problem besteht ja jetzt schon was länger.
                          Da einige Hersteller aber standardmäßige ahci aus haben, merken das manche Spieler garnicht. Oder es schaltet sich erst bei einem wechsel auf SSD ein. Naja ich kann zumindest auf ahci verzichten, da es nur Vorteile im hot plug oder anderen Konstellationen bringt und keinen Geschwindigkeits Vorteil.

                          Mfg

                          Comment


                            #14
                            Moin,

                            ich habe derzeit das gleiche Problem.

                            Nutze seit dem letzten WE ein AsRock Z97 Pro4 MB. Dort finde ich jedoch keinen Reiter "Peripherie" im UEFI, auch xHCI ist nicht zu finden.

                            Kann ich statt dessen auch die AHCI Settings ausschalten? Nutze zwei SSDs. Sind die dann langsamer oder sind andere Probleme zu erwarten?

                            Alle oben beschriebenen Probleme (ladezeiten, Abstürze, SST Software) treffen bei mir zu. Vor dem Upgrade (CPU, MB) war alles schick.


                            Danke im Voraus,
                            Gruß Fire
                            Hardware: Intel i5 4670K | Zalman NPS9900MAX | GeIL 16GB @1333MHz | Asrock Z97 Pro4 | Sapphire Radeon R9 380X Nitro | Samsung SSDs 840 series 120GB & 250 GB | Samsung HD204UI 2TB | be quiet! Pure Power 530W | Aerocool RS-9 Devil Red | Samsung SyncMaster SA350 24" + ASUS VE198S 19" | Saitek X52 | TrackIR 5 | Thrustmaster MFD Cougar | Speedlink Darksky LED | Razor Diamondback | Razor X-Mat Control | SoundBlaster Tactic 3D Rage ### Software: Windows 10 Pro 64Bit
                            sigpic

                            Comment


                              #15
                              Hey Fire,

                              laut diversen Seiten im Internet hat dein Board aber eine xHCI Einstellung im Bios/UEFI. Vielleicht heißt der Eintrag auch Extensible Host Controller Interface...

                              AHCI ist eine andere Geschichte, dies solltes Du tunlichst nicht verändern.

                              Viele Grüße
                              F4l0
                              f4l0
                              Developer of Simshaker for Aviators

                              Feel the brrrrttt:
                              [Official] SimShaker for Aviators Forums thread at ED forums
                              SimShaker blog - transfer game effects into the real world
                              SimShaker Soundmodule with Voicemeeter Banana Setup: http://forums.eagle.ru/showthread.php?p=2469416

                              DCS Toggle Switches

                              System specs: Intel i7-8700k, 32 GB RAM, Nvidia 1070 GTX, lots of SSDs
                              Flightgear: Oculus Rift, Warthog, MFG Crosswind, Cougar MFDs, Jetseat, Bass shaker

                              Comment


                                #16
                                Servus Fire,

                                also erstmal hat das xHCI nix mit den SATA Ports für deine Festplatten zu tun, sondern nur mit dem USB. Also es wird dadurch nix an Geschwindigkeit ö.ä. verändert. Wenn ich das richtig verstanden habe ist das eine Art genormter Controller für die neueren USB 3.0 Schnittstellen.

                                Ich musste bei mir im BIOS auch erstmal ein wenig suchen bis ich es gefunden habe. Bei mir war es unter: Advanced -> USB Configuration -> Legacy USB 3.0 Support.
                                Vielleicht hilft dir auch das angehängte Bild weiter.

                                Gruß
                                Ulman
                                Attached Files
                                Windows 10 Pro 64bit | Intel I5-3570K @ 3.80 GHz | ASrock Z77 Professional-M | Zotac GTX 970 | 16GB DDR3 @ 2400 MHz
                                TM Hotas Warthog | Saitek Pro Flight Rudder | TrackIR 5

                                Comment


                                  #17
                                  Das nenn ich wirklich mal versteckt. Ich versuchs mal, Danke.


                                  Gruß Fire
                                  Hardware: Intel i5 4670K | Zalman NPS9900MAX | GeIL 16GB @1333MHz | Asrock Z97 Pro4 | Sapphire Radeon R9 380X Nitro | Samsung SSDs 840 series 120GB & 250 GB | Samsung HD204UI 2TB | be quiet! Pure Power 530W | Aerocool RS-9 Devil Red | Samsung SyncMaster SA350 24" + ASUS VE198S 19" | Saitek X52 | TrackIR 5 | Thrustmaster MFD Cougar | Speedlink Darksky LED | Razor Diamondback | Razor X-Mat Control | SoundBlaster Tactic 3D Rage ### Software: Windows 10 Pro 64Bit
                                  sigpic

                                  Comment


                                    #18
                                    Originally posted by Ulman View Post
                                    Servus Fire,

                                    also erstmal hat das xHCI nix mit den SATA Ports für deine Festplatten zu tun, sondern nur mit dem USB. Also es wird dadurch nix an Geschwindigkeit ö.ä. verändert. Wenn ich das richtig verstanden habe ist das eine Art genormter Controller für die neueren USB 3.0 Schnittstellen.

                                    Ich musste bei mir im BIOS auch erstmal ein wenig suchen bis ich es gefunden habe. Bei mir war es unter: Advanced -> USB Configuration -> Legacy USB 3.0 Support.
                                    Vielleicht hilft dir auch das angehängte Bild weiter.

                                    Gruß
                                    Ulman
                                    Tut mir leid. Das stimmt so nicht.
                                    Du meinst den XHCI Hands off mit großem X. Hat mit dem Problem nichts zu tun.
                                    xHCI mit kleinem x als Variable hat sehr wohl was mit dem Sata controller zu tun.
                                    Im Gegensatz zu IDE kann ahci oder xhci sachen wie hotplug. Etc. Geschwindigkeits Unterschiede gibt es keine.

                                    Ja du kannst den ahci modus ausmachen. Vorher fehlinstalierte Treiber und Software deinstallieren.
                                    Gute Nacht

                                    Comment


                                      #19
                                      Läuft, merci.
                                      Hardware: Intel i5 4670K | Zalman NPS9900MAX | GeIL 16GB @1333MHz | Asrock Z97 Pro4 | Sapphire Radeon R9 380X Nitro | Samsung SSDs 840 series 120GB & 250 GB | Samsung HD204UI 2TB | be quiet! Pure Power 530W | Aerocool RS-9 Devil Red | Samsung SyncMaster SA350 24" + ASUS VE198S 19" | Saitek X52 | TrackIR 5 | Thrustmaster MFD Cougar | Speedlink Darksky LED | Razor Diamondback | Razor X-Mat Control | SoundBlaster Tactic 3D Rage ### Software: Windows 10 Pro 64Bit
                                      sigpic

                                      Comment

                                      Working...
                                      X