Announcement

Collapse
No announcement yet.

A10-c Warthog Multiplayer

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    A10-c Warthog Multiplayer

    Hihi leute ich bin neu Bei dcs a10c warthog.
    ich und mein Freund haben gerstern das Spiel gekauft und wollen nun im Multiplayer spielen. Jedoch wird bei mir kein Server angezeigt (bei meinem Freund 2 die aber beide nicht ngehen)
    Ich habe auf Neuen Server erstellen geklickt und habe Alles eingegeben und bin in meinen Server gekommen. Ich habe meinem Freund die Ip und das Pw gegeben aber wenn er sich verbinden will steht da immer : Wird zum Server verbunden und nach einer Zeit steht da nur noch Keine Verbindung zum Server möglich. Was soll er (oder ich ) machen damit wir zusammen auf einem Multiplayerserver spielen könne

    #2
    Originally posted by Tulhu View Post
    ich und mein Freund haben gerstern das Spiel gekauft und wollen nun im Multiplayer spielen. Jedoch wird bei mir kein Server angezeigt (bei meinem Freund 2 die aber beide nicht ngehen)
    Habt ihr die alte Standalone-Version gekauft bzw. installiert (Version 1.1.1.1)? Da habe ich gerade auch 0 Server gesehen, die wird kaum noch genutzt.

    Mehr Server findet ihr mit Sicherheit in der aktuellen Version 1.2.3.

    Diese Version steht nicht mehr für sich allein, sondern ist ein Modul für DCS World, und die richtige Installationsreihenfolge wäre:
    - DCS World 1.2.3 (English download version)
    - DCS: A-10C Warthog 1.2.3 (English download version)

    DCS World ist kostenlos, und das A-10C Modul sollte sich mit den Keys, die ihr erworben habt, aktivieren lassen.

    Die alte Version muss vorher nicht deinstalliert werden, ihr könnt ruhig beides parallel installieren, wenn es nicht zu eng ist auf der Festplatte. Sonst kann die alte Installation aber auch problemlos entfernt werden, die ist komplett unabhängig von DCS World.

    Originally posted by Tulhu View Post
    Ich habe auf Neuen Server erstellen geklickt und habe Alles eingegeben und bin in meinen Server gekommen. Ich habe meinem Freund die Ip und das Pw gegeben aber wenn er sich verbinden will steht da immer : Wird zum Server verbunden und nach einer Zeit steht da nur noch Keine Verbindung zum Server möglich. Was soll er (oder ich ) machen damit wir zusammen auf einem Multiplayerserver spielen könne
    Das klingt so, als wenn euch da die Netzwerktechnik einen kleinen Strich durch die Rechnung gemacht hat. Wenn einer von euch einen Server aufmachen und der/die andere darauf connecten soll, müsst ihr grob das Folgende machen (gerne die einzelnen Schritte googlen, in der Wikipedia nachlesen oder den Netzwerkprofi eures Vertrauens fragen und ihm/ihr Bier oder 'ne kühle Mate spendieren):
    • Damit das übers Internet überhaupt gehen kann, muss bei dem, der den Server einrichtet, eine sogenannte Portweiterleitung eingerichtet werden.
    • Weitergeleitet werden müssen die Portbereiche 10308 bis 10309, und zwar einmal für TCP und einmal für UDP (Edit: Port 10309 und Hinweis auf Portbereich ergänzt)
    • Diese Weiterleitung muss im DSL-Modem/Kabel-Modem/zentralen Internet-Router eingerichtet werden
    • Ziel der Weiterleitung muss die lokale IP-Adresse des PCs sein, auf dem DCS läuft. Diese lokale Adresse ist typischerweise sowas wie 192.168.2.63 (kann auch eine ganze andere Adresse sein, aber von Telekom-DSL-Routern und Co wird normalerweise sowas in der Art vergeben)
    • Unter Windows könnt ihr die IP-Adresse des Rechners rausfinden mit: Start -> Ausführen -> cmd [Enter]
    • In der Eingabeaufforderung eintippen:
      Code:
      ipconfig /all
    • Da findet ihr dann vermutlich sowas in der Art:
    • Code:
      Ethernet-Adapter LAN-Verbindung:
      
         Verbindungsspezifisches DNS-Suffix:
         Beschreibung. . . . . . . . . . . : Intel(R) 82579V Gigabit Network Connection
         Physikalische Adresse . . . . . . : 54-04-A6-00-00-00
         DHCP aktiviert. . . . . . . . . . : Nein
         Autokonfiguration aktiviert . . . : Ja
         Verbindungslokale IPv6-Adresse  . : fe80::6dee:0000:0000:7a50%11(Bevorzugt)
         IPv4-Adresse  . . . . . . . . . . : 192.168.2.63(Bevorzugt)
         Subnetzmaske  . . . . . . . . . . : 255.255.255.0
         Standardgateway . . . . . . . . . : 192.168.2.1
         DHCPv6-IAID . . . . . . . . . . . : 240387000
         DHCPv6-Client-DUID. . . . . . . . : 00-01-00-01-16-B2-69-54-54-00-00-00-00-00
         DNS-Server  . . . . . . . . . . . : 192.168.2.2
                                             192.168.2.1
         NetBIOS über TCP/IP . . . . . . . : Aktiviert
    • Die (im Beispiel fett gedruckte) IPv4 Adresse ist es, die im DSL-Router als Ziel der Weiterleitung eingetragen werden muss
    • Wenn der Router konfiguriert und ein neuer DCS-Server gestartet ist, sollte der Buddy den Server nach einem Refresh in der Server-Liste finden
    • Alternativ kann der Client auch über "Connect by IP" eine Direktverbindung aufbauen. Dazu muss er aber die öffentliche IP-Adresse kennen.
    • Also muss der Server-Betreiber seine eigene öffentliche IP-Adresse rausfinden. Beispielsweise einfach mal www.whatismyip.com aufrufen. Die dort gelistete IP dann dem Buddy per Teamspeak/Skype/IRC/Telefon oder was weiß ich wie mitteilen.
    • Jetzt kann es noch passieren, dass auf beiden Seiten die Windows Firewall oder sonst eine Firewall fragt, ob dcs.exe oder simulator.exe da irgendwas mit Netzwerk machen darf, worauf die Antwort logischerweise lauten sollte: Ja, klar.
    • Im Prinzip sollte es das gewesen sein. Aber um ehrlich zu sein, es gibt da so viele Stolpersteine, dass es immer am einfachsten ist, wenn ihr irgendwen mit Netzwerkerfahrung dazuholen könnt. Ansonsten hilft meist viel testen, ausprobieren und nachlesen.


    Viel Erfolg!
    Last edited 03-07-2013, 11:28 PM. Reason: Port-Bereich angepasst; Thx Dragon!

    Comment


      #3
      Tolle Anleitung Yurgon!

      Originally posted by Yurgon View Post
      • Weitergeleitet werden müssen die Ports 10308 TCP und 10308 UDP
      Das hat bei mir allerdings nicht ausgereicht und ich kenne mindestens eine Person bei der das auch so war.

      Ich musste im Router einen Portbereich von 10308 bis 10309 öffnen.
      Also nicht die einzelnen Ports 10308 und 10309 sondern von-bis!
      Ich verstehe es auch nicht ganz, warum die einzelnen Ports nicht funktionierten.

      Comment


        #4
        Ja, Dragon, bei mir war es auch so, keine Ahnung warum
        Wobei man sagen muss, dass das die Standardports sind, wenn man die beim Starten des Servers verändert, dann muss man natürlich die dann genutzten Ports freigeben
        "Sieh nur, wie majestätisch du durch die Luft segelst. Wie ein Adler. Ein fetter Adler."
        http://www.space-view.net

        Comment


          #5
          Danke euch erstmal (Mein Freund hat schon eine neuere Version ich noch die 1.1.1.1 kann es auch daran leigen das er nicht in meinen Server kommt)?
          Werde sonst das andere mal ausprobieren

          Comment


            #6
            Die Versionen sind untereinander nicht kompatibel und daher seht ihr euch gegenseitig nicht.
            Dennoch solltest du der Anleitung oben folgen.

            Kommt doch mal bei uns im TS3 vorbei, dann kann man solche Dinge klären ohne sich hier die Finger blutig zu schreiben.

            http://spare-time-pilots.de
            Last edited 03-07-2013, 11:37 AM.

            Comment


              #7
              Originally posted by =STP= Dragon View Post
              Das hat bei mir allerdings nicht ausgereicht und ich kenne mindestens eine Person bei der das auch so war.

              Ich musste im Router einen Portbereich von 10308 bis 10309 öffnen.
              Sieh an, davon höre ich gerade zum ersten Mal, aber ich habe auch nur sehr selten für einen einzelnen Buddy gehostet; dabei hatte Port 10308 TCP+UDP gereicht.

              Ich habe den Post aktualisiert, danke für den Hinweis (und thx MasterZelgadis für die Bestätigung)!

              Comment


                #8
                Ausserdem gaaanz wichtig!

                Zusätzlich die Netzwerkgeschwindigkeit im Multiplayerhauptmenu unter Optionen auf LAN setzen. (nicht im Singleplayer Hauptmenu)

                Funktioniert erstaunlicherweise immernoch am besten ...warum auch immer .
                "Blyat Naaaaa" - Izlom

                Comment


                  #9
                  Originally posted by Isegrim View Post
                  ...warum auch immer .
                  Weil das Spiel so die höchste Bandbreite zulässt (vermute ich)

                  Comment

                  Working...
                  X