Announcement

Collapse
No announcement yet.

G-Sync/Freesync not activating after PC wakes up

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    G-Sync/Freesync not activating after PC wakes up

    Greetings everyone,

    I've been playing with the new Nvidia driver (417.71) that allows G-Sync to work with AMD Freesync monitors. In a word, it's awesome, and works really well!

    Only thing is, when I go away from my computer and let the monitor sleep (backlight turns off), and come back to it and wake the monitor up by moving the mouse or hitting a key, G-Sync is no longer working properly. My monitor at 75Hz skips frames, and I have to go into NVCP and change the refresh rate to 60 Hz, then change it back to what I want (75 Hz) for G-Sync to re-enable.

    I've read about people having this problem with 'real' G-Sync monitors, so it can't just be because I'm using a Freesync one. When it's working, it's great, and I'd love to keep using it--just without this inconvenience. I can avoid it by disabling Sleep Mode in my monitor, but the backlight stays on all the time and I don't want that.

    Any ideas?
    AD
    Kit:
    Asus Z170-P, i5-6600k at 4.5 GHz, 1.35V w/ CM Hyper 212 EVO, 2 x 8GB GSkill Ripjaws 4 @ 3000MHz 15-15-15-35, Zotac GTX 1080 Ti AMP Extreme Core Edition, EVGA SuperNova 750 G2 PSU, HP Omen 32" 2560x1440 single screen, Thrustmaster Cougar HOTAS fitted with Leo Bodnar's BU0836A controller.

    Flying is the art of throwing yourself at the ground, and having all the rules and regulations get in the way!

    If man was meant to fly, he would have been born with a lot more money!

    #2
    Haven't noticed an issue with my g-sync monitor when I've let the monitor go to sleep.

    I did have issues with upgrading from 417.35 to 417.76 with an express install that caused performance issues in various titles. FPS was all over the place in one game I was playing.

    Could have fixed it with DDU, but it instead did a fresh windows install for other reasons anyway. Not saying that your nv driver installation is corrupted, but mine was after an express install. Everything seems normal with 417.76 now.
    Win 10 pro 64bit i7 8700k @ 5.0ghz (all cores) - EVGA RTX 2080Ti XC Ultra, 32GB DDR4 3200 16CAS, 970 Evo 250Gb boot drive, 970 Evo Plus 1TB, pny 480gb sata 3 SSDx2, 4TB HDD - Acer Predator x34 (3440x1440@100hz), Samsung Odyssey WMR, - Peripherals = msffb2 for heli/prop planes, warthog (for jets), -Warthog throttle, Logitech G13, MFG Crosswinds

    Comment


      #3
      Originally posted by Headwarp View Post
      Haven't noticed an issue with my g-sync monitor when I've let the monitor go to sleep.

      ***
      Could have fixed it with DDU, but it instead did a fresh windows install for other reasons anyway. Not saying that your nv driver installation is corrupted, but mine was after an express install. Everything seems normal with 417.76 now.

      I had a G-Sync monitor quite a while ago, and it did the same thing as my Freesync one does now--G-Sync disabled on wake.


      Where did you get the 417.76 driver? The Nvidia website only shows 417.71.


      AD
      Kit:
      Asus Z170-P, i5-6600k at 4.5 GHz, 1.35V w/ CM Hyper 212 EVO, 2 x 8GB GSkill Ripjaws 4 @ 3000MHz 15-15-15-35, Zotac GTX 1080 Ti AMP Extreme Core Edition, EVGA SuperNova 750 G2 PSU, HP Omen 32" 2560x1440 single screen, Thrustmaster Cougar HOTAS fitted with Leo Bodnar's BU0836A controller.

      Flying is the art of throwing yourself at the ground, and having all the rules and regulations get in the way!

      If man was meant to fly, he would have been born with a lot more money!

      Comment


        #4
        I meant 417.71.. brain fart. Might point out that even if I let my display sleep, I never let my system go into hibernation. I'd rather just turn the PC off. Hibernation has some kind of issue in every version of Windows I've ever used >.< I stick to High Performance power plan.
        Win 10 pro 64bit i7 8700k @ 5.0ghz (all cores) - EVGA RTX 2080Ti XC Ultra, 32GB DDR4 3200 16CAS, 970 Evo 250Gb boot drive, 970 Evo Plus 1TB, pny 480gb sata 3 SSDx2, 4TB HDD - Acer Predator x34 (3440x1440@100hz), Samsung Odyssey WMR, - Peripherals = msffb2 for heli/prop planes, warthog (for jets), -Warthog throttle, Logitech G13, MFG Crosswinds

        Comment


          #5
          There is a known issue, for over a year by now, that takes place if you have GF Experience installed -AND- game controllers, of any kind, plugged in. That haunted me till I found out what hinders my PC from going to sleep, it was GF-Exp. Deinstalled it and all worked.

          Maybe it's related to yours....and your driver has a hotfix available iirc, check that too, Guru3d.com
          Asus Strix Z370-E - Intel i7-8700K@5G_delidded - 32GB - Asus 1080GTX-Ti Poseidon retrofitted EK-waterblock - 1x 960Evo 250GB - 3x Samsung 850/860Pro 256GB Raid-0 - 32GB PageFile - 2x Seagate 2TB - Heatkiller IV - MoRa3-360LT@4x180mm fans - Corsair AXi-1200 - TiR5-Pro - Warthog Hotas - Saitek Combat Pedals - Asus PG278Q 27" WQHD Gsync 144Hz - Oculus Rift VR - Win10Pro64 - Slave to the Machine

          Comment


            #6
            Originally posted by Headwarp View Post
            I meant 417.71.. brain fart. Might point out that even if I let my display sleep, I never let my system go into hibernation. I'd rather just turn the PC off. Hibernation has some kind of issue in every version of Windows I've ever used >.< I stick to High Performance power plan.
            I always let my display sleep (backlight off), because I don't want the backlight on all the time when I'm not using the PC. I don't Hibernate my PC, I just want the monitor backlight off.

            I can disable Sleep Mode in the monitor's menus, so the backlight stays on even when I'm not using my computer. Then, it isn't a problem--G-Sync works all the time. I just don't want the backlight on when I'm not using my computer, it wastes electricity and puts un-needed time on the backlight.

            I'm both cheap & broke, so I need my monitor to last as long as possible hehehehe

            AD
            Last edited by Aluminum Donkey; 01-24-2019, 07:24 PM.
            Kit:
            Asus Z170-P, i5-6600k at 4.5 GHz, 1.35V w/ CM Hyper 212 EVO, 2 x 8GB GSkill Ripjaws 4 @ 3000MHz 15-15-15-35, Zotac GTX 1080 Ti AMP Extreme Core Edition, EVGA SuperNova 750 G2 PSU, HP Omen 32" 2560x1440 single screen, Thrustmaster Cougar HOTAS fitted with Leo Bodnar's BU0836A controller.

            Flying is the art of throwing yourself at the ground, and having all the rules and regulations get in the way!

            If man was meant to fly, he would have been born with a lot more money!

            Comment


              #7
              soo Bitmaster's right 417.75 is up @ Guru3D.. but it was mostly related to a flickering on the main display caused by HDMI being used for a secondary display from what i read. I installed since I have a monitor and my HMD.

              Still, nah never really had issues with g-sync simply because of the monitor going to sleep. Plenty of times where g-sync has been broken with a windows update or a flaky driver update however.

              Don't drive yourself nutty hehe. 417.71 and 417.75 are the first two drivers to touch freesync. I'd post your experiences on that public spreadsheet and hope nvidia sees it and fixes it in future updates.
              Last edited by Headwarp; 01-24-2019, 11:38 PM.
              Win 10 pro 64bit i7 8700k @ 5.0ghz (all cores) - EVGA RTX 2080Ti XC Ultra, 32GB DDR4 3200 16CAS, 970 Evo 250Gb boot drive, 970 Evo Plus 1TB, pny 480gb sata 3 SSDx2, 4TB HDD - Acer Predator x34 (3440x1440@100hz), Samsung Odyssey WMR, - Peripherals = msffb2 for heli/prop planes, warthog (for jets), -Warthog throttle, Logitech G13, MFG Crosswinds

              Comment


                #8
                Originally posted by Headwarp View Post
                soo Bitmaster's right 417.75 is up @ Guru3D.. but it was mostly related to a flickering on the main display caused by HDMI being used for a secondary display from what i read. I installed since I have a monitor and my HMD.

                Still, nah never really had issues with g-sync simply because of the monitor going to sleep. Plenty of times where g-sync has been broken with a windows update or a flaky driver update however.

                Don't drive yourself nutty hehe. 417.71 and 417.75 are the first two drivers to touch freesync. I'd post your experiences on that public spreadsheet and hope nvidia sees it and fixes it in future updates.
                Ok, I just tried driver version 417.75.

                Looks like it doesn't work as well, because G-Sync doesn't work below about 52 or 53 FPS. It just switches to what appears to be normal VSync mode, causing stuttering. So, I certainly won't be using that! I just want to try it to see if it works without disabling itself all the time. 417.75 appears to have "gimped" G-Sync because people were complaining about flickering in dual-monitor setups with one monitor on DisplayPort and the other on HDMI.

                I'll keep it for a little while and play around with it, but I'll probably go back to 417.71, which allowed G-Sync to work over an extremely wide FPS range, and gave amazing results in DCS World.

                Oh man, I hope Nvidia gets all this crap sorted out! I'd love to use G-Sync, it's awesome when it works properly, but oh man is it ever an infuriatingly finicky pile o' steaming dookie right now!

                AD
                Kit:
                Asus Z170-P, i5-6600k at 4.5 GHz, 1.35V w/ CM Hyper 212 EVO, 2 x 8GB GSkill Ripjaws 4 @ 3000MHz 15-15-15-35, Zotac GTX 1080 Ti AMP Extreme Core Edition, EVGA SuperNova 750 G2 PSU, HP Omen 32" 2560x1440 single screen, Thrustmaster Cougar HOTAS fitted with Leo Bodnar's BU0836A controller.

                Flying is the art of throwing yourself at the ground, and having all the rules and regulations get in the way!

                If man was meant to fly, he would have been born with a lot more money!

                Comment


                  #9
                  Sorry everyone, but it looks like the new driver sucks. (417.75).

                  Confirmed with Nvidia's pendulum test that G-Sync quits working below about 52 FPS, making it rather useless in DCS when flying close to the ground in Vegas or Normandy.... I don't know how to bypass that 52FPS limit, or if it's possible at all, but I certainly want to because of how crappy it is.

                  Looks like I'll have to go back to the older one until Nvidia assembles their fecal matter. This is a mighty shame, because I really like my new used GTX 1080 Ti, and would love to use G-Sync. The two together are kinda the ultimate combination for use on a "moderately-high-end" PC.

                  Years ago, I bought an Nvidia graphics card and a *very* expensive G-Sync monitor to go with it. I had the exact same problem--G-Sync would keep turning itself off when away from the PC for a little while, and was sometimes difficult to re-enable, requiring switching resolutions in NVCP and sometimes even a graphics card re-start, only to have it quit on me again.


                  Looks like it'll be a while before Team Green gets their rubbish sorted out.

                  AD
                  Last edited by Aluminum Donkey; 01-25-2019, 05:25 AM.
                  Kit:
                  Asus Z170-P, i5-6600k at 4.5 GHz, 1.35V w/ CM Hyper 212 EVO, 2 x 8GB GSkill Ripjaws 4 @ 3000MHz 15-15-15-35, Zotac GTX 1080 Ti AMP Extreme Core Edition, EVGA SuperNova 750 G2 PSU, HP Omen 32" 2560x1440 single screen, Thrustmaster Cougar HOTAS fitted with Leo Bodnar's BU0836A controller.

                  Flying is the art of throwing yourself at the ground, and having all the rules and regulations get in the way!

                  If man was meant to fly, he would have been born with a lot more money!

                  Comment


                    #10
                    Ok, I messed around with my PC for a little while, and now G-Sync seems to be working properly with the 417.75 driver, across the whole range of framerates.

                    Danged if I know what changed, but at least it's working

                    Unfortunately, even with the new driver, G-Sync still turns itself off whenever the monitor sleeps and I have to re-enable it by switching resolutions back and forth. People with "real" G-Sync monitors (not Freesync) are having this problem too. So, devil only knows what'll happen in the long run.

                    AD
                    Kit:
                    Asus Z170-P, i5-6600k at 4.5 GHz, 1.35V w/ CM Hyper 212 EVO, 2 x 8GB GSkill Ripjaws 4 @ 3000MHz 15-15-15-35, Zotac GTX 1080 Ti AMP Extreme Core Edition, EVGA SuperNova 750 G2 PSU, HP Omen 32" 2560x1440 single screen, Thrustmaster Cougar HOTAS fitted with Leo Bodnar's BU0836A controller.

                    Flying is the art of throwing yourself at the ground, and having all the rules and regulations get in the way!

                    If man was meant to fly, he would have been born with a lot more money!

                    Comment

                    Working...
                    X