No announcement yet.

TM Hotas X: last update messed up Z&R axis!

  • Filter
  • Time
  • Show
Clear All
new posts

    TM Hotas X: last update messed up Z&R axis!

    i have just updated to the latest version, something messed up the way how are working the joystick ZR and R axises, they are now both MIXED UP and now the RUDDER and THRUST axis are no longer usable

    , they are acting both on the rudder and/or THRUST , the only choice i have is either to have thrust or rudder!!!

    i have deleted the entire joystick setting pref, and tried to re assign the axises, still the same thing!

    wtf? i NEVER had such a problem in years of playing DCS since its earliest version, nothing has changed with my TM Hotas X, it works well in other sims (XPlane, Arma3 etc)

    as it is now, DCS v2.0.x alpha is UNFLYABLE here! please fix this ASAP
    Last edited 02-28-2016, 01:10 AM.

    My custom made aircraft skins and other content for DCS World!

    WIN10 x64 / 32 Gb RAM DDR4 @ 3000mhz / i7-7820X @ 4.1ghz / NVIDIA GeForce 1080 Ti / all SSD Samsung EVO 860 / VIRPIL T50-Throttle & T50MC flightstick on WarBRD base / MFG Crosswind pedals / Pimax 5k+

    Don't know if you have the exact same issue but when i get into a 'new' plane i always have to (re)set the joystick (X55) settings. At first when i move the throttle the stick (in-cockpit) moves too, clearing and re-assigning some of the axis fixes this. If it works ok in v1.5 you can copy the settings to v2.0.
    If man were meant to fly he'd be filled with helium.


      I also am having the exact issues. I am using the X56 Rhino. It works great on the AV8B. After updating to 2.5 from beta it will no longer work on the A10C


        I have been having all sorts of problems with my usb WH and rudder pedals of late with the Huey... sometimes the flight control just dissapears after several minutes (and its not the EGT turbo failure)... also when I choose an instant action... it will sometimes work OK, but if you try to re-run the action after a crash... again there is no flight control. This is with the Open Beta... so obviously expect bugs; but hope they are sorting these USB flight control problems out?


          Same Problem

          Same here-planes pitches up all over the place. I do not have this problem in the stable version. Using WH stick and throttle.