No announcement yet.

Hormuz Mission 1 issue

  • Filter
  • Time
  • Show
Clear All
new posts

    Hormuz Mission 1 issue


    Taking advantage of the beautiful new version of the M2000, I tried the first mission of the mini campaign in Hormuz

    It was a blast to be back in the cockpit of a M2000 after the 2 beautiful campaign in the caucasus and in the nevada.

    I was enjoying a lot the mission and as I was following directives from the awacs it looks the mission become "stuck".

    I destroyed as requested the first target (manpad) and reported it back to the awacs.. then.. nothing.. no more coms with the awacs and no guidance on anything to do..

    Did I miss something is there a bug in the mission?

    Again, thanks for the wonderful job!


    Hey! IIRC you are not told to destroy the target but to report the location of the crash site. The mission won’t guide you by hand but male sure to check F10 menu to report any findings. Let me know if it works!


      ** Heavy spoiler **

      ** You were warned ****

      mm i'm sorry I don't get it I do use F10 a lot to report the various findings

      I report the fight at the airport
      I report the crash location. Then a car make an escape.

      After following the car, which stop next to a building. I report it.
      Then I'm told to report the location of the crash, and to make a markpoint, for that.

      So what I do is that I go low and when I overfly it, I press the markpoint on the navigation system. At that moment I'm fired by a manpad. In a building north east of the crash. My wingman even told me where it is exactly (and that's nice because I don't have a real clue)

      I'm nearly sure that the awacs tell me to destroy the manpad. Which I do, then I got a voice call from my pilot telling the awacs it's done.. then.. nothing..

      Or am I that drunk?
      Last edited 01-09-2020, 07:35 PM.


        I tried it a second time and it worked like a charm this time

        I made a much better markpoint and the sequence of events that followed were completely different

        Sorry for the inconvenience

        In the first try I didn't got the confirmation for the markpoint and directly switch to the manpad conversation.

        And PLEASE keep up doing wonderful missions, this is one of the primary reasons I'm playing the mirage
        Last edited 01-09-2020, 08:36 PM.


          Glad to hear that! Enjoy the rest.


            Sorry to bug you again, but I was playing mission 1 of the coup d'etat campaign and the truck doesn't move from the crash site when it's been reported as doing so. As a result the mission can't proceed any further. Please let me know if you need any further details.


              This is a bug caused by latest update and it should have been resolved with the last hotfix..l in any case I sent the updated version to Razbam, but perhaps they didn’t manage to push it to ED on time. In which case it should be out on Wednesday.


                Thanks for the quick reply. It's similar to the issue I was having to in M17 of Enemy Within 3.0 which has persisted even after the hotfix so I thought they might be related. I'll wait for the next update and let you know if any issues persist after that.


                  thanks & sorry for trouble. Out of my hands to some extent...


                    Just wanted to say I flew the mission last night with no issues. Thanks for the fix!


                      Thanks for the report!


                        Sorry for the dump question.

                        How do i report the location/making a markpoint?

                        I reporr tracers,the crash site and the truck which stops on the houses nearby, and then nothing.

                        Btw i am completely new to the sim...sorry

                        Is there maybe a walk through on yt?
                        Last edited 07-31-2020, 09:57 PM.


                          And here i really need you help as well, guys. I am totally confused.

                          What means:
                          Throughout the mission, do NOT use the built - in ATC. Use F10 menu to communicate with a custom one.

                          It is advised to go through normal alignment and wait for wingman to complete his (he will call he is ready). Then contact Ground, Tower etc.

                          from the Briefing?

                          There is written:
                          Al Dhafra AB
                          ATC: 251.1
                          GRD: 240.9
                          DEP: 269.7
                          APP: 270.0
                          NAV: VORTAC MA 96X (114.9)

                          But if i click on the F10 Map Al Dafra, Frequency is shown with 126.50 and ILS with 111.10


                          And is there somewhere a complete eyplain of this kneeboard page? i mean what everything means in detail. R-G for example (second clear, but what means the first letter?)...

                          Sorry for noobish beginner questions...but...
                          Last edited 08-01-2020, 10:44 AM.


                            Hey! The ATC is on custom channels, just tune to the ones listed in the briefings and SPACE BAR / F10 menu as instructed.


                              R-G means red and green radios. Recommend to fly the tutorials and stock campaign before moving to this one.


                                OK, got everything an completet the mission today. Was a bit confusing with the radio in the beginning. And i thought it is the first (easyiest campaign).

                                Best immersion ever. Chapeau
                                Last edited 08-03-2020, 10:59 AM.