Announcement

Collapse
No announcement yet.

Bank hold and pitch hold channels don't work

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Bank hold and pitch hold channels don't work

    Hello, I'm on the newest open beta version and the bank and pitch hold channels don't work. So hover won't work for me either. No, I don't have the lighting problem. The heading hold and altitude hold work fine, the buttons light up and the helicopter is acting accordingly.

    Was there a change in the AP system in one of the latest updates? Am I missing something?

    Regards


    SOLVED: INU switch was off.
    Last edited by Krizzo; 09-27-2020, 05:13 PM.

    #2
    Works perfect for me after the quick coldstart in PG map.

    Sent from my ANE-LX1 using Tapatalk

    Comment


      #3
      I haven't noticed any issues on the current OpenBeta. You mentioned the lights are on, so I'm assuming you didn't try to engage Hover mode below 4m or that your doppler's still getting ready.


      If it was heavy wind then you'd also start weather cocking, so that would affect all channels...



      If you say Heading is holding and altitude, then I'm assuming flight director is off, and you are trimming... is route mode engaged maybe? That can try to 'level you out', ie neutralise bank + pitch but retain heading.


      EDIT: ...and I only ready your last sentence now on it being solved. Cool, just learnt something.
      For Black Shark tutorials, visit my channel:
      https://www.youtube.com/channel/UC-L...3SSNUGVN95b8Bw

      Comment

      Working...
      X