Announcement

Collapse
No announcement yet.

DCS World Open Beta Dedicated Server

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Originally posted by speed-of-heat View Post
    I have this problem even when I run as admin
    Ok I just solved this problem. For me at least it was the fact that I was editing while the exe was running. If you edit while everything is off then it doesn't revert back to anything. Also I was not putting "" for break lines. Hope it helps someone.
    Stay safe

    Comment


      So I just installed the DS so I can test off-loading the AI to different cores.

      Anyway, when I launch the server, it binds to my trackIR... when I launch my second DCS instance (non-DS) to join the DS, my trackIR is already bound to the DS so I can't use it. How do I stop the DS from grabbing my trackIR? I noticed in the logs it binds to all my controls/joysticks but doesn't seem to cause an issue. (BTW I spend over an hour trying to figure out why DS wouldn't start, turned out my TIR app was hung, but I had no idea the DS was looking for it. *facepalm* Wasn't obvious until my regular client wouldn't start either. Happens all the time when I resume from sleep mode).

      One more quick Q:
      If I am running on the same machine, is there any benefit to downloading the DS package, or should I just run my existing install with --server --no-render with a separate shortcut and save 55GB?
      Last edited 10-16-2020, 06:01 AM.

      Comment


        I don't know a way to stop dedicated server from taking TIR. Only way is to start DCS frist, switch to Desktop with Alt-Tap and then start the dedi.


        Some people said the dedi took less resources then the "--server --no-render" counterpart. But I haven't compared it myself.
        SYSTEM: Mainboard MSI Z270 Krait | CPU i7 7700k @ 4.8 GHz | RAM 32 GB @ 3200 MHz | GPU MSI GTX 1080ti | 1 TB SSD | Win 10 x64
        DEVICES: ASUS 27" LCD | TrackIR 5 | LukeClip | Rift S & HP Reverb | PointCTRL | TM Warthog | MFG Crosswind | Throttle Quadrant Logitech | TableMount MonsterTech
        MODULES: All

        PROJECTS: OpenFlightSchool: DE / EN

        Comment


          Thanks kaltokri,

          I suppose I'll need to add no_device_hotplug = true to autoexec as well in the server, otherwise it may re-grab it if I unplug/replug TIR.

          Comment

          Working...
          X