Announcement

Collapse
No announcement yet.

3Dmigoto VR mod for DCS : new zoom, label masking and Pimax Parallel Projection fix

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    new version 7.2 available in first post for the OB :compatibility with 2.5.6.52437, bug fixes.
    It should also fix the label & tooltips problem, It seems I finally find a fix.
    P8700K @4.8 GHz, 1080ti, 16 GB RAM, HP reverb Pro.
    I spend my time making 3dmigoto VR mods for BoS and DCS instead of flying, see https://www.patreon.com/lefuneste

    Comment


      Originally posted by lefuneste01 View Post
      It should also fix the label & tooltips problem, It seems I finally find a fix.
      Seems to work fine now even with my custom dot labels (conf'd as full label). Thanks for fixing that

      Comment


        So I am still able to run the version for 2.5.6.50321 OB and pass the IC.


        Is this still the latest and greatest IC version available?
        Intel i7 9700k, 64GB DDR4, Gigabyte Z390 Master, RTX 2080 Ti 11gb, 500GB Sabrent Rocket (System) 1TB XPG Gammix S11 Pro M.2 (DCS), Windows 10 64, Samsung 55" 4K UHD TV, Samsung Odyssey Plus

        DCS OB 2.5.6, F-14B Tomcat, F-18C Hornet, F-16C Viper, A-10C Warthog, F-5 Tiger II, AV-8B Harrier, P-51D Mustang, FC3, Super Carrier

        Thrustmaster Warthog Hotas, (3) Cougar MFD's, Logitech Pro Rudder Pedals, (2) Stream Decks, (1) Stream Deck XL, (1) Stream Deck Mini, Misc Button Boxes

        Comment


          Originally posted by DERacing View Post
          So I am still able to run the version for 2.5.6.50321 OB and pass the IC.


          Is this still the latest and greatest IC version available?

          7.2 available in first post for the OB :compatibility with 2.5.6.52437, bug fixes. The mod is always IC compliant because it does not modify the game files, only the rendering, as ReShade.
          P8700K @4.8 GHz, 1080ti, 16 GB RAM, HP reverb Pro.
          I spend my time making 3dmigoto VR mods for BoS and DCS instead of flying, see https://www.patreon.com/lefuneste

          Comment


            Is it me or did this literally stop working in the latest update?

            Comment


              Originally posted by Eldur View Post
              Is it me or did this literally stop working in the latest update?
              I'll have a look.
              P8700K @4.8 GHz, 1080ti, 16 GB RAM, HP reverb Pro.
              I spend my time making 3dmigoto VR mods for BoS and DCS instead of flying, see https://www.patreon.com/lefuneste

              Comment


                Originally posted by Eldur View Post
                Is it me or did this literally stop working in the latest update?

                All seems working (at least copy/paste of radio messages, label masking, sharpen,...)
                P8700K @4.8 GHz, 1080ti, 16 GB RAM, HP reverb Pro.
                I spend my time making 3dmigoto VR mods for BoS and DCS instead of flying, see https://www.patreon.com/lefuneste

                Comment


                  Weird, I can't even enter the menu (LShift F7) anymore... might this be a conflict with Mustang's shader mod?

                  Comment


                    Found what did that. Mustang's shader mod has got a Tonemap.fx in it since v 1.04 and removing it does the trick. That's why I didn't encounter problems with it before. Same probably goes for Kegetys mod... might also work without that file, but in that case it contains most of the performance improvements I guess.

                    Comment


                      Looks like the label masking stopped working, at least with the A-10C II, when that got released... is this something that needs work for each module by chance? Have yet to check with other modules though. Only other graphics mod is Mustang's shaders with Tonemap.fx removed in order to make this one work at all.
                      Attached Files

                      Comment


                        Tried without the shader mod and clearing shader chaches to see if it was causing this (so 3dmigoto would be the only graphical mod), I can still see the labels through Jeff, A-10C2, F-16, F-18, F-14, Ka-50. Haven't bothered trying other assets...

                        Comment


                          Originally posted by Eldur View Post
                          Tried without the shader mod and clearing shader chaches to see if it was causing this (so 3dmigoto would be the only graphical mod), I can still see the labels through Jeff, A-10C2, F-16, F-18, F-14, Ka-50. Haven't bothered trying other assets...
                          Hello. Sorry, I did not see your previous post. I'll check.
                          Did you check your graphic settings ? Cockpit illumination must be off.
                          P8700K @4.8 GHz, 1080ti, 16 GB RAM, HP reverb Pro.
                          I spend my time making 3dmigoto VR mods for BoS and DCS instead of flying, see https://www.patreon.com/lefuneste

                          Comment


                            I do have Cockpit Global Illumination on and it never was a problem, but I'll try that out. Thanks, not a biggie that you did't react immediately.

                            Comment


                              New version 7.3 available in first post, for both stable and beta.
                              Only few changes for last beta: reflection on cockpit glasses/instruments for Ka50 and UH1 can be disabled again (they don't look well in VR). If you don't need this fixes, that not worth to upgrade.

                              Eldur : all features, including label fixing, are working for me for the last beta. Are you sure that the mod is active ? Did you have something diplayed when you press LSHIFT+F7 ? Or did you enable label masking in mod menu ?
                              P8700K @4.8 GHz, 1080ti, 16 GB RAM, HP reverb Pro.
                              I spend my time making 3dmigoto VR mods for BoS and DCS instead of flying, see https://www.patreon.com/lefuneste

                              Comment


                                Thanks for asking. I will try again with the new DCS version, and yes, I had the menus appear. I still have to see if Mustang's shader mod might cause problems even with the Tonemap.fx removed from it. I should also try to switch label masking off and on probably. And play around with the labels setting in DCS. IIRC I had it set to full for most of the time, but edited them to be dots only anyway shortly before ED implemented the dot only option that I switched over to a while ago. Maybe that's causing the issue.

                                And thanks for fixing the reflections there, it's really weird especially in the Ka-50.

                                Comment


                                  Originally posted by Eldur View Post
                                  Thanks for asking. I will try again with the new DCS version, and yes, I had the menus appear. I still have to see if Mustang's shader mod might cause problems even with the Tonemap.fx removed from it. I should also try to switch label masking off and on probably. And play around with the labels setting in DCS. IIRC I had it set to full for most of the time, but edited them to be dots only anyway shortly before ED implemented the dot only option that I switched over to a while ago. Maybe that's causing the issue.

                                  And thanks for fixing the reflections there, it's really weird especially in the Ka-50.
                                  Maybe you should try to do a repair...
                                  P8700K @4.8 GHz, 1080ti, 16 GB RAM, HP reverb Pro.
                                  I spend my time making 3dmigoto VR mods for BoS and DCS instead of flying, see https://www.patreon.com/lefuneste

                                  Comment


                                    I did that, no change though. But after quite some testing, I kinda found some "killers".

                                    It clearly doesn't like something about Mustang's shader mod, but I ran 1.03 quite long without problems, so it's something that he added with the newer versions, but I jumped to 1.10 directly from that one. And it still works with the older one and that one still seems to fix the foggy haze for me. So I'll just use that one for the time being and ask him if he could do something about the issue.

                                    I've been playing around with the labels themselves recently. When nothing else kills the masking, not having just a dot (as in period, the thing you end a sentence with) will break the masking. I tried some other ones like ° just to have a bigger do(nu)t or even just letters like v to point at things I struggle to see (Rift CV1 is very tough on visibility). All those don't get masked. Don't know about the default ones with range, type, name etc though.

                                    BTW Global Cockpit illumination on/off = absolutely not affecting the label masking at all. Might kill some other features though, but I haven't noticed anything not working because of that, I just use the mod for masking the labels and getting rid of baked reflections.

                                    Comment


                                      Originally posted by Eldur View Post
                                      I did that, no change though. But after quite some testing, I kinda found some "killers".

                                      It clearly doesn't like something about Mustang's shader mod, but I ran 1.03 quite long without problems, so it's something that he added with the newer versions, but I jumped to 1.10 directly from that one. And it still works with the older one and that one still seems to fix the foggy haze for me. So I'll just use that one for the time being and ask him if he could do something about the issue.

                                      I've been playing around with the labels themselves recently. When nothing else kills the masking, not having just a dot (as in period, the thing you end a sentence with) will break the masking. I tried some other ones like ° just to have a bigger do(nu)t or even just letters like v to point at things I struggle to see (Rift CV1 is very tough on visibility). All those don't get masked. Don't know about the default ones with range, type, name etc though.

                                      BTW Global Cockpit illumination on/off = absolutely not affecting the label masking at all. Might kill some other features though, but I haven't noticed anything not working because of that, I just use the mod for masking the labels and getting rid of baked reflections.
                                      I can confirm you full default labels (range + object name + pilot name) are correctly masked on my install.
                                      It's possible cockpit global illumination is not killing anymore mod features, that was not the case when I handle zoom modification, but now there are less shaders modified.
                                      Didn't you try the copy/paste of radio messages and sharpen features ?
                                      P8700K @4.8 GHz, 1080ti, 16 GB RAM, HP reverb Pro.
                                      I spend my time making 3dmigoto VR mods for BoS and DCS instead of flying, see https://www.patreon.com/lefuneste

                                      Comment


                                        Appears to be non-functional with the latest patch (OB 2.5.6.57949)

                                        Comment


                                          Originally posted by SPAS79 View Post
                                          Appears to be non-functional with the latest patch (OB 2.5.6.57949)
                                          Thanks for the information, I'll have a look this week end.
                                          P8700K @4.8 GHz, 1080ti, 16 GB RAM, HP reverb Pro.
                                          I spend my time making 3dmigoto VR mods for BoS and DCS instead of flying, see https://www.patreon.com/lefuneste

                                          Comment

                                          Working...
                                          X