Announcement

Collapse
No announcement yet.

VAICOM PRO plugin for VoiceAttack

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Originally posted by jmarso View Post
    The other 4 steps I've done except for 3 since I own AIRIO. I'm not sure how #2 would work other than a reset.

    Something odd is going on. I've gone back and loaded an older mission file that I made and everything works fine. That got me thinking that maybe it was a supercarrier module issue, but when I changed the carrier to the Stennis in this new mission file and deleted all the Burkes, the problem persists.

    EDIT: I built a quick mission from scratch and everything works fine in it as well. I'm not sure why VAICOM doesn't like this particular mission file. Like I said, using the Jester wheel and normal comms menu, everything still works the way it should.
    Attach the mission file to a post and I will then try it and see if I get the issue / can figure out what is going on

    Sent from my SM-T835 using Tapatalk
    Windows 10 Home ¦ Z370 AORUS Gaming K3 motherboard ¦ i5-8600K oc to 4.3GHz ¦ 48GB Corsair PC4 memory @ 3000MHz ¦ Samsung 960 EVO M.2 SSD for OS, Samsung 860 EVO 500GB SSD for DCS ¦ ASUS ROG GTX 2060 Super 8GB ¦ Virpil WarBRD base with VFX grip, Thrustmaster A10c and F/A-18 grips ¦ VKB Gunfighter Mk2 and MCG ¦ Thrustmaster Warthog Throttle ¦ MFG Crosswinds ¦ Oculus Rift S

    Comment


      Mediafire link: Link removed

      Comment


        Finally got Vaicom working.

        Not sure what the issue was but I ended up having to do the following TWICE and then it started working again:

        - Delete Exports.lua file
        - Perform Repair and Cleanup on DCS World Install
        - Reset all settings in VaiCom

        No idea if something failed the first time around or I messed up, or whether something needs to be done in a particular order that I had the wrong way around so by doing it twice it fell inline.

        Comment


          Okay, the mission I was rebuilding from scratch with everything working is now having the same link host problem with AIRIO. Something is causing it, just not sure what.

          Again, I feel compelled to ask if changing the radio presets in the player's Tomcat in the ME might have something to do with this, although I don't see how.
          Last edited 10-15-2020, 06:10 AM.

          Comment


            4. Run Voice Attack as Admin.

            On my system, this a key factor. Plus, I had to write a script to Stop/Start certain processes to get VA/VAICOM to work.

            I have included the .cmd contents and it is executed as an Admin. Hope this helps anyone that might have similar issues.

            ::--------------------------------------------------------------------
            :: Jeffrey S. Bradley, 9/22/2018 (Rev v1.1 11/26/201
            ::--------------------------------------------------------------------
            ::
            :: The initial part of this script is for re-calling this same
            :: batch file but making the CMD Window run Minimized. The VoiceAttack
            :: app window displays as a normal window.
            ::
            :: This script stops both NahimicSvc32Run/NahimicSvc32Run
            :: tasks (in case they were running) and stops the NahimicService
            :: and kills the NahimicSvc64 process before looping to
            :: to verify that all processes are no longer running.
            :: Finally, it then starts the VoiceAttack executable and
            :: subsequently restarts the processes.
            ::
            :: Note: This MUST be 'Run as an administrator'
            ::--------------------------------------------------------------------


            ::--------------------------------------------------------------------
            @ECHO OFF

            IF "%1"=="done" GOTO RunTime
            START "" /MIN %0 done
            EXIT

            :RunTime
            TITLE VoiceAttack CMD

            CD C:\JSBCommands
            SCHTASKS /END /TN NahimicSvc32Run
            SCHTASKS /END /TN NahimicSvc64Run
            SC STOP NahimicService
            TASKKILL /F /IM NahimicSvc32.exe
            TASKKILL /F /IM NahimicSvc64.exe
            TASKKILL /F /IM NahimicService.exe

            :StartOver
            TASKLIST | FINDSTR /I "Nahimic" >nul

            IF %ERRORLEVEL% EQU 1 (GOTO End) ELSE (GOTO StartOver)

            :End
            CD "C:\Program Files (x86)\VoiceAttack"
            "C:\Program Files (x86)\VoiceAttack\VoiceAttack.exe"
            SC START NahimicService

            EXIT
            ::--------------------------------------------------------------------
            Last edited 10-15-2020, 09:39 AM.
            Alienware Area 51 R5 - Intel i9 7980XE (4.7 GHz), 32GB Dual Channel HyperX DDR4 XMP, Dual NVIDIA GeForce GTX 1080 Ti Graphics 11GB GDDR5X SLI, 4.5 TB combo of SSDs/HDDs, Alienware 1500 Watt Multi-GPU Power Supply, Alienware 25” 240Hz Gaming Monitor, Alienware Pro Gaming Keyboard, TM HOTAS, TM Cougar F-16C MFDs, Saitek Pro Flight Rudder Pedals, TrackIR5, Win10 Pro x64

            Comment


              My flight mate is unable to retain the license key after closing and restarting his computer. It appears that Vaicom is reverting to original state. He has to input his license key and set all of his settings every time he turns his computer on.

              Any suggestions? Thanks...Drac

              Comment


                Originally posted by jmarso View Post
                Mediafire link: Link removed
                Just realized that mission file may look a little daunting when opened up. For purposes of this problem, you can delete every red unit in the mission and the problem is still there.

                Comment


                  Originally posted by jmarso View Post
                  Just realized that mission file may look a little daunting when opened up. For purposes of this problem, you can delete every red unit in the mission and the problem is still there.

                  Thanks - will have a chance to look either tonight or tomorrow
                  Windows 10 Home ¦ Z370 AORUS Gaming K3 motherboard ¦ i5-8600K oc to 4.3GHz ¦ 48GB Corsair PC4 memory @ 3000MHz ¦ Samsung 960 EVO M.2 SSD for OS, Samsung 860 EVO 500GB SSD for DCS ¦ ASUS ROG GTX 2060 Super 8GB ¦ Virpil WarBRD base with VFX grip, Thrustmaster A10c and F/A-18 grips ¦ VKB Gunfighter Mk2 and MCG ¦ Thrustmaster Warthog Throttle ¦ MFG Crosswinds ¦ Oculus Rift S

                  Comment


                    VAICOM Pro Not Working

                    Originally posted by ZoneySD View Post
                    Folks, I'm having issues where VAICOM isn't working with DCS. I've gone through the steps that I normally go through after an upgrade (I actually made a checklist!) but no joy. It seems that VA is recognizing my commands like "Chief, remove the wheel chocks) but nothing happens within DCS (no communication, etc). Same thing for my commands with Flight, AAR, etc. It seems like it isn't communicating with DCS. It does work with my local commands but not VAICOM. I'm on OpenBeta, I have the path set, OB selected, and Easy Comm. VA sees me in the F/A-18 module as well. As I said, I've gone through the after upgrade checklist a couple of times with no luck. Looking for ideas. Thanks!
                    Folks, Still having this issue. I've gone through all of the steps multiple times and it is still not working. Would really appreciate some help with this. I've run out of ideas...

                    Comment


                      @ZoneySD when voice attack is loaded you have on the right side a number of icons. Is there a red circle with a red line through it? If so you have disabled the keyboard inputs so no keystrokes are sent. Haven’t read the whole post so my apologies if you already checked it.

                      Had once a problem where Voice Attack/Viacom did not respond to my joystick commands. Turned out I had disabled the joystick inputs. Took me days to figure out.

                      Comment


                        Originally posted by bradleyjs View Post
                        4. Run Voice Attack as Admin.

                        On my system, this a key factor. ...
                        On my system I never run Voice Attack as Admin and VAICOMPRO works just fine. However, since VAICOMPRO sometimes wants to edit files, I set Windows folder permissions to let me modify the VAICOMPRO folders and the DCS folders when running as an ordinary user. This is a lot safer than giving an application admin privileges.
                        I'm Softball on Multiplayer. Dell XPS-8500 24GB, i7-3770@3.40GHz, Win 10Pro, Nvidia GeForce GTX 1060 6GB, TiR, CH hotas and pedals

                        Comment


                          I tried to find the solution, but failed and this thread is sooo long...

                          I have an issue currently, I can't select menu items by saying "take X". It generally looks OK (read down to top):

                          10:17:00.203 Constructing message...
                          10:17:00.201 TX4 | AUTO: [ ] , [ Menu Item 5 ]
                          10:17:00.199 Have result, identified as command: Take 5
                          10:17:00.198 Captured sentence: take 5
                          10:17:00.173 Recognized : 'take 5'

                          But the menu item in DCS still is not selected.
                          I'm using Vaicom Pro for years now and I'm not aware of any changes I might have done (besides updating to the latest DCS OB as I always do).
                          What do I miss here?
                          Ryzen 3700X, 2080ti, 32GB, HP Reverb, Rift S, Thrustmaster Warthog, Crosswind, SFX-100 motion rig

                          Comment


                            Originally posted by DthFrmAbv View Post
                            I tried to find the solution, but failed and this thread is sooo long...



                            I have an issue currently, I can't select menu items by saying "take X". It generally looks OK (read down to top):



                            10:17:00.203 Constructing message...

                            10:17:00.201 TX4 | AUTO: [ ] , [ Menu Item 5 ]

                            10:17:00.199 Have result, identified as command: Take 5

                            10:17:00.198 Captured sentence: take 5

                            10:17:00.173 Recognized : 'take 5'



                            But the menu item in DCS still is not selected.

                            I'm using Vaicom Pro for years now and I'm not aware of any changes I might have done (besides updating to the latest DCS OB as I always do).

                            What do I miss here?
                            If you do not have AIRIO you need to download this and place the DLL in the extensions subfolder under Vaicompro in the VA install.

                            There is now a whole Vaicom sub-forum and the answer to this is in one of the other threads.

                            Sent from my SM-T835 using Tapatalk
                            Windows 10 Home ¦ Z370 AORUS Gaming K3 motherboard ¦ i5-8600K oc to 4.3GHz ¦ 48GB Corsair PC4 memory @ 3000MHz ¦ Samsung 960 EVO M.2 SSD for OS, Samsung 860 EVO 500GB SSD for DCS ¦ ASUS ROG GTX 2060 Super 8GB ¦ Virpil WarBRD base with VFX grip, Thrustmaster A10c and F/A-18 grips ¦ VKB Gunfighter Mk2 and MCG ¦ Thrustmaster Warthog Throttle ¦ MFG Crosswinds ¦ Oculus Rift S

                            Comment


                              Originally posted by RedeyeStorm View Post
                              @ZoneySD when voice attack is loaded you have on the right side a number of icons. Is there a red circle with a red line through it? If so you have disabled the keyboard inputs so no keystrokes are sent. Haven’t read the whole post so my apologies if you already checked it.

                              Had once a problem where Voice Attack/Viacom did not respond to my joystick commands. Turned out I had disabled the joystick inputs. Took me days to figure out.

                              Thanks RedeyeStorm. I'm going through the key inputs again.


                              Sent from my iPhone using Tapatalk

                              Comment


                                Hey all. I've been having issues with VA working at times and then nothing. The latest update seemed to have fixed it.
                                However, hoping into my Caucuses Server today I found that my VA would always indicate vaicom listening suspended on that particular server. The other two servers and SP missions worked like a charm. While doing some research trying to find out why?? I remembered that if you use Skatezilla DCS utility and you don't have the latest updated Skatezilla DCS utility will definitely "F" up your install when doing a DCS update or repair.
                                All though Skatezilla DCS utilityis a great utility it does not alert you on any updates. This is the second time I found this out the hard way and hopefully it will sink in this time for me.
                                Anyways I hope this will give someone an idea on where to look if all seems lost.

                                Cheers
                                sigpic

                                Comment


                                  I have just got back into flying and am having problems of commands not being actioned. I have the latest Viacom program, 2.5.22.2 and the latest Voice Attack program 1.8.7. Everything appears to be setup as per directions, but here's what happens. When in the F18 and I wish to land all I have to say is " airport name" callsign inbound. Then I hear the pilot voice and shortly ATC replies with landing information. If I say options instead and then say the proper "take 1, 2,3, or any of the other numbers I hear the beep but nothing happens. If I use the mouse to select the F# key it works as advertised and the menu disappears. One of my squad mates and I work for hours and carried out all the trouble shooting suggestions on your site but no joy. When looking at the actions screen in Voice Attack I see the commands I give are recognized but no action taken. If I use cockpit controls by voice they work fine unless the comms menu is open then nothing at all happens. I'm totally out of ideas. Can you help please. Thanks

                                  Comment


                                    Originally posted by Sartechchief View Post
                                    If I say options instead and then say the proper "take 1, 2,3, or any of the other numbers I hear the beep but nothing happens. If I use the mouse to select the F# key it works as advertised and the menu disappears.
                                    try downloading the AIRIO extension and placing the dll in the extensions folder under Vaicompro (you do not need to buy the extension). This is a known issue and should be fixed in the next release.

                                    Windows 10 Home ¦ Z370 AORUS Gaming K3 motherboard ¦ i5-8600K oc to 4.3GHz ¦ 48GB Corsair PC4 memory @ 3000MHz ¦ Samsung 960 EVO M.2 SSD for OS, Samsung 860 EVO 500GB SSD for DCS ¦ ASUS ROG GTX 2060 Super 8GB ¦ Virpil WarBRD base with VFX grip, Thrustmaster A10c and F/A-18 grips ¦ VKB Gunfighter Mk2 and MCG ¦ Thrustmaster Warthog Throttle ¦ MFG Crosswinds ¦ Oculus Rift S

                                    Comment


                                      I'm having trouble with Voice Attack It recognizes keyboard commands, but rarely recognizes HOTAS input in game. I have all of my mic transmit buttons bound, but the program only occasionally recognizes them when I am in game. It seems very inconsistent. When I am out of game it has no issues recognizing my HOTAS inputs. Anyone had this issue or a similar one?
                                      Modules: A10C, AV8, M2000C, AJS-37, MiG-21, MiG-19, MiG-15, F86F, F5E, F14A/B, F16C, F18C, P51, P47, Spitfire IX, Bf109K, Fw190-D, UH-1, Ka-50, SA342 Gazelle, Mi8, Christian Eagle II, CA, FC3

                                      Comment


                                        Hey guys. This is an awesome Mod which i bought ages ago but only just started using. Works well, thanks to some extra tips from this thread, but one quick question... I have selected Import new Theatres but there are no ATC updates for the Syria map - at least as far as i can see. I cant update the Keyword list, despite following the instructions (i think) because there is nothing to add to the list. Any ideas of a schoolboy error?

                                        Edited to add - just added the Airio.dll to my VoiceAttack/Vaicompro extensions folder as suggested for a different issue. Worked immediately and ATCs are now up to date for all maps.
                                        Last edited 10-21-2020, 10:26 AM.

                                        Comment


                                          Originally posted by NakedSquirrel View Post
                                          I'm having trouble with Voice Attack It recognizes keyboard commands, but rarely recognizes HOTAS input in game. I have all of my mic transmit buttons bound, but the program only occasionally recognizes them when I am in game. It seems very inconsistent. When I am out of game it has no issues recognizing my HOTAS inputs. Anyone had this issue or a similar one?
                                          Do you still have the HOTAS controls bound in DCS?

                                          What HOTAS are you using?

                                          Are there any beeps or entries in the VA logfile when you have issues in DCS? Which module(s) are you flying?
                                          Windows 10 Home ¦ Z370 AORUS Gaming K3 motherboard ¦ i5-8600K oc to 4.3GHz ¦ 48GB Corsair PC4 memory @ 3000MHz ¦ Samsung 960 EVO M.2 SSD for OS, Samsung 860 EVO 500GB SSD for DCS ¦ ASUS ROG GTX 2060 Super 8GB ¦ Virpil WarBRD base with VFX grip, Thrustmaster A10c and F/A-18 grips ¦ VKB Gunfighter Mk2 and MCG ¦ Thrustmaster Warthog Throttle ¦ MFG Crosswinds ¦ Oculus Rift S

                                          Comment

                                          Working...
                                          X