Announcement

Collapse
No announcement yet.

Issue receiving Game

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Issue receiving Game

    Hi

    I purchased this module via paypal and it is showing as Paid, however not completed. Is anyone else having the same issue and did you get it resolved!?

    #2
    Same here buddy. Purchaced with PayPal and Showing Paid in my profile.

    Comment


      #3
      sorry about the typo!!

      Comment


        #4
        Same with me also payed through Paypal yet still says processing.Got reciept from paypal showing it was paid.
        MODULES: FC3, M2000C, L-39C/ZA, UH-1H HUEY, A-10C WARTHOG, F-86F SABRE,MIG-15, MIG-21, KA-50,Hawk,P-51 and Nevada.

        Comment


          #5
          Pretty poor, I have bought every module and have been with this since lock on! First time any issue! Maybe the server has COVID.

          Comment


            #6
            I bought $9.99 upgrade via PayPal. Order status shows "PAID" and have receipt email from PayPal as well...but that's it. Order is not "completed" and cannot download either.

            Comment


              #7
              Same here, Paid with fully with Miles. It says order is paid but I can't install/download it. Never had any problems before so maybe just to many people trying to buy right now.

              Comment


                #8
                Same issue here with the upgrade paid by miles. At the end of my purchase I got an error about some php code. Looks like their website has an issue.
                Last edited 09-30-2020, 07:55 PM.

                Comment


                  #9
                  Does ED look at these posts - or is there another thread to post tech support issues.

                  Comment


                    #10
                    Never mind - I see this is in a customer support thread.

                    Comment


                      #11
                      just refreshed the order page and it says Completed now, looks like its just a delay. took about 12 or 15 minutes, now downloading. hope its the same for you guys.

                      Comment


                        #12
                        Just for troubleshooting purposes, according to instructions we should be able to download and install from the Module Manager, but the new product is not in my product list to do that. In the store it shows as paid and delivered, whatever that means.
                        Last edited 10-01-2020, 07:07 AM.

                        Comment


                          #13
                          Originally posted by Red-Dog View Post
                          just refreshed the order page and it says Completed now, looks like its just a delay. took about 12 or 15 minutes, now downloading. hope its the same for you guys.
                          Wondering how you downloaded. Did it show up in your Module Manager? Mine is not even tho it says order completed and delivered.

                          Comment


                            #14
                            Originally posted by zippydoda View Post
                            Wondering how you downloaded. Did it show up in your Module Manager? Mine is not even tho it says order completed and delivered.
                            My A-10C upgrade is now showing completed and I was able to install through the module manager. I have open beta / non-steam version of DCS.

                            Comment


                              #15
                              Originally posted by zippydoda View Post
                              Wondering how you downloaded. Did it show up in your Module Manager? Mine is not even tho it says order completed and delivered.
                              Just like usmcnaz, Once it showed "Completed" on the order page I logged into DCS and used the Module Manager like normal.
                              I'm also on (open beta Stand alone). Hope you can get it all sorted out.
                              Last edited 10-01-2020, 12:32 PM.

                              Comment


                                #16
                                I have waited 24 hours now, the order says complete and money is taken from my account, but no sign of the module in module manager. I have reinstalled the A10c module, log out and in again i DCS.



                                How do I get the module?
                                Windows 10 pro 64bit | Intel I7 4790K@ 4GHz | 24GB Crucial ballistix sport 1600MHz DDR3 | ASUS Strix GTX1080Ti OC | Crucial mx 100 250Gb SSD | Crucial mx 300 520Gb SSD "Game disc"| Samsung 1Tb HDD |

                                Comment


                                  #17
                                  At this point if your still having problems I would suggest opening a support ticket with ED. https://www.digitalcombatsimulator.com/en/support/

                                  Comment


                                    #18
                                    But you guys are using the latest Open Beta of DCS World, right?
                                    Did you know? True Harrier fans contribute to the AV-8B Community Bugtracker!

                                    Comment


                                      #19
                                      No I dont use the Open Beta version. Is that the problem, because no download today either.


                                      Edit: It says Requires DCS World Open Beta version 2.5.6 or above!



                                      Then I have to wait for the other version, I cant have both installed. Or should i change to the Beta? For me I think Beta is like a testing unfinished product with bugs and stuff.
                                      Last edited 10-02-2020, 06:17 PM.
                                      Windows 10 pro 64bit | Intel I7 4790K@ 4GHz | 24GB Crucial ballistix sport 1600MHz DDR3 | ASUS Strix GTX1080Ti OC | Crucial mx 100 250Gb SSD | Crucial mx 300 520Gb SSD "Game disc"| Samsung 1Tb HDD |

                                      Comment

                                      Working...
                                      X